aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/aftp/Makefile22
-rw-r--r--emulators/aftp/distinfo1
-rw-r--r--emulators/aftp/files/aftp.186
-rw-r--r--emulators/aftp/files/patch-aa39
-rw-r--r--emulators/aftp/files/patch-ab108
-rw-r--r--emulators/aftp/pkg-comment1
-rw-r--r--emulators/aftp/pkg-descr12
-rw-r--r--emulators/aftp/pkg-plist2
8 files changed, 271 insertions, 0 deletions
diff --git a/emulators/aftp/Makefile b/emulators/aftp/Makefile
new file mode 100644
index 000000000000..f9c89084cbcf
--- /dev/null
+++ b/emulators/aftp/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: aftp
+# Version required: 1.0
+# Date created: 18th Febuary 1997
+# Whom: Joel Sutton <suttonj@interconnect.com.au>
+#
+# $Id$
+#
+
+DISTNAME= aftp
+PKGNAME= aftp-1.0
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.apple.asimov.net/pub/apple_II/incoming/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= suttonj@interconnect.com.au
+
+MAN1= aftp.1
+
+post-install:
+ ${INSTALL_MAN} ${FILESDIR}/aftp.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/emulators/aftp/distinfo b/emulators/aftp/distinfo
new file mode 100644
index 000000000000..f966d8e0fe92
--- /dev/null
+++ b/emulators/aftp/distinfo
@@ -0,0 +1 @@
+MD5 (aftp.tgz) = 65badcfefbcbb7f70d968b26cab1b9e4
diff --git a/emulators/aftp/files/aftp.1 b/emulators/aftp/files/aftp.1
new file mode 100644
index 000000000000..0821418007c5
--- /dev/null
+++ b/emulators/aftp/files/aftp.1
@@ -0,0 +1,86 @@
+.TH aftp 1 "21st January, 1997" "Version 1.0p1"
+.SH NAME
+\fBaftp\fP - Transfer files to/from Apple II disk images.
+.SH SYNOPSIS
+.IP "aftp"
+\fB[-poirh]\fP \fIdisk image ... \fP
+.LP
+.SH DESCRIPTION
+\fBaftp(1)\fP manipulates and browses Apple II disk images. It supports
+both Apple ][ DOS 3.3, ProDOS and XGS images. Both binary floppy images
+(.IIE) and hard disk volume (.HDV) images are also supported.
+.SH OPTIONS
+.IP "\fB-p\fP"
+use a Prodos filesystem.
+.IP "\fB-o\fP"
+use a Prodos ordered image.
+.IP "\fB-i\fP"
+use an XGS image file.
+.IP "\fB-r\fP"
+load images as read-only.
+.IP "\fB-h\fP"
+display aftp help.
+.SH NOTES
+.LP
+When invoked with a single disk image filename as the first parameter,
+aftp operates in interactive mode and all of the interactive commands
+are available. Specifing multiple disk images will display the root
+directory of each image and then terminate without entering
+interactive mode.
+.sp
+If you have ever used the unix \fBftp(1)\fP command, the \fBaftp(1)\fP
+commands will be very familiar. Interactive commands are:
+.IP "\fBdir\fP"
+display disk image directory.
+.IP "\fBls\fP"
+alias for the dir command.
+.IP "\fBget\fP \fI[file]\fP"
+get a file from the disk image.
+.IP "\fBput\fP \fI[file]\fP"
+put a file in the disk image.
+.IP "\fBdel\fP \fI[file]\fP"
+delete a file from the disk image.
+.IP "\fBcd\fP \fI[dir]\fP"
+change the current disk image directory.
+.IP "\fBtext\fP"
+set text mode.
+.IP "\fBbinary\fP"
+set binary mode.
+.IP "\fBhelp\fP"
+display help.
+.IP "\fBdump\fP"
+display a hex dump of the disk image.
+.IP "\fB!\fP\fIcommand\fP"
+shell escape.
+.IP "\fBquit\fP"
+exit the program.
+.LP
+When putting files in disk images, the following default attributes
+will be used depending on whether you are transferring in binary or
+text mode:
+.sp
+.nf
+DOS, Text File type: T
+DOS, Binary File type: B
+ProDOS, Text File type: TXT, SubType: R=0
+ProDOS, Binary File type: BIN, SubType: A$=2000
+.LP
+.SH BUGS
+File extentions are not properly recognised. To correct this problem
+use a command line option to specify the type of disk image you are
+accessing.
+.sp
+There is bound to be other bugs so be sure to backup your disk images
+just in case.
+.sp
+Bug reports can be sent to Andru Luvisi <luvisi@andru.sonoma.edu>.
+.SH AUTHOR
+Written by Galen C. Hunt <gchunt@cc.dixie.edu>
+.br
+Ported to UNIX by Andru Luvisi <luvisi@andru.sonoma.edu>
+.br
+Man page by Joel Sutton <suttonj@interconnect.com.au>
+.sp
+This man page is based on the original README included with aftp.
+.SH COPYRIGHT
+Released into the public domain with no warranties - 13 Jun 1994 Release 1.0
diff --git a/emulators/aftp/files/patch-aa b/emulators/aftp/files/patch-aa
new file mode 100644
index 000000000000..b31229050322
--- /dev/null
+++ b/emulators/aftp/files/patch-aa
@@ -0,0 +1,39 @@
+*** Makefile.orig Tue Jan 7 04:58:59 1997
+--- Makefile Sun May 18 01:48:32 1997
+***************
+*** 1,11 ****
+
+! OBJS=aftp.o pro.o dos.o
+
+ aftp: $(OBJS)
+! gcc -o aftp $(OBJS)
+
+ .c.o:
+! gcc -c $<
+
+ clean:
+ rm -f $(OBJS) aftp
+--- 1,23 ----
++ # AFTP Version 1.0
++ # Makefile updated 20th Jan, 1996
+
+! OBJS= aftp.o pro.o dos.o
+! #CC_OPTS= -DDIRECTORY_COMMANDS
+! CC= gcc ${CC_OPTS}
+! INSTALL= install -c
+! INSTALL_BIN= ${INSTALL} -s -o bin -g bin
+! PREFIX?= /usr/local
+!
+! all: aftp
+
+ aftp: $(OBJS)
+! ${CC} -o aftp $(OBJS)
+
+ .c.o:
+! ${CC} -c $<
+!
+! install: all
+! ${INSTALL_BIN} aftp ${PREFIX}/bin/
+
+ clean:
+ rm -f $(OBJS) aftp
diff --git a/emulators/aftp/files/patch-ab b/emulators/aftp/files/patch-ab
new file mode 100644
index 000000000000..061e93a29129
--- /dev/null
+++ b/emulators/aftp/files/patch-ab
@@ -0,0 +1,108 @@
+diff -rc aftp/aftp.c aftp-1.01a/aftp.c
+*** aftp.c Mon Jan 6 22:19:13 1997
+--- aftp.c Tue Jan 21 00:49:56 1997
+***************
+*** 283,299 ****
+
+ static void print_help(void)
+ {
+! printf("Command:\n");
+! printf(" aftp [options] {input_disk_files}\n");
+ printf("Options:\n");
+ printf(" -p use a (P)rodos filesystem.\n");
+ printf(" -o use a prodos (O)rdered image.\n");
+ printf(" -i use an xgs image file.\n");
+! printf(" -d Load images as read-only.\n");
+ printf(" -? Display aftp help.\n");
+- printf("Summary:\n");
+- printf(" Ftp like interface to dsk, do, po, and img files.\n");
+- printf(" Defaults to Dos 3.3 filesystem on a dsk disk.\n");
+ exit(1);
+ }
+
+--- 283,296 ----
+
+ static void print_help(void)
+ {
+! printf("useage:\n");
+! printf(" aftp [options] <input_disk_files>\n");
+ printf("Options:\n");
+ printf(" -p use a (P)rodos filesystem.\n");
+ printf(" -o use a prodos (O)rdered image.\n");
+ printf(" -i use an xgs image file.\n");
+! printf(" -r Load images as read-only.\n");
+ printf(" -? Display aftp help.\n");
+ exit(1);
+ }
+
+***************
+*** 327,332 ****
+--- 324,330 ----
+ read_only = !read_only;
+ break;
+ case '?':
++ case 'h':
+ print_help();
+ break;
+ default:
+***************
+*** 373,378 ****
+--- 371,377 ----
+ ;
+ *p = '\0';
+ system(cmd + 1);
++ printf("\n") ;
+ continue;
+ }
+ for (; *p && !isspace(*p); p++)
+***************
+*** 386,392 ****
+ *p = '\0';
+ if (!*cmd)
+ continue;
+! if (!strcmp(cmd, "dir"))
+ {
+ strcpy(remot, arg);
+ (*d->os->name)(remot, sizeof(remot));
+--- 385,391 ----
+ *p = '\0';
+ if (!*cmd)
+ continue;
+! if (!strcmp(cmd, "dir") || !strcmp(cmd, "ls"))
+ {
+ strcpy(remot, arg);
+ (*d->os->name)(remot, sizeof(remot));
+***************
+*** 503,508 ****
+--- 502,508 ----
+ else if (!strcmp(cmd, "help") || !strcmp(cmd, "?"))
+ {
+ printf("dir Display disk image directory.\n");
++ printf("ls Alias for the dir command.\n");
+ printf("get [file] Get a file from disk image.\n");
+ printf("put [file] Put a file on disk image.\n");
+ printf("del [file] Delete a file from disk image.\n");
+***************
+*** 511,520 ****
+ printf("mkdir [dir] Create a disk image directory.\n");
+ printf("rmdir [dir] Remove a disk image directory.\n");
+ #endif
+ printf("text Set text mode.\n");
+ printf("binary Set binary mode.\n");
+ printf("help Display help.\n");
+! printf("!dos command Execute a dos command.\n");
+ printf("quit Quit Program.\n");
+ }
+ else
+--- 511,521 ----
+ printf("mkdir [dir] Create a disk image directory.\n");
+ printf("rmdir [dir] Remove a disk image directory.\n");
+ #endif
++ printf("dump Display a hex dump of the disk image.\n") ;
+ printf("text Set text mode.\n");
+ printf("binary Set binary mode.\n");
+ printf("help Display help.\n");
+! printf("!command Shell escape.\n");
+ printf("quit Quit Program.\n");
+ }
+ else
diff --git a/emulators/aftp/pkg-comment b/emulators/aftp/pkg-comment
new file mode 100644
index 000000000000..c005af46ad97
--- /dev/null
+++ b/emulators/aftp/pkg-comment
@@ -0,0 +1 @@
+A ftp-like shell for accessing Apple II disk images.
diff --git a/emulators/aftp/pkg-descr b/emulators/aftp/pkg-descr
new file mode 100644
index 000000000000..a048223db3df
--- /dev/null
+++ b/emulators/aftp/pkg-descr
@@ -0,0 +1,12 @@
+aftp manipulates and browses Apple II disk images. It
+supports both Apple DOS 3.3, ProDOS and XGS images.
+Both binary floppy images (.IIE) and hard disk volume
+(.HDV) images are also supported.
+
+This version contains my patches and man page but nothing significant
+has changed since Andru Luvisi released it at the end of 1996.
+
+Share and enjoy,
+
+Joel...
+suttonj@interconnect.com.au
diff --git a/emulators/aftp/pkg-plist b/emulators/aftp/pkg-plist
new file mode 100644
index 000000000000..11826c1a83e0
--- /dev/null
+++ b/emulators/aftp/pkg-plist
@@ -0,0 +1,2 @@
+bin/aftp
+man/man1/aftp.1.gz