aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/gtk-aluminumalloy-cryogenic-theme/Makefile1
-rw-r--r--x11-themes/gtk-aluminumalloy-smog-theme/Makefile1
-rw-r--r--x11-themes/gtk-aluminumalloy-toxic-theme/Makefile1
-rw-r--r--x11-themes/gtk-aluminumalloy-volcanic-theme/Makefile13
-rw-r--r--x11-themes/gtk-aluminumalloy-volcanic-theme/pkg-descr6
-rw-r--r--x11-themes/metacity-aluminumalloy-cryogenic-theme/Makefile1
-rw-r--r--x11-themes/metacity-aluminumalloy-smog-theme/Makefile1
-rw-r--r--x11-themes/metacity-aluminumalloy-toxic-theme/Makefile1
-rw-r--r--x11-themes/metacity-aluminumalloy-volcanic-theme/Makefile1
9 files changed, 8 insertions, 18 deletions
diff --git a/x11-themes/gtk-aluminumalloy-cryogenic-theme/Makefile b/x11-themes/gtk-aluminumalloy-cryogenic-theme/Makefile
index 69b36ffe935e..b9ad04052546 100644
--- a/x11-themes/gtk-aluminumalloy-cryogenic-theme/Makefile
+++ b/x11-themes/gtk-aluminumalloy-cryogenic-theme/Makefile
@@ -10,5 +10,4 @@ MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-volcanic-theme
DISTINFO_FILE= ${.CURDIR}/../gtk-aluminumalloy-cryogenic-theme/distinfo
PLIST= ${.CURDIR}/../gtk-aluminumalloy-cryogenic-theme/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/gtk-aluminumalloy-smog-theme/Makefile b/x11-themes/gtk-aluminumalloy-smog-theme/Makefile
index dd107f959206..9e073a6f9179 100644
--- a/x11-themes/gtk-aluminumalloy-smog-theme/Makefile
+++ b/x11-themes/gtk-aluminumalloy-smog-theme/Makefile
@@ -10,5 +10,4 @@ MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-volcanic-theme
DISTINFO_FILE= ${.CURDIR}/../gtk-aluminumalloy-smog-theme/distinfo
PLIST= ${.CURDIR}/../gtk-aluminumalloy-smog-theme/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/gtk-aluminumalloy-toxic-theme/Makefile b/x11-themes/gtk-aluminumalloy-toxic-theme/Makefile
index db90d31e9130..433df944781d 100644
--- a/x11-themes/gtk-aluminumalloy-toxic-theme/Makefile
+++ b/x11-themes/gtk-aluminumalloy-toxic-theme/Makefile
@@ -10,5 +10,4 @@ MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-volcanic-theme
DISTINFO_FILE= ${.CURDIR}/../gtk-aluminumalloy-toxic-theme/distinfo
PLIST= ${.CURDIR}/../gtk-aluminumalloy-toxic-theme/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/gtk-aluminumalloy-volcanic-theme/Makefile b/x11-themes/gtk-aluminumalloy-volcanic-theme/Makefile
index 96bd3cce5192..577a90dc1529 100644
--- a/x11-themes/gtk-aluminumalloy-volcanic-theme/Makefile
+++ b/x11-themes/gtk-aluminumalloy-volcanic-theme/Makefile
@@ -11,7 +11,7 @@ PKGNAMESUFFIX?= -${FLAVOR}-theme
DISTNAME= aa_${FLAVOR}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A port of wonderful MacOS X theme Aluminum Alloy, ${FLAVOR} flavor
+COMMENT= Port of Mac OS X theme Aluminum Alloy (${FLAVOR} flavor)
TYPE?= gtk
FLAVOR?= volcanic
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${THEME_NAME}
USE_BZIP2= yes
NO_BUILD= yes
-.if ${TYPE} == "gtk"
+.if ${TYPE} == gtk
THEME_DIR= ${PREFIX}/share/themes/${THEME_NAME}
PLIST_SUB+= GTK20="" METACITY="@comment "
USE_GNOME= gtk20
@@ -32,16 +32,15 @@ PLIST_SUB+= GTK20="@comment " METACITY=""
USE_GNOME= gnomehier
.endif
-NO_STAGE= yes
do-install:
- @${MKDIR} ${THEME_DIR}
+ @${MKDIR} ${STAGEDIR}${THEME_DIR}
.if ${TYPE} == "gtk"
cd ${WRKSRC} && ${FIND} gtk-2.0 -name '*[^~]' | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
- ${INSTALL_DATA} ${WRKSRC}/index.theme ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.theme ${STAGEDIR}${THEME_DIR}
.else
cd ${WRKSRC} && ${FIND} metacity-1 -name '*[^~]' | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.endif
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-aluminumalloy-volcanic-theme/pkg-descr b/x11-themes/gtk-aluminumalloy-volcanic-theme/pkg-descr
index 67bce23e313d..c59497b2a3f1 100644
--- a/x11-themes/gtk-aluminumalloy-volcanic-theme/pkg-descr
+++ b/x11-themes/gtk-aluminumalloy-volcanic-theme/pkg-descr
@@ -1,6 +1,4 @@
-This is a port the wonderful MacOS X theme Aluminum Alloy. Original theme by
-Max Rudberg (http://www.maxthemes.com).
+This is a port the wonderful Mac OS X theme Aluminum Alloy. Original theme
+created by Max Rudberg (http://www.maxrudberg.com/).
Theme comes in several flavors: volcanic, smog, cryogenic, toxic.
-
-WWW: http://www.users.monornet.hu/linux/
diff --git a/x11-themes/metacity-aluminumalloy-cryogenic-theme/Makefile b/x11-themes/metacity-aluminumalloy-cryogenic-theme/Makefile
index 1282f9732e9f..04772d3f41cf 100644
--- a/x11-themes/metacity-aluminumalloy-cryogenic-theme/Makefile
+++ b/x11-themes/metacity-aluminumalloy-cryogenic-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-cryogenic-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/metacity-aluminumalloy-smog-theme/Makefile b/x11-themes/metacity-aluminumalloy-smog-theme/Makefile
index 1abf7d2c11c0..42816821e107 100644
--- a/x11-themes/metacity-aluminumalloy-smog-theme/Makefile
+++ b/x11-themes/metacity-aluminumalloy-smog-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-smog-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/metacity-aluminumalloy-toxic-theme/Makefile b/x11-themes/metacity-aluminumalloy-toxic-theme/Makefile
index d36b9e1fc13e..8257d1549cdc 100644
--- a/x11-themes/metacity-aluminumalloy-toxic-theme/Makefile
+++ b/x11-themes/metacity-aluminumalloy-toxic-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-toxic-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/metacity-aluminumalloy-volcanic-theme/Makefile b/x11-themes/metacity-aluminumalloy-volcanic-theme/Makefile
index a4fb994844d3..e430eda53123 100644
--- a/x11-themes/metacity-aluminumalloy-volcanic-theme/Makefile
+++ b/x11-themes/metacity-aluminumalloy-volcanic-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-aluminumalloy-volcanic-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"