aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--palm/p5-Palm/Makefile30
-rw-r--r--palm/p5-Palm/distinfo1
-rw-r--r--palm/p5-Palm/pkg-comment1
-rw-r--r--palm/p5-Palm/pkg-descr15
-rw-r--r--palm/p5-Palm/pkg-plist11
5 files changed, 58 insertions, 0 deletions
diff --git a/palm/p5-Palm/Makefile b/palm/p5-Palm/Makefile
new file mode 100644
index 000000000000..8388ae7263e0
--- /dev/null
+++ b/palm/p5-Palm/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Palm
+# Date created: 29 April 2000
+# Whom: Andrew Arensburger <arensb@ooblick.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= p5-Palm
+PORTVERSION= 1.1.8
+CATEGORIES= palm perl5
+MASTER_SITES= http://www.ooblick.com/software/coldsync/
+
+MAINTAINER= arensb@ooblick.com
+
+USE_PERL5= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Palm::Address.3 \
+ Palm::Datebook.3 \
+ Palm::Mail.3 \
+ Palm::Memo.3 \
+ Palm::PDB.3 \
+ Palm::Raw.3 \
+ Palm::StdAppInfo.3 \
+ Palm::ToDo.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/palm/p5-Palm/distinfo b/palm/p5-Palm/distinfo
new file mode 100644
index 000000000000..241d510dcf5f
--- /dev/null
+++ b/palm/p5-Palm/distinfo
@@ -0,0 +1 @@
+MD5 (p5-Palm-1.1.8.tar.gz) = c1c8959964f588f1c9fb924dc4d96bea
diff --git a/palm/p5-Palm/pkg-comment b/palm/p5-Palm/pkg-comment
new file mode 100644
index 000000000000..6f410edb8946
--- /dev/null
+++ b/palm/p5-Palm/pkg-comment
@@ -0,0 +1 @@
+Perl 5 modules for reading and writing Palm database files
diff --git a/palm/p5-Palm/pkg-descr b/palm/p5-Palm/pkg-descr
new file mode 100644
index 000000000000..21f35132bdfd
--- /dev/null
+++ b/palm/p5-Palm/pkg-descr
@@ -0,0 +1,15 @@
+ This is a set of Perl 5 modules for reading, manipulating, and
+writing the .prc and .pdb database files used by PalmOS devices such
+as the PalmPilot.
+ It is fairly easy to extend the functionality of this package
+by writing parsers for any .pdb type that you like. This package
+includes sample modules to parse the databases created by the built-in
+applications (Address, Datebook, Mail, Memo, ToDo).
+
+ These modules were written to support ColdSync, a Palm
+synchronization tool for Unix. See details at
+
+WWW: http://www.ooblick.com/software/coldsync/
+
+- Andrew Arensburger
+arensb@ooblick.com
diff --git a/palm/p5-Palm/pkg-plist b/palm/p5-Palm/pkg-plist
new file mode 100644
index 000000000000..0a29e1bc308a
--- /dev/null
+++ b/palm/p5-Palm/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Palm/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Palm/Address.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/Datebook.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/Mail.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/Memo.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/PDB.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/Raw.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/StdAppInfo.pm
+lib/perl5/site_perl/%%PERL_VER%%/Palm/ToDo.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Palm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Palm