aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/elib-emacs/Makefile84
-rw-r--r--devel/elib-emacs/distinfo1
-rw-r--r--devel/elib-emacs/files/patch-aa22
-rw-r--r--devel/elib-emacs/files/patch-ab13
-rw-r--r--devel/elib-emacs/pkg-comment1
-rw-r--r--devel/elib-emacs/pkg-descr14
-rw-r--r--devel/elib-emacs/pkg-message.emacs194
-rw-r--r--devel/elib-emacs/pkg-plist33
-rw-r--r--devel/elib/Makefile84
-rw-r--r--devel/elib/distinfo1
-rw-r--r--devel/elib/files/patch-aa22
-rw-r--r--devel/elib/files/patch-ab13
-rw-r--r--devel/elib/pkg-comment1
-rw-r--r--devel/elib/pkg-descr14
-rw-r--r--devel/elib/pkg-message.emacs194
-rw-r--r--devel/elib/pkg-plist33
16 files changed, 344 insertions, 0 deletions
diff --git a/devel/elib-emacs/Makefile b/devel/elib-emacs/Makefile
new file mode 100644
index 000000000000..9dc5c8bb1dce
--- /dev/null
+++ b/devel/elib-emacs/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: Elib for GNU Emacs 19
+# Date created: 24 Feb 2000
+# Whom: OKAZAKI Tetsurou
+#
+# $FreeBSD$
+#
+
+PORTNAME= elib
+PORTVERSION= 1.0
+CATEGORIES= devel elisp
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= emacs
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER?= okazaki@FreeBSD.org
+
+# setupel filename
+PORT_SETUPEL= elib-startup.el
+# document install directory by install-doc target
+PORTDOCDIR= share/doc/elib
+
+# This is a master port.
+PORTCLASS?= master
+
+# emacs port setup
+.if (${PORTCLASS} == "master")
+EMACS_PORT_NAME= emacs
+.endif
+
+# target name for make build
+ALL_TARGET?= all
+
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
+ PORTDOCDIR=${PORTDOCDIR} \
+ PORT_SETUPEL=${PORT_SETUPEL}
+MAKE_ARGS+= EMACS="${EMACS_CMD} -q --no-site-file" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ MAKEINFO="makeinfo --no-split" \
+ MKDIR="${MKDIR}" \
+ prefix="${PREFIX}"
+
+.if defined(EMACS_PORT_NAME)
+.if ${EMACS_MAJOR_VER} <= 19
+INSTALL_LOADPATHSETUP= yes
+PKGMESSAGE= ${PKGDIR}/pkg-message.emacs19
+PLIST_SUB+= LOADPATHSETUP:=""
+.else
+PLIST_SUB+= LOADPATHSETUP:="@comment "
+.endif
+.else
+.BEGIN:
+ @${ECHO} "Error: Bad port."
+ @${ECHO} "You must define EMACS_PORT_NAME."
+ @${FALSE}
+.endif
+
+post-build:
+ @${ECHO} "(provide 'elib-startup)" >> ${WRKSRC}/${PORT_SETUPEL}
+
+post-install:
+.if defined(INSTALL_LOADPATHSETUP)
+ @${MAKE} setupel-install
+.endif
+.if !defined(NOPORTDOCS)
+ @${MAKE} doc-install
+.endif
+.if exists(${PKGMESSAGE})
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+doc-install:
+ ${MKDIR} ${PREFIX}/${PORTDOCDIR}
+ cd ${INSTALL_WRKSRC} && \
+ for i in ChangeLog NEWS README ; do \
+ ${INSTALL_DATA} $${i} ${PREFIX}/${PORTDOCDIR}/ ; \
+ done
+
+setupel-install:
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORT_SETUPEL} \
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/
+
+.include <bsd.port.post.mk>
diff --git a/devel/elib-emacs/distinfo b/devel/elib-emacs/distinfo
new file mode 100644
index 000000000000..b94d383aa71b
--- /dev/null
+++ b/devel/elib-emacs/distinfo
@@ -0,0 +1 @@
+MD5 (elib-1.0.tar.gz) = 7588759a973ce912359b60fb31e00edd
diff --git a/devel/elib-emacs/files/patch-aa b/devel/elib-emacs/files/patch-aa
new file mode 100644
index 000000000000..7fa161af1852
--- /dev/null
+++ b/devel/elib-emacs/files/patch-aa
@@ -0,0 +1,22 @@
+--- Makefile.orig Mon Dec 11 09:50:56 1995
++++ Makefile Sat Nov 4 03:07:26 2000
+@@ -61,16 +61,16 @@
+ install: all installdirs install-info
+ $(INSTALL_DATA) $(ELFILES) $(ELIBDIR)
+ $(INSTALL_DATA) $(ELCFILES) $(ELIBDIR)
+- @echo Please merge elib-startup.el into $(locallisppath)/default.el
++# @echo Please merge elib-startup.el into $(locallisppath)/default.el
+
+ installdirs:
+- -mkdir $(ELIBDIR)
++ -${MKDIR} $(ELIBDIR)
+
+ install-info: elib.info
+ $(INSTALL_DATA) elib.info* $(infodir)
+ if $(SHELL) -c 'install-info --version' \
+ >/dev/null 2>&1; then \
+- install-info --infodir=$(infodir) elib.info; \
++ install-info --info-dir=$(infodir) elib.info; \
+ else true; fi
+
+ clean:
diff --git a/devel/elib-emacs/files/patch-ab b/devel/elib-emacs/files/patch-ab
new file mode 100644
index 000000000000..4f8c3fb89f07
--- /dev/null
+++ b/devel/elib-emacs/files/patch-ab
@@ -0,0 +1,13 @@
+--- elib.texi~ Mon Dec 11 09:50:55 1995
++++ elib.texi Thu Feb 24 15:29:26 2000
+@@ -21,6 +21,10 @@
+ @comment the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
+ @setfilename elib.info
+ @settitle Elib - The Emacs Lisp Library
++@dircategory The Emacs editor and associated tools
++@direntry
++* ELIB: (elib). The Emacs Lisp Library.
++@end direntry
+ @setchapternewpage odd
+ @syncodeindex fn cp
+
diff --git a/devel/elib-emacs/pkg-comment b/devel/elib-emacs/pkg-comment
new file mode 100644
index 000000000000..1c80a66ce0ad
--- /dev/null
+++ b/devel/elib-emacs/pkg-comment
@@ -0,0 +1 @@
+Collection of useful routines for Emacs lisp programs
diff --git a/devel/elib-emacs/pkg-descr b/devel/elib-emacs/pkg-descr
new file mode 100644
index 000000000000..e1d707615440
--- /dev/null
+++ b/devel/elib-emacs/pkg-descr
@@ -0,0 +1,14 @@
+Elib, the GNU Emacs Lisp Library, is a collection of useful routines
+for Emacs lisp programs which don't have to be reinvented each time
+a new program is written.
+
+Elib provides features of:
+ - container data structures (queues, stacks, AVL trees, etc)
+ - string handling functions missing in standard Emacs
+ - minibuffer handling functions missing in standard Emacs
+ - routines for handling lists of so-called cookies in a buffer.
+
+ELIB is installed into the following directory tree:
+ PREFIX/share/emacs/site-lisp/elib/ --- elib
+
+WWW: http://www.gnu.org/software/elib/elib.html
diff --git a/devel/elib-emacs/pkg-message.emacs19 b/devel/elib-emacs/pkg-message.emacs19
new file mode 100644
index 000000000000..391bdd3c3b8e
--- /dev/null
+++ b/devel/elib-emacs/pkg-message.emacs19
@@ -0,0 +1,4 @@
+To use elib, put the following setup into your ~/.emacs:
+
+ (require 'elib-startup)
+
diff --git a/devel/elib-emacs/pkg-plist b/devel/elib-emacs/pkg-plist
new file mode 100644
index 000000000000..bbb7eb0aac89
--- /dev/null
+++ b/devel/elib-emacs/pkg-plist
@@ -0,0 +1,33 @@
+%%EMACS_LIBDIR%%/site-lisp/elib/avltree.el
+%%EMACS_LIBDIR%%/site-lisp/elib/avltree.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/bintree.el
+%%EMACS_LIBDIR%%/site-lisp/elib/bintree.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/cookie.el
+%%EMACS_LIBDIR%%/site-lisp/elib/cookie.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/dll-debug.el
+%%EMACS_LIBDIR%%/site-lisp/elib/dll-debug.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/dll.el
+%%EMACS_LIBDIR%%/site-lisp/elib/dll.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/elib-node.el
+%%EMACS_LIBDIR%%/site-lisp/elib/elib-node.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-f.el
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-f.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-m.el
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-m.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/read.el
+%%EMACS_LIBDIR%%/site-lisp/elib/read.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-f.el
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-f.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-m.el
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-m.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/string.el
+%%EMACS_LIBDIR%%/site-lisp/elib/string.elc
+%%LOADPATHSETUP:%%%%EMACS_LIBDIR_WITH_VER%%/site-lisp/%%PORT_SETUPEL%%
+@dirrm %%EMACS_LIBDIR%%/site-lisp/elib
+%%PORTDOCDIR%%/ChangeLog
+%%PORTDOCDIR%%/NEWS
+%%PORTDOCDIR%%/README
+@dirrm %%PORTDOCDIR%%
+@unexec install-info --delete %D/info/elib.info %D/info/dir
+info/elib.info
+@exec install-info %D/info/elib.info %D/info/dir
diff --git a/devel/elib/Makefile b/devel/elib/Makefile
new file mode 100644
index 000000000000..9dc5c8bb1dce
--- /dev/null
+++ b/devel/elib/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: Elib for GNU Emacs 19
+# Date created: 24 Feb 2000
+# Whom: OKAZAKI Tetsurou
+#
+# $FreeBSD$
+#
+
+PORTNAME= elib
+PORTVERSION= 1.0
+CATEGORIES= devel elisp
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= emacs
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER?= okazaki@FreeBSD.org
+
+# setupel filename
+PORT_SETUPEL= elib-startup.el
+# document install directory by install-doc target
+PORTDOCDIR= share/doc/elib
+
+# This is a master port.
+PORTCLASS?= master
+
+# emacs port setup
+.if (${PORTCLASS} == "master")
+EMACS_PORT_NAME= emacs
+.endif
+
+# target name for make build
+ALL_TARGET?= all
+
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
+ PORTDOCDIR=${PORTDOCDIR} \
+ PORT_SETUPEL=${PORT_SETUPEL}
+MAKE_ARGS+= EMACS="${EMACS_CMD} -q --no-site-file" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ MAKEINFO="makeinfo --no-split" \
+ MKDIR="${MKDIR}" \
+ prefix="${PREFIX}"
+
+.if defined(EMACS_PORT_NAME)
+.if ${EMACS_MAJOR_VER} <= 19
+INSTALL_LOADPATHSETUP= yes
+PKGMESSAGE= ${PKGDIR}/pkg-message.emacs19
+PLIST_SUB+= LOADPATHSETUP:=""
+.else
+PLIST_SUB+= LOADPATHSETUP:="@comment "
+.endif
+.else
+.BEGIN:
+ @${ECHO} "Error: Bad port."
+ @${ECHO} "You must define EMACS_PORT_NAME."
+ @${FALSE}
+.endif
+
+post-build:
+ @${ECHO} "(provide 'elib-startup)" >> ${WRKSRC}/${PORT_SETUPEL}
+
+post-install:
+.if defined(INSTALL_LOADPATHSETUP)
+ @${MAKE} setupel-install
+.endif
+.if !defined(NOPORTDOCS)
+ @${MAKE} doc-install
+.endif
+.if exists(${PKGMESSAGE})
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+doc-install:
+ ${MKDIR} ${PREFIX}/${PORTDOCDIR}
+ cd ${INSTALL_WRKSRC} && \
+ for i in ChangeLog NEWS README ; do \
+ ${INSTALL_DATA} $${i} ${PREFIX}/${PORTDOCDIR}/ ; \
+ done
+
+setupel-install:
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORT_SETUPEL} \
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/
+
+.include <bsd.port.post.mk>
diff --git a/devel/elib/distinfo b/devel/elib/distinfo
new file mode 100644
index 000000000000..b94d383aa71b
--- /dev/null
+++ b/devel/elib/distinfo
@@ -0,0 +1 @@
+MD5 (elib-1.0.tar.gz) = 7588759a973ce912359b60fb31e00edd
diff --git a/devel/elib/files/patch-aa b/devel/elib/files/patch-aa
new file mode 100644
index 000000000000..7fa161af1852
--- /dev/null
+++ b/devel/elib/files/patch-aa
@@ -0,0 +1,22 @@
+--- Makefile.orig Mon Dec 11 09:50:56 1995
++++ Makefile Sat Nov 4 03:07:26 2000
+@@ -61,16 +61,16 @@
+ install: all installdirs install-info
+ $(INSTALL_DATA) $(ELFILES) $(ELIBDIR)
+ $(INSTALL_DATA) $(ELCFILES) $(ELIBDIR)
+- @echo Please merge elib-startup.el into $(locallisppath)/default.el
++# @echo Please merge elib-startup.el into $(locallisppath)/default.el
+
+ installdirs:
+- -mkdir $(ELIBDIR)
++ -${MKDIR} $(ELIBDIR)
+
+ install-info: elib.info
+ $(INSTALL_DATA) elib.info* $(infodir)
+ if $(SHELL) -c 'install-info --version' \
+ >/dev/null 2>&1; then \
+- install-info --infodir=$(infodir) elib.info; \
++ install-info --info-dir=$(infodir) elib.info; \
+ else true; fi
+
+ clean:
diff --git a/devel/elib/files/patch-ab b/devel/elib/files/patch-ab
new file mode 100644
index 000000000000..4f8c3fb89f07
--- /dev/null
+++ b/devel/elib/files/patch-ab
@@ -0,0 +1,13 @@
+--- elib.texi~ Mon Dec 11 09:50:55 1995
++++ elib.texi Thu Feb 24 15:29:26 2000
+@@ -21,6 +21,10 @@
+ @comment the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
+ @setfilename elib.info
+ @settitle Elib - The Emacs Lisp Library
++@dircategory The Emacs editor and associated tools
++@direntry
++* ELIB: (elib). The Emacs Lisp Library.
++@end direntry
+ @setchapternewpage odd
+ @syncodeindex fn cp
+
diff --git a/devel/elib/pkg-comment b/devel/elib/pkg-comment
new file mode 100644
index 000000000000..1c80a66ce0ad
--- /dev/null
+++ b/devel/elib/pkg-comment
@@ -0,0 +1 @@
+Collection of useful routines for Emacs lisp programs
diff --git a/devel/elib/pkg-descr b/devel/elib/pkg-descr
new file mode 100644
index 000000000000..e1d707615440
--- /dev/null
+++ b/devel/elib/pkg-descr
@@ -0,0 +1,14 @@
+Elib, the GNU Emacs Lisp Library, is a collection of useful routines
+for Emacs lisp programs which don't have to be reinvented each time
+a new program is written.
+
+Elib provides features of:
+ - container data structures (queues, stacks, AVL trees, etc)
+ - string handling functions missing in standard Emacs
+ - minibuffer handling functions missing in standard Emacs
+ - routines for handling lists of so-called cookies in a buffer.
+
+ELIB is installed into the following directory tree:
+ PREFIX/share/emacs/site-lisp/elib/ --- elib
+
+WWW: http://www.gnu.org/software/elib/elib.html
diff --git a/devel/elib/pkg-message.emacs19 b/devel/elib/pkg-message.emacs19
new file mode 100644
index 000000000000..391bdd3c3b8e
--- /dev/null
+++ b/devel/elib/pkg-message.emacs19
@@ -0,0 +1,4 @@
+To use elib, put the following setup into your ~/.emacs:
+
+ (require 'elib-startup)
+
diff --git a/devel/elib/pkg-plist b/devel/elib/pkg-plist
new file mode 100644
index 000000000000..bbb7eb0aac89
--- /dev/null
+++ b/devel/elib/pkg-plist
@@ -0,0 +1,33 @@
+%%EMACS_LIBDIR%%/site-lisp/elib/avltree.el
+%%EMACS_LIBDIR%%/site-lisp/elib/avltree.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/bintree.el
+%%EMACS_LIBDIR%%/site-lisp/elib/bintree.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/cookie.el
+%%EMACS_LIBDIR%%/site-lisp/elib/cookie.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/dll-debug.el
+%%EMACS_LIBDIR%%/site-lisp/elib/dll-debug.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/dll.el
+%%EMACS_LIBDIR%%/site-lisp/elib/dll.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/elib-node.el
+%%EMACS_LIBDIR%%/site-lisp/elib/elib-node.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-f.el
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-f.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-m.el
+%%EMACS_LIBDIR%%/site-lisp/elib/queue-m.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/read.el
+%%EMACS_LIBDIR%%/site-lisp/elib/read.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-f.el
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-f.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-m.el
+%%EMACS_LIBDIR%%/site-lisp/elib/stack-m.elc
+%%EMACS_LIBDIR%%/site-lisp/elib/string.el
+%%EMACS_LIBDIR%%/site-lisp/elib/string.elc
+%%LOADPATHSETUP:%%%%EMACS_LIBDIR_WITH_VER%%/site-lisp/%%PORT_SETUPEL%%
+@dirrm %%EMACS_LIBDIR%%/site-lisp/elib
+%%PORTDOCDIR%%/ChangeLog
+%%PORTDOCDIR%%/NEWS
+%%PORTDOCDIR%%/README
+@dirrm %%PORTDOCDIR%%
+@unexec install-info --delete %D/info/elib.info %D/info/dir
+info/elib.info
+@exec install-info %D/info/elib.info %D/info/dir