aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/dnsmasq/Makefile5
-rw-r--r--dns/dnsmasq/distinfo4
-rw-r--r--dns/dnsmasq/files/dnsmasq.sh29
-rw-r--r--dns/dnsmasq/pkg-descr22
4 files changed, 47 insertions, 13 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index baae252ce2da..e3489845564b 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dnsmasq
-PORTVERSION= 2.7
+PORTVERSION= 2.9
CATEGORIES= dns
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
@@ -16,7 +16,7 @@ COMMENT= A caching DNS forwarder
USE_REINPLACE= yes
MAN8= dnsmasq.8
-PLIST_FILES= sbin/dnsmasq etc/dnsmasq.conf.example
+PLIST_FILES= sbin/dnsmasq etc/dnsmasq.conf.example etc/rc.d/dnsmasq.sh
post-patch:
@${REINPLACE_CMD} -e \
@@ -26,6 +26,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc/dnsmasq.conf.example
+ ${INSTALL_SCRIPT} files/dnsmasq.sh ${PREFIX}/etc/rc.d/dnsmasq.sh
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/dns/dnsmasq/distinfo b/dns/dnsmasq/distinfo
index e814d37876f9..060dccf7a427 100644
--- a/dns/dnsmasq/distinfo
+++ b/dns/dnsmasq/distinfo
@@ -1,2 +1,2 @@
-MD5 (dnsmasq-2.7.tar.gz) = f526e81e11627177e9949b72d5424f7a
-SIZE (dnsmasq-2.7.tar.gz) = 99948
+MD5 (dnsmasq-2.9.tar.gz) = d3f365eaba2f60b115c97116d382e98c
+SIZE (dnsmasq-2.9.tar.gz) = 104552
diff --git a/dns/dnsmasq/files/dnsmasq.sh b/dns/dnsmasq/files/dnsmasq.sh
new file mode 100644
index 000000000000..529c437715eb
--- /dev/null
+++ b/dns/dnsmasq/files/dnsmasq.sh
@@ -0,0 +1,29 @@
+#! /bin/sh
+#
+#
+# PROVIDE: dnsmasq
+# REQUIRE: DAEMON NETWORKING SERVERS
+# KEYWORD: FreeBSD
+#
+# Add the following line to /etc/rc.conf to enable dnsmasq:
+#
+# dnsmasq_enable="YES"
+#
+
+# override these variables in /etc/rc.conf
+dnsmasq_enable=NO
+
+
+. /etc/rc.subr
+
+name=dnsmasq
+rcvar=$(set_rcvar)
+
+command=/usr/local/sbin/${name}
+pidfile=/var/run/${name}.pid
+required_files=${dnsmasq_conf}
+#start_precmd=${name}_precmd
+
+load_rc_config ${name}
+run_rc_command "$1"
+
diff --git a/dns/dnsmasq/pkg-descr b/dns/dnsmasq/pkg-descr
index 25b730f729ab..aacd9a4caded 100644
--- a/dns/dnsmasq/pkg-descr
+++ b/dns/dnsmasq/pkg-descr
@@ -1,13 +1,17 @@
-Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server. It is designed to provide DNS
-and, optionally, DHCP, to a small network. It can serve the names of local machines which are not in
-the global DNS. The DHCP server integrates with the DNS server and allows machines with DHCP-allocated
-addresses to appear in the DNS with names configured either in each host or in a central configuration
-file. Dnsmasq supports static and dynamic DHCP leases and BOOTP for network booting of diskless
-machines.
+Dnsmasq is lightweight, easy to configure DNS forwarder and
+DHCP server. It is designed to provide DNS and, optionally,
+DHCP, to a small network. It can serve the names of local
+machines which are not in the global DNS. The DHCP server
+integrates with the DNS server and allows machines with
+DHCP-allocated addresses to appear in the DNS with names
+configured either in each host or in a central configuration
+file. Dnsmasq supports static and dynamic DHCP leases and BOOTP
+for network booting of diskless machines.
-Dnsmasq is targeted at home networks using NAT and connected to the internet via a modem, cable-modem
-or ADSL connection but would be a good choice for any small network where low resource use and ease of
-configuration are important.
+Dnsmasq is targeted at home networks using NAT and connected to
+the internet via a modem, cable-modem or ADSL connection but
+would be a good choice for any small network where low resource
+use and ease of configuration are important.
WWW: http://www.thekelleys.org.uk/dnsmasq/doc.html