aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/weather/Makefile34
-rw-r--r--astro/weather/distinfo3
-rw-r--r--astro/weather/pkg-descr13
-rw-r--r--astro/weather/pkg-plist4
5 files changed, 55 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index e99985e9afb8..ecfb58de444d 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -98,6 +98,7 @@
SUBDIR += tkgeomap
SUBDIR += viking
SUBDIR += wcslib
+ SUBDIR += weather
SUBDIR += weatherget
SUBDIR += weatherspect
SUBDIR += wmglobe
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
new file mode 100644
index 000000000000..eb558de7f126
--- /dev/null
+++ b/astro/weather/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: weather
+# Date created: 2010-05-25
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weather
+PORTVERSION= 1.5
+CATEGORIES= astro python
+MASTER_SITES= http://fungi.yuggoth.org/weather/src/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= An utility to provide current weather conditions and forecasts
+
+USE_PYTHON= -2.6
+
+MAN1= weather.1
+MAN5= weatherrc.5
+
+post-patch:
+ @${REINPLACE_CMD} -e '1 s/python/${PYTHON_VERSION}/' ${WRKSRC}/weather
+
+do-build:
+ @${WRKSRC}/weather --version
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/weather ${PREFIX}/bin/
+ @${INSTALL_DATA} ${WRKSRC}/weather.py ${WRKSRC}/weather.pyc ${PYTHON_SITELIBDIR}/
+ @${INSTALL_MAN} ${WRKSRC}/weather.1 ${MANPREFIX}/man/man1/
+ @${INSTALL_MAN} ${WRKSRC}/weatherrc.5 ${MANPREFIX}/man/man5/
+
+.include <bsd.port.mk>
diff --git a/astro/weather/distinfo b/astro/weather/distinfo
new file mode 100644
index 000000000000..287969909954
--- /dev/null
+++ b/astro/weather/distinfo
@@ -0,0 +1,3 @@
+MD5 (weather-1.5.tar.gz) = 87c7f59bd34a2f62e38a11b81160cd6b
+SHA256 (weather-1.5.tar.gz) = 4a88936ada82a7027d97e33edc9aea50222ee5a3092566bf82fc77952222711b
+SIZE (weather-1.5.tar.gz) = 16533
diff --git a/astro/weather/pkg-descr b/astro/weather/pkg-descr
new file mode 100644
index 000000000000..411622d9e2c9
--- /dev/null
+++ b/astro/weather/pkg-descr
@@ -0,0 +1,13 @@
+This command-line utility is intended to provide quick access to current
+weather conditions and forecasts. Presently, it is capable of returning data
+for localities throughout the USA by retrieving and formatting decoded METARs
+(Meteorological Aerodrome Reports) from NOAA (the USA National Oceanic and
+Atmospheric Administration) and forecasts from NWS (the USA National Weather
+Service). The tool is written to function in the same spirit as other command-
+line informational utilities like cal(1), calendar(1) and dict(1). It can
+retrieve arbitrary weather data via specific command-line switches (station
+ID, city, state), or aliases can be configured system wide and on a per-user
+basis. It can be freely used and redistributed under the terms of a BSD-like
+License.
+
+WWW: http://fungi.yuggoth.org/weather/
diff --git a/astro/weather/pkg-plist b/astro/weather/pkg-plist
new file mode 100644
index 000000000000..acd49c389e08
--- /dev/null
+++ b/astro/weather/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/weather
+%%PYTHON_SITELIBDIR%%/weather.py
+%%PYTHON_SITELIBDIR%%/weather.pyc