aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/net-snmp/Makefile4
-rw-r--r--security/botan110/Makefile2
-rw-r--r--security/dsniff/Makefile6
-rw-r--r--security/libressl-devel/Makefile3
-rw-r--r--security/libressl/Makefile3
-rw-r--r--security/openca-tools-forked/Makefile2
-rw-r--r--security/p5-Crypt-OpenSSL-CA/Makefile2
-rw-r--r--security/p5-OpenCA-OpenSSL/Makefile4
-rw-r--r--security/pks/Makefile4
-rw-r--r--security/racoon2/Makefile2
-rw-r--r--security/softhsm2/Makefile2
-rw-r--r--security/sslscan/Makefile4
-rw-r--r--sysutils/cfengine310/Makefile4
-rw-r--r--sysutils/cfengine311/Makefile4
-rw-r--r--sysutils/ipmitool/Makefile2
-rw-r--r--textproc/libucl/Makefile2
-rw-r--r--www/envoy/Makefile2
-rw-r--r--www/squid3/Makefile2
18 files changed, 26 insertions, 28 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 082a88c44798..284d1b5fbd18 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -74,7 +74,7 @@ TLS_CONFIGURE_ON= --with-security-modules=tsm --with-transports=TLSTCP,DTLSUDP
.include <bsd.port.options.mk>
-.if (${OSVERSION} >= 1200085 || ${SSL_DEFAULT:Mopenssl111*})
+.if (${OSVERSION} >= 1200085 || ${SSL_DEFAULT:Mopenssl*})
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-openssl11
.endif
@@ -249,7 +249,7 @@ post-patch:
${WRKSRC}/agent/mibgroup/host/hr_system.c
@${REINPLACE_CMD} -E -e 's|return pci_lookup_name|disabled broken|g' \
${WRKSRC}/configure
-.if (${OSVERSION} >= 1200085 || ${SSL_DEFAULT:Mopenssl111*})
+.if (${OSVERSION} >= 1200085 || ${SSL_DEFAULT:Mopenssl*})
@${REINPLACE_CMD} -E -e 's|SSL_library_init|OPENSSL_init_ssl|g' \
${WRKSRC}/configure
.endif
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 517182e907d6..e0337452b2b6 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -42,7 +42,7 @@ GMP_CONFIGURE_WITH= gnump
.include <bsd.port.pre.mk>
-.if (${OPSYS} == FreeBSD && ${OSVERSION} > 1200084) || ${SSL_DEFAULT:Mopenssl111} || ${SSL_DEFAULT:M*-devel}
+.if (${OPSYS} == FreeBSD && ${OSVERSION} > 1200084) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:M*-devel}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-openssl11
.endif
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 3c33d357cf1c..8f705f5734ed 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -39,7 +39,7 @@ X11_CONFIGURE_WITH=x
USES+= ssl
.endif
-.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085) || ${SSL_DEFAULT} == openssl111
+.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085) || ${SSL_DEFAULT} == openssl
# Requires LibreSSL for old SSL interface
BUILD_DEPENDS+= ${NONEXISTENT}:security/libressl:stage
CPPFLAGS+= -nostdinc -I/usr/include -I${WRKDIR}/libressl/include
@@ -52,8 +52,8 @@ pre-configure:
@cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${PREFIX} \
&& ${FIND} -E . ! -name *.so\* | ${CPIO} -dump ${WRKDIR}/libressl >/dev/null 2>&1
.else
-BROKEN_SSL= openssl111
-BROKEN_SSL_REASON_openssl111= incomplete definition of type 'struct rsa_st'
+BROKEN_SSL= openssl
+BROKEN_SSL_REASON_openssl= incomplete definition of type 'struct rsa_st'
.endif
post-patch:
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index 304cb501e711..6ef6bc8a37bf 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -22,8 +22,7 @@ NC_DESC= Install TLS-enabled netcat
TLS1_3_DESC= TLSv1.3 support (experimental)
CONFLICTS_INSTALL= libressl-[0-9]* \
- openssl-[0-9]* \
- openssl111-[0-9]*
+ openssl-[0-9]*
NC_CONFIGURE_ENABLE= nc
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 9f28c50f57de..aec0c360f551 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -20,8 +20,7 @@ MAN3_DESC= Install API manpages (section 3)
NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl-devel-[0-9]* \
- openssl-[0-9]* \
- openssl111-[0-9]*
+ openssl-[0-9]*
NC_CONFIGURE_ENABLE= nc
diff --git a/security/openca-tools-forked/Makefile b/security/openca-tools-forked/Makefile
index 3f8e8c4cad37..38cf0a18610b 100644
--- a/security/openca-tools-forked/Makefile
+++ b/security/openca-tools-forked/Makefile
@@ -12,7 +12,7 @@ COMMENT= Tools to deal with SCEP and PKCS7 messages
LICENSE= APACHE20
-BROKEN_SSL= openssl111
+BROKEN_SSL= openssl
USES= gmake perl5 ssl
diff --git a/security/p5-Crypt-OpenSSL-CA/Makefile b/security/p5-Crypt-OpenSSL-CA/Makefile
index a31814017106..bb2ab051dbc0 100644
--- a/security/p5-Crypt-OpenSSL-CA/Makefile
+++ b/security/p5-Crypt-OpenSSL-CA/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= p5-Convert-ASN1>=0.02:converters/p5-Convert-ASN1 \
TEST_DEPENDS= p5-Test-Group>=0:devel/p5-Test-Group \
p5-Test-Taint>=0:devel/p5-Test-Taint
-BROKEN_SSL= openssl111
+BROKEN_SSL= openssl
USES= perl5 ssl
USE_PERL5= modbuild
diff --git a/security/p5-OpenCA-OpenSSL/Makefile b/security/p5-OpenCA-OpenSSL/Makefile
index 54c0f3ebd31c..5b10928b8362 100644
--- a/security/p5-OpenCA-OpenSSL/Makefile
+++ b/security/p5-OpenCA-OpenSSL/Makefile
@@ -12,8 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl crypto extension to OpenSSL
-BROKEN_SSL= openssl111 ${BROKEN_SSL_${OSREL:R}}
-BROKEN_SSL_REASON_openssl111= incomplete definition of type 'struct x509_st'
+BROKEN_SSL= openssl ${BROKEN_SSL_${OSREL:R}}
+BROKEN_SSL_REASON_openssl= incomplete definition of type 'struct x509_st'
BROKEN_SSL_12= base
BROKEN_SSL_13= base
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 2b9d0eb6628f..06f35af567a3 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -14,8 +14,8 @@ COMMENT= PGP Public Key Server
LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= openssl111
-BROKEN_SSL_REASON_openssl111= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')
+BROKEN_SSL= openssl
+BROKEN_SSL_REASON_openssl= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')
USES= bdb ssl
USE_GCC= any
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 6a0790a90a72..8562c474a2cc 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -11,7 +11,7 @@ RACOON2_COMMIT_DATE=20181215
MAINTAINER= cy@FreeBSD.org
COMMENT= Racoon2 IPsec daemon
-BROKEN_FreeBSD_11= Requires openssl111 to build
+BROKEN_FreeBSD_11= Requires openssl to build
CONFLICTS= racoon2-legacy-*
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 04c83bd25f86..56fe44d4bd6e 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -52,7 +52,7 @@ CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl --with-openssl=${OPENSSLBA
.include <bsd.port.options.mk>
-.if ${SSL_DEFAULT:Mlibressl*} || ${SSL_DEFAULT:Mopenssl111}
+.if ${SSL_DEFAULT:Mlibressl*} || ${SSL_DEFAULT:Mopenssl}
CONFIGURE_ARGS+= --disable-gost
.endif
diff --git a/security/sslscan/Makefile b/security/sslscan/Makefile
index 8dee4b8d8e6e..dbebcec36123 100644
--- a/security/sslscan/Makefile
+++ b/security/sslscan/Makefile
@@ -31,8 +31,8 @@ UNSAFESSL_ALL_TARGET= sslscan
.include <bsd.port.pre.mk>
-.if empty(PORT_OPTIONS:MUNSAFESSL) && ${SSL_DEFAULT:Mopenssl111}
-BROKEN= Does not build with openssl111
+.if empty(PORT_OPTIONS:MUNSAFESSL) && ${SSL_DEFAULT:Mopenssl}
+BROKEN= Does not build with openssl
.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine310/Makefile b/sysutils/cfengine310/Makefile
index ac16c25407b1..7e8489caeff3 100644
--- a/sysutils/cfengine310/Makefile
+++ b/sysutils/cfengine310/Makefile
@@ -76,8 +76,8 @@ LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
.if ${SSL_DEFAULT} != "openssl"
-BROKEN_FreeBSD_12= fails to build with openssl111
-BROKEN_FreeBSD_13= fails to build with openssl111
+BROKEN_FreeBSD_12= fails to build with openssl
+BROKEN_FreeBSD_13= fails to build with openssl
.endif
.endif
diff --git a/sysutils/cfengine311/Makefile b/sysutils/cfengine311/Makefile
index e900fc3f5374..5e1090964737 100644
--- a/sysutils/cfengine311/Makefile
+++ b/sysutils/cfengine311/Makefile
@@ -76,8 +76,8 @@ LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
.if ${SSL_DEFAULT} != "openssl"
-BROKEN_FreeBSD_12= fails to build with openssl111
-BROKEN_FreeBSD_13= fails to build with openssl111
+BROKEN_FreeBSD_12= fails to build with openssl
+BROKEN_FreeBSD_13= fails to build with openssl
.endif
.endif
diff --git a/sysutils/ipmitool/Makefile b/sysutils/ipmitool/Makefile
index c2477f3d2b95..ff3766f74528 100644
--- a/sysutils/ipmitool/Makefile
+++ b/sysutils/ipmitool/Makefile
@@ -49,7 +49,7 @@ FREEIPMI_CONFIGURE_ENABLE= intf-free
.include <bsd.port.options.mk>
-.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085) || ${SSL_DEFAULT} == openssl111
+.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085) || ${SSL_DEFAULT} == openssl
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src_plugins_lanplus_lanplus__crypt__impl.c
.endif
diff --git a/textproc/libucl/Makefile b/textproc/libucl/Makefile
index 5aba9ea44571..9b29902c638a 100644
--- a/textproc/libucl/Makefile
+++ b/textproc/libucl/Makefile
@@ -54,7 +54,7 @@ UTILS_CONFIGURE_ENABLE= utils
.include <bsd.port.options.mk>
# https://github.com/vstakhov/libucl/issues/203
-.if ${PORT_OPTIONS:MSIGNATURES} && ((${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base) || ${SSL_DEFAULT} == openssl111)
+.if ${PORT_OPTIONS:MSIGNATURES} && ((${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base) || ${SSL_DEFAULT} == openssl)
BROKEN= Signatures checking support does not build with OpenSSL 1.1.1
.endif
diff --git a/www/envoy/Makefile b/www/envoy/Makefile
index cd269bffdcf8..a273e42ad044 100644
--- a/www/envoy/Makefile
+++ b/www/envoy/Makefile
@@ -13,7 +13,7 @@ COMMENT= Edge and service proxy for cloud-native applications
LICENSE= APACHE20
BROKEN_i386= makes a lot of 64-bit assumptions (patches welcome)
-BROKEN_SSL= base openssl openssl111 libressl libressl-devel
+BROKEN_SSL= base openssl libressl libressl-devel
BROKEN_SSL_REASON= requires BoringSSL
BUILD_DEPENDS= ${LOCALBASE}/include/absl/base/thread_annotations.h:devel/abseil \
diff --git a/www/squid3/Makefile b/www/squid3/Makefile
index 1967ad5dd5ed..deee86738e2e 100644
--- a/www/squid3/Makefile
+++ b/www/squid3/Makefile
@@ -114,7 +114,7 @@ SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE} \
LIBOPENSSL_CFLAGS=-I${OPENSSLINC} \
LIBOPENSSL_LIBS="-lcrypto -lssl"
SSL_USES= ssl
-SSL_VARS= BROKEN_SSL=openssl111
+SSL_VARS= BROKEN_SSL=openssl
SSL_CRTD_CONFIGURE_ENABLE= ssl-crtd
SSL_CRTD_IMPLIES= SSL
STACKTRACES_CONFIGURE_ENABLE= stacktraces