aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/php5-phar/Makefile1
-rw-r--r--archivers/php5-phar/files/patch-tar.c18
-rw-r--r--databases/php5-pdo/Makefile1
-rw-r--r--databases/php5-pdo/files/patch-pdo_sql_parser.re42
-rw-r--r--lang/php5/Makefile62
-rw-r--r--lang/php5/Makefile.ext124
-rw-r--r--lang/php5/distinfo4
7 files changed, 109 insertions, 143 deletions
diff --git a/archivers/php5-phar/Makefile b/archivers/php5-phar/Makefile
index 668bc01f116c..6587ae6c572e 100644
--- a/archivers/php5-phar/Makefile
+++ b/archivers/php5-phar/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= archivers
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/archivers/php5-phar/files/patch-tar.c b/archivers/php5-phar/files/patch-tar.c
deleted file mode 100644
index 387a414414f2..000000000000
--- a/archivers/php5-phar/files/patch-tar.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- tar.c.orig 2012-06-02 08:29:43.000000000 +0200
-+++ tar.c 2012-06-02 08:31:37.000000000 +0200
-@@ -337,6 +337,15 @@
- last_was_longlink = 1;
- /* support the ././@LongLink system for storing long filenames */
- entry.filename_len = entry.uncompressed_filesize;
-+ /* Check for overflow - bug 61065 */
-+ if (entry.filename_len == UINT_MAX) {
-+ if (error) {
-+ spprintf(error, 4096, "phar error: \"%s\" is a corrupted tar file (invalid entry size)", fname);
-+ }
-+ php_stream_close(fp);
-+ phar_destroy_phar_data(myphar TSRMLS_CC);
-+ return FAILURE;
-+ }
- entry.filename = pemalloc(entry.filename_len+1, myphar->is_persistent);
-
- read = php_stream_read(fp, entry.filename, entry.filename_len);
diff --git a/databases/php5-pdo/Makefile b/databases/php5-pdo/Makefile
index b2db17b371ea..76f31572786d 100644
--- a/databases/php5-pdo/Makefile
+++ b/databases/php5-pdo/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/databases/php5-pdo/files/patch-pdo_sql_parser.re b/databases/php5-pdo/files/patch-pdo_sql_parser.re
deleted file mode 100644
index eb16ad277e80..000000000000
--- a/databases/php5-pdo/files/patch-pdo_sql_parser.re
+++ /dev/null
@@ -1,42 +0,0 @@
---- pdo_sql_parser.re.orig
-+++ pdo_sql_parser.re
-@@ -32,12 +32,12 @@
-
- #define YYCTYPE unsigned char
- #define YYCURSOR cursor
--#define YYLIMIT cursor
-+#define YYLIMIT s->end
- #define YYMARKER s->ptr
--#define YYFILL(n)
-+#define YYFILL(n) { RET(PDO_PARSER_EOI); }
-
- typedef struct Scanner {
-- char *ptr, *cur, *tok;
-+ char *ptr, *cur, *tok, *end;
- } Scanner;
-
- static int scan(Scanner *s)
-@@ -51,7 +51,6 @@ static int scan(Scanner *s)
- COMMENTS = ("/*"([^*]+|[*]+[^/*])*[*]*"*/"|"--"[^\r\n]*);
- SPECIALS = [:?"'];
- MULTICHAR = [:?];
-- EOF = [\000];
- ANYNOEOF = [\001-\377];
- */
-
-@@ -64,7 +63,6 @@ static int scan(Scanner *s)
- SPECIALS { SKIP_ONE(PDO_PARSER_TEXT); }
- COMMENTS { RET(PDO_PARSER_TEXT); }
- (ANYNOEOF\SPECIALS)+ { RET(PDO_PARSER_TEXT); }
-- EOF { RET(PDO_PARSER_EOI); }
- */
- }
-
-@@ -94,6 +92,7 @@ PDO_API int pdo_parse_params(pdo_stmt_t *stmt, char *inquery, int inquery_len,
-
- ptr = *outquery;
- s.cur = inquery;
-+ s.end = inquery + inquery_len + 1;
-
- /* phase 1: look for args */
- while((t = scan(&s)) != PDO_PARSER_EOI) {
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index f577071b1331..77a5b220928a 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.4.3
+PORTVERSION= 5.4.4
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
@@ -22,6 +22,7 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
MAKE_JOBS_SAFE= yes
+NO_OPTIONS_SORT=yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf
@@ -41,18 +42,21 @@ CONFIGURE_ARGS= \
USE_GNOME= libxml2
-OPTIONS= CLI "Build CLI version" on \
- CGI "Build CGI version" on \
- FPM "Build FPM version" off \
- APACHE "Build Apache module" off \
- AP2FILTER " Use Apache 2.x filter interface (experimental)" off \
- EMBED "Build embedded library" off \
- DEBUG "Enable debug" off \
- DTRACE "Enable DTrace support" off \
- IPV6 "Enable ipv6 support" on \
- MAILHEAD "Enable mail header patch" off \
- LINKTHR "Link thread lib (for threaded extensions)" on
-# SUHOSIN "Enable Suhosin protection system" on \
+OPTIONS_DEFINE= CLI CGI FPM APACHE AP2FILTER EMBED DEBUG DTRACE IPV6 MAILHEAD LINKTHR # SUHOSIN
+OPTIONS_DEFAULT=CLI CGI IPV6 LINKTHR
+
+CLI_DESC= Build CLI version
+CGI_DESC= Build CGI version
+FPM_DESC= Build FPM version
+APACHE_DESC= Build Apache module
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+EMBED_DESC= Build embedded library
+SUHOSIN_DESC= Enable Suhosin protection system
+DEBUG_DESC= Enable debug
+DTRACE_DESC= Enable DTrace support
+IPV6_DESC= Enable ipv6 support
+MAILHEAD_DESC= Enable mail header patch
+LINKTHR_DESC= Link thread lib (for threaded extensions)
CONFLICTS= php52-5* php53-5*
@@ -65,7 +69,7 @@ PATCH_DIST_STRIP= -p1
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= ale
-#.if !defined(WITHOUT_SUHOSIN)
+#.if ${PORT_OPTIONS:MSUHOSIN}
#PATCHFILES+= suhosin-patch-5.3.x-0.9.10.patch.gz
#PATCH_SITES+= http://download.suhosin.org/:suhosin
#PLIST_SUB+= SUHOSIN=""
@@ -73,12 +77,12 @@ PATCH_SITE_SUBDIR= ale
PLIST_SUB+= SUHOSIN="@comment "
#.endif
-.if defined(WITH_MAILHEAD)
+.if ${PORT_OPTIONS:MMAILHEAD}
PATCHFILES+= php-5.4.x-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
-.if !defined(WITHOUT_CLI)
+.if ${PORT_OPTIONS:MCLI}
PHP_SAPI+= cli
PLIST_SUB+= CLI=""
MAN1+= php.1
@@ -87,7 +91,7 @@ PLIST_SUB+= CLI="@comment "
CONFIGURE_ARGS+=--disable-cli
.endif
-.if !defined(WITHOUT_CGI)
+.if ${PORT_OPTIONS:MCGI}
PHP_SAPI+= cgi
PLIST_SUB+= CGI=""
.else
@@ -95,7 +99,7 @@ PLIST_SUB+= CGI="@comment "
CONFIGURE_ARGS+=--disable-cgi
.endif
-.if defined(WITH_FPM)
+.if ${PORT_OPTIONS:MFPM}
PHP_SAPI+= fpm
MAN8+= php-fpm.8
USE_RC_SUBR+= php-fpm
@@ -107,15 +111,15 @@ PLIST_SUB+= FPM=""
PLIST_SUB+= FPM="@comment "
.endif
-.if defined(WITH_APACHE) && defined(WITH_EMBED)
+.if ${PORT_OPTIONS:MAPACHE} && ${PORT_OPTIONS:MEMBED}
IGNORE= cannot be built with multiple SAPI (apache and embedded)
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
PHP_SAPI+= mod
USE_APACHE= 20+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
-.if defined(WITH_AP2FILTER)
+.if ${PORT_OPTIONS:MAP2FILTER}
CONFIGURE_ARGS+=--with-apxs2filter=${APXS}
.else
CONFIGURE_ARGS+=--with-apxs2=${APXS}
@@ -128,7 +132,7 @@ PLIST_SUB+= APACHE=""
PLIST_SUB+= APACHE="@comment "
.endif
-.if defined(WITH_EMBED)
+.if ${PORT_OPTIONS:MEMBED}
PHP_SAPI+= embed
CONFIGURE_ARGS+=--enable-embed
PLIST_SUB+= EMBED=""
@@ -155,29 +159,29 @@ CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
pthreads_working="yes" \
lt_cv_path_SED="sed"
-.if defined(WITH_LINKTHR)
+.if ${PORT_OPTIONS:MLINKTHR}
CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif
-.if defined(WITH_DTRACE)
+.if ${PORT_OPTIONS:MDTRACE}
.if ${OSVERSION} < 900000
IGNORE= cannot be built with DTrace support on FreeBSD < 9.x
.endif
CONFIGURE_ARGS+=--enable-dtrace
.endif
-.if defined(WITHOUT_IPV6)
+.if empty(PORT_OPTIONS:MIPV6)
CONFIGURE_ARGS+=--disable-ipv6
.endif
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
-.if defined(WITH_FPM)
+.if ${PORT_OPTIONS:MFPM}
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \
${WRKSRC}/sapi/fpm/php-fpm.conf.in
.endif
@@ -203,10 +207,10 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-production ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
@${TOUCH} ${PREFIX}/include/php/ext/php_config.h
-.if defined(WITH_FPM)
+.if ${PORT_OPTIONS:MFPM}
@${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 461b407798f0..c5f29306adc6 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -40,13 +40,16 @@ CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.if ${PHP_MODNAME} == "dba"
CONFIGURE_ARGS+=--enable-dba
-OPTIONS= CDB "cdb database support" on \
- DB4 "Berkeley DB4 support" off \
- GDBM "GDBM database support" off \
- QDBM "QDBM database support" off \
- TOKYO "Tokyo Cabinet database support" off \
- INIFILE "INI file support" on \
- FLATFILE "flatfile support" on
+OPTIONS_DEFINE= CDB DB4 GDBM QDBM TOKYO INIFILE FLATFILE
+OPTIONS_DEFAULT=CDB INIFILE FLATFILE
+
+CDB_DESC= cdb database support
+DB4_DESC= Berkeley DB4 support
+GDBM_DESC= GDBM database support
+QDBM_DESC= QDBM database support
+TOKYO_DESC= Tokyo Cabinet database support
+INIFILE_DESC= INI file support
+FLATFILE_DESC= flatfile support
PHP_HEADER_DIRS= libcdb libflatfile libinifile
.endif
@@ -86,23 +89,21 @@ USE_OPENSSL= yes
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
-. if !defined(WITHOUT_X11)
-USE_XORG= xpm
-. endif
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
--with-jpeg-dir=${LOCALBASE} \
--with-png-dir=${LOCALBASE} \
--with-zlib-dir=/usr
-. if !defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
-. endif
-OPTIONS= T1LIB "Include T1lib support" on \
- TRUETYPE "Enable TrueType string function" on \
- JIS "Enable JIS-mapped Japanese font support" off \
- VPX "Enable VP8 codec support" off
+OPTIONS_DEFINE= T1LIB TRUETYPE JIS X11 VPX
+OPTIONS_DEFAULT=T1LIB TRUETYPE X11
+
+T1LIB_DESC= Include T1lib support
+TRUETYPE_DESC= Enable TrueType string function
+JIS_DESC= Enable JIS-mapped Japanese font support
+X11_DESC= Enable XPM support
+VPX_DESC= Enable VP8 codec support
PHP_HEADER_DIRS=libgd
.endif
@@ -168,7 +169,10 @@ CONFIGURE_ARGS+=--with-ldap-sasl
CONFIGURE_ARGS+=--enable-mbstring \
--with-pcre-dir=${LOCALBASE}
-OPTIONS= REGEX "Enable multibyte regex support" on
+OPTIONS_DEFINE= REGEX
+OPTIONS_DEFAULT=REGEX
+
+REGEX_DESC= Enable multibyte regex support
PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
@@ -188,17 +192,25 @@ CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mysql"
-OPTIONS= MYSQLND "Use MySQL Native Driver" on
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT=MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver"
.endif
.if ${PHP_MODNAME} == "mysqli"
-OPTIONS= MYSQLND "Use MySQL Native Driver" on
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT=MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver"
.endif
.if ${PHP_MODNAME} == "odbc"
CONFIGURE_ARGS+=--enable-odbc
-OPTIONS= IODBC "Use the iODBC driver instead of unixODBC" off
+OPTIONS_DEFINE= IODBC
+
+IODBC_DESC= Use the iODBC driver instead of unixODBC
.endif
.if ${PHP_MODNAME} == "openssl"
@@ -222,7 +234,9 @@ CONFIGURE_ARGS+=--with-pdo-dblib=${LOCALBASE}
USE_PHP= pdo
USE_PHP_BUILD= yes
-OPTIONS= MSSQL "Enable Microsoft SQL Server support" off
+OPTIONS_DEFINE= MSSQL
+
+MSSQL_DESC= Enable Microsoft SQL Server support
.endif
.if ${PHP_MODNAME} == "pdo_firebird"
@@ -235,14 +249,19 @@ USE_FIREBIRD= yes
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-OPTIONS= MYSQLND "Use MySQL Native Driver" on
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT=MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver"
USE_PHP= pdo
USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-OPTIONS= IODBC "Use the iODBC driver instead of unixODBC" off
+OPTIONS_DEFINE= IODBC
+
+IODBC_DESC= Use the iODBC driver instead of unixODBC
USE_PHP= pdo
USE_PHP_BUILD= yes
@@ -445,51 +464,56 @@ CONFIGURE_ARGS+=--with-zlib=/usr
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "dba"
-. if defined(WITHOUT_CDB)
+. if empty(PORT_OPTIONS:MCDB)
CONFIGURE_ARGS+=--without-cdb
. endif
-. if defined(WITH_DB4)
+. if ${PORT_OPTIONS:MDB4}
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
-. if defined(WITH_GDBM)
+. if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
-. if defined(WITH_QDBM)
+. if ${PORT_OPTIONS:MQDBM}
LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
-. if defined(WITH_TOKYO)
+. if ${PORT_OPTIONS:MTOKYO}
LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
CONFIGURE_ARGS+=--with-tcadb=${LOCALBASE}
. endif
-. if defined(WITHOUT_INIFILE)
+. if empty(PORT_OPTIONS:MINIFILE)
CONFIGURE_ARGS+=--disable-inifile
. endif
-. if defined(WITHOUT_FLATFILE)
+. if empty(PORT_OPTIONS:MFLATFILE)
CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
.if ${PHP_MODNAME} == "gd"
-. if !defined(WITHOUT_T1LIB)
+. if ${PORT_OPTIONS:MT1LIB}
LIB_DEPENDS+= t1.5:${PORTSDIR}/devel/t1lib
CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
. endif
-. if !defined(WITHOUT_TRUETYPE)
+. if ${PORT_OPTIONS:MTRUETYPE}
CONFIGURE_ARGS+=--enable-gd-native-ttf
. endif
-. if defined(WITH_JIS)
+. if ${PORT_OPTIONS:MJIS}
CONFIGURE_ARGS+=--enable-gd-jis-conv
. endif
-. if defined(WITH_VPX)
+. if ${PORT_OPTIONS:MX11}
+USE_XORG= xpm
+
+CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
+. endif
+. if ${PORT_OPTIONS:MVPX}
LIB_DEPENDS+= vpx.1:${PORTSDIR}/multimedia/libvpx
CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
@@ -497,16 +521,16 @@ CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mbstring"
-. if defined(WITHOUT_REGEX)
-CONFIGURE_ARGS+=--disable-mbregex
-. else
+. if ${PORT_OPTIONS:MREGEX}
LIB_DEPENDS+= onig.1:${PORTSDIR}/devel/oniguruma4
CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
+. else
+CONFIGURE_ARGS+=--disable-mbregex
. endif
.endif
.if ${PHP_MODNAME} == "mysql"
-. if defined(WITH_MYSQLND)
+. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-mysql=mysqlnd
. else
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
@@ -517,7 +541,7 @@ USE_MYSQL= yes
.endif
.if ${PHP_MODNAME} == "mysqli"
-. if defined(WITH_MYSQLND)
+. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-mysqli=mysqlnd
. else
CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
@@ -532,39 +556,39 @@ post-extract:
.endif
.if ${PHP_MODNAME} == "odbc"
-.if defined(WITH_IODBC)
+. if ${PORT_OPTIONS:MIODBC}
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
-.else
+. else
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
-.endif
+. endif
.endif
.if ${PHP_MODNAME} == "pdo_dblib"
-.if defined(WITH_MSSQL)
+. if ${PORT_OPTIONS:MMSSQL}
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
-.else
+. else
LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
-.endif
+. endif
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-.if defined(WITH_IODBC)
+. if ${PORT_OPTIONS:MIODBC}
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
-.else
+. else
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
-.endif
+. endif
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-. if defined(WITH_MYSQLND)
+. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
USE_PHP+= mysql
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index f33518d84901..ebcb6a41e4e4 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,4 +1,4 @@
-SHA256 (php-5.4.3.tar.bz2) = d7e0c987586b6554ee08e3b71cc2806ddd1b192451159083d861c132994bc1bd
-SIZE (php-5.4.3.tar.bz2) = 11147567
+SHA256 (php-5.4.4.tar.bz2) = 70b0e604077058791a311121e96d792210685dffbb329d2042084637435cc666
+SIZE (php-5.4.4.tar.bz2) = 11150967
SHA256 (php-5.4.x-mail-header.patch) = 005ae1cd8ed17c72d7b09dee9c4466e8b16d4ecba7fe11276731ed6ff9fbb344
SIZE (php-5.4.x-mail-header.patch) = 3379