aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Exceptions/Makefile26
-rw-r--r--devel/p5-POE-Exceptions/distinfo1
-rw-r--r--devel/p5-POE-Exceptions/pkg-descr17
-rw-r--r--devel/p5-POE-Exceptions/pkg-plist9
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b3337fa19b79..2094822bf6de 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -729,6 +729,7 @@
SUBDIR += p5-POE-Component-Logger
SUBDIR += p5-POE-Component-Pcap
SUBDIR += p5-POE-Component-RSS
+ SUBDIR += p5-POE-Exceptions
SUBDIR += p5-POE-Session-Cascading
SUBDIR += p5-POE-Session-MultiDispatch
SUBDIR += p5-PPerl
diff --git a/devel/p5-POE-Exceptions/Makefile b/devel/p5-POE-Exceptions/Makefile
new file mode 100644
index 000000000000..1d0965565c71
--- /dev/null
+++ b/devel/p5-POE-Exceptions/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: POE-Exceptions
+# Date created: 16 October 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Exceptions
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= POE class for handling exceptions
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Exceptions.3 POE::Kernel::Exception.3 \
+ POE::Session::Exception.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Exceptions/distinfo b/devel/p5-POE-Exceptions/distinfo
new file mode 100644
index 000000000000..e339e20a88f9
--- /dev/null
+++ b/devel/p5-POE-Exceptions/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Exceptions-0.03.tar.gz) = b962d88f0bdcb2c9e63f0451cd7c4a29
diff --git a/devel/p5-POE-Exceptions/pkg-descr b/devel/p5-POE-Exceptions/pkg-descr
new file mode 100644
index 000000000000..aaf3d193dbc8
--- /dev/null
+++ b/devel/p5-POE-Exceptions/pkg-descr
@@ -0,0 +1,17 @@
+POE::Exceptions extends POE to catch exceptions neatly. A new signal,
+DIE, is introduced. This signal will be fired every time an exception
+occurs. (For those of you new to the term exception, an exception is
+whenever the code decides to bail out by die'ing.) If the signal handler
+returns 1 (as in the example above), POE will assume that the handler
+dealt with the signal appropriately. If the signal handler returns 0,
+POE will assume that the handler does not want to deal with the signal
+and POE will propgate the exception as if the handler never existed.
+
+Caveat: POE::Exceptions will die on its own in the case of a double
+exception fault. If the DIE signal handler itself throws an exception,
+POE::Exceptions will shut the program down and bail out.
+
+WWW: http://search.cpan.org/dist/POE-Exceptions/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-POE-Exceptions/pkg-plist b/devel/p5-POE-Exceptions/pkg-plist
new file mode 100644
index 000000000000..866664e26e8a
--- /dev/null
+++ b/devel/p5-POE-Exceptions/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Exceptions/.packlist
+%%SITE_PERL%%/POE/Exceptions.pm
+%%SITE_PERL%%/POE/Kernel/Exception.pm
+%%SITE_PERL%%/POE/Session/Exception.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Exceptions
+@unexec rmdir %D/%%SITE_PERL%%/POE/Kernel 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true