aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/malbolge/Makefile31
-rw-r--r--lang/malbolge/distinfo1
-rw-r--r--lang/malbolge/pkg-comment1
-rw-r--r--lang/malbolge/pkg-descr9
-rw-r--r--lang/malbolge/pkg-plist4
6 files changed, 47 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index da322bcdc5a8..418889d14675 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -64,6 +64,7 @@
SUBDIR += logo
SUBDIR += lua
SUBDIR += m3gdb
+ SUBDIR += malbolge
SUBDIR += mawk
SUBDIR += mdk
SUBDIR += mit-scheme
diff --git a/lang/malbolge/Makefile b/lang/malbolge/Makefile
new file mode 100644
index 000000000000..675c15c52164
--- /dev/null
+++ b/lang/malbolge/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: malbolge
+# Date created: 14 June 2001
+# Whom: simond@irrelevant.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= malbolge
+PORTVERSION= 1.0
+CATEGORIES= lang
+MASTER_SITES= http://www.mines.edu/students/b/bolmstea/malbolge/
+DISTNAME= malbolge
+
+MAINTAINER= simond@irrelevant.org
+
+post-patch:
+ ${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g" ${WRKSRC}/malbolge.c
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/malbolge.c -o ${WRKSRC}/malbolge
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/malbolge ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/malbolge
+ ${INSTALL_DATA} ${WRKSRC}/malbolge.txt ${PREFIX}/share/doc/malbolge
+ ${INSTALL_DATA} ${WRKSRC}/malbolge.txt ${WRKSRC}/nop.mal \
+ ${PREFIX}/share/doc/malbolge
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/malbolge/distinfo b/lang/malbolge/distinfo
new file mode 100644
index 000000000000..e09f4aa9dd48
--- /dev/null
+++ b/lang/malbolge/distinfo
@@ -0,0 +1 @@
+MD5 (malbolge.tar.gz) = b7b0123a5be7611688130876da82ba82
diff --git a/lang/malbolge/pkg-comment b/lang/malbolge/pkg-comment
new file mode 100644
index 000000000000..cd616dc5c8f3
--- /dev/null
+++ b/lang/malbolge/pkg-comment
@@ -0,0 +1 @@
+An Infernal programming language
diff --git a/lang/malbolge/pkg-descr b/lang/malbolge/pkg-descr
new file mode 100644
index 000000000000..fe7ea8e69a3b
--- /dev/null
+++ b/lang/malbolge/pkg-descr
@@ -0,0 +1,9 @@
+Malbolge was truly created with the idea that programming should be hard.
+It should be as close to the Infernal as a programming language possibly
+can be. It will continue to evolve over time, as newer, more twisted minds
+attack this problem.
+
+WWW: http://www.mines.edu/students/b/bolmstea/malbolge/index.html
+
+- Simon Dick
+simond@irrelevant.org
diff --git a/lang/malbolge/pkg-plist b/lang/malbolge/pkg-plist
new file mode 100644
index 000000000000..4bc526bf7cea
--- /dev/null
+++ b/lang/malbolge/pkg-plist
@@ -0,0 +1,4 @@
+bin/malbolge
+%%PORTDOCS%%share/doc/malbolge/malbolge.txt
+%%PORTDOCS%%share/doc/malbolge/nop.mal
+%%PORTDOCS%%@dirrm share/doc/malbolge