aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/afd/Makefile33
-rw-r--r--ftp/afd/distinfo1
-rw-r--r--ftp/afd/files/patch-Include.mk.freebsd11
-rw-r--r--ftp/afd/pkg-comment1
-rw-r--r--ftp/afd/pkg-descr14
-rw-r--r--ftp/afd/pkg-plist63
7 files changed, 124 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index fd616d33cf77..e14438c4af13 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -2,6 +2,7 @@
#
SUBDIR += IglooFTP
+ SUBDIR += afd
SUBDIR += axyftp
SUBDIR += bftpd
SUBDIR += caitoo
diff --git a/ftp/afd/Makefile b/ftp/afd/Makefile
new file mode 100644
index 000000000000..76aca40618f4
--- /dev/null
+++ b/ftp/afd/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: afd
+# Date created: Apr 26, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= afd
+PORTVERSION= 1.2.6
+CATEGORIES= ftp
+MASTER_SITES= http://www.dwd.de/general/GBTI/afd/download/ \
+ ftp://ftp.dwd.de/pub/afd/
+DISTNAME= src-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_MOTIF= yes
+MAKE_ENV= BINMODE=${BINMODE} \
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+
+post-patch:
+ @find ${WRKSRC} -name Makefile | xargs \
+ ${PERL} -pi -e "s,^(INST(ALL)?DIR *)= .*,\1= ${PREFIX}/bin,g ; \
+ s,cp -p,cp,g"
+ @${PERL} -pi -e "s,%%CFLAGS%%,${CFLAGS},g" ${WRKSRC}/Include.mk.freebsd
+ @${PERL} -pi -e "s,^SBINDIR = .*,SBINDIR = ${PREFIX}/sbin,g" ${WRKSRC}/afd_mon/Makefile
+
+pre-build:
+ @(cd ${WRKSRC} ; ${RM} -f Include.mk ; \
+ ${LN} -s Include.mk.freebsd Include.mk)
+
+.include <bsd.port.mk>
diff --git a/ftp/afd/distinfo b/ftp/afd/distinfo
new file mode 100644
index 000000000000..2dc5bb7a9ae2
--- /dev/null
+++ b/ftp/afd/distinfo
@@ -0,0 +1 @@
+MD5 (src-1.2.6.tar.gz) = 246ebec3bbf9765489929d9d3dcb4b73
diff --git a/ftp/afd/files/patch-Include.mk.freebsd b/ftp/afd/files/patch-Include.mk.freebsd
new file mode 100644
index 000000000000..cf7b9f3e1b57
--- /dev/null
+++ b/ftp/afd/files/patch-Include.mk.freebsd
@@ -0,0 +1,11 @@
+--- Include.mk.freebsd.orig Sun Jun 10 22:04:23 2001
++++ Include.mk.freebsd Sun Jun 10 22:03:33 2001
+@@ -7,7 +7,7 @@
+ ARFLAGS = rsv
+ MMAP_FLAG =
+ #COMPILER_FLAGS = ${WARN_OPTIONS} ${OPTIMIZATION_OPTIONS} ${MMAP_FLAG} -DFREEBSD -D_WITH_SETUID_CHECK
+-COMPILER_FLAGS = ${WARN_OPTIONS} ${MMAP_FLAG} -DFREEBSD -D_WITH_SETUID_CHECK -g
++COMPILER_FLAGS = %%CFLAGS%% ${WARN_OPTIONS} ${MMAP_FLAG} -DFREEBSD -D_WITH_SETUID_CHECK
+ #DEBUG_FLAGS = -D_DEBUG -D_FIFO_DEBUG
+ DEBUG_FLAGS =
+ #EFENCE = -lefence
diff --git a/ftp/afd/pkg-comment b/ftp/afd/pkg-comment
new file mode 100644
index 000000000000..4395eb0bfb74
--- /dev/null
+++ b/ftp/afd/pkg-comment
@@ -0,0 +1 @@
+Automatic File Distributor
diff --git a/ftp/afd/pkg-descr b/ftp/afd/pkg-descr
new file mode 100644
index 000000000000..0688f080c88f
--- /dev/null
+++ b/ftp/afd/pkg-descr
@@ -0,0 +1,14 @@
+The Automatic File Distributor provides a framework for very flexible,
+non-stop, log and debug-able delivery of an arbitrary amount of files to
+multiple recipients as expressed in URLs (currently mailing and ftp supported
+with the mailto://user@domain and ftp://user:password@host URL conventions).
+
+The most common technique used to distribute data is for each individual to
+fetch the data from one common place. This place can be a database, FTP-server
+or even the WWW (World Wide Web). However, this is not always the most user or
+customer friendly way for a company or organization to distribute its products.
+For this reason AFD (Automatic File Distributor) was developed, to provide a
+better service to users or customers in transporting the required data directly
+to the location where it is required.
+
+WWW: http://www.dwd.de/general/GBTI/afd/english/
diff --git a/ftp/afd/pkg-plist b/ftp/afd/pkg-plist
new file mode 100644
index 000000000000..96ae7203ad4a
--- /dev/null
+++ b/ftp/afd/pkg-plist
@@ -0,0 +1,63 @@
+bin/afd_ctrl
+bin/afd_info
+bin/afd_load
+bin/afd_mon
+bin/afd_stat
+bin/afd_status
+bin/afdcfg
+bin/afdcmd
+bin/afdd
+bin/archive_watch
+bin/bfc
+bin/cache_spy
+bin/convert_fsa
+bin/convert_jid
+bin/convert_stat
+bin/current_job_list_spy
+bin/delete_log
+bin/dir_ctrl
+bin/dir_info
+bin/dir_spy
+bin/edit_hc
+bin/file_dir_check
+bin/force_archive_check
+bin/fra_view
+bin/fsa_edit
+bin/fsa_view
+bin/get_counter
+bin/get_dc_data
+bin/get_file_size
+bin/get_full_date
+bin/gts2tiff
+bin/input_log
+bin/job_list_spy
+bin/mafd
+bin/mon
+bin/mon_ctrl
+bin/mon_info
+bin/mon_sys_log
+bin/monitor_log
+bin/output_log
+bin/queue_spy
+bin/rafdd_cmd
+bin/receive_log
+bin/reset_fsa
+bin/rm_job
+bin/set_counter
+bin/show_bench_stat
+bin/show_cmd
+bin/show_dlog
+bin/show_ilog
+bin/show_log
+bin/show_olog
+bin/show_stat
+bin/system_log
+bin/tiff-sniffer
+bin/trans_db_log
+bin/transfer_log
+bin/udc
+bin/view_dc
+bin/watch_dir
+sbin/msa_view
+sbin/topview
+sbin/view_hosts