aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Image-Delivery/Makefile39
-rw-r--r--www/p5-Image-Delivery/distinfo3
-rw-r--r--www/p5-Image-Delivery/pkg-descr13
-rw-r--r--www/p5-Image-Delivery/pkg-plist14
5 files changed, 70 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f41f20fdb5a4..6993049a2356 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -797,6 +797,7 @@
SUBDIR += p5-Handel
SUBDIR += p5-IMDB-Film
SUBDIR += p5-IMDB-Movie
+ SUBDIR += p5-Image-Delivery
SUBDIR += p5-Jemplate
SUBDIR += p5-Jifty
SUBDIR += p5-Kwiki
diff --git a/www/p5-Image-Delivery/Makefile b/www/p5-Image-Delivery/Makefile
new file mode 100644
index 000000000000..7ff4fb1caed2
--- /dev/null
+++ b/www/p5-Image-Delivery/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Image-Delivery
+# Date created: 08 September 2007
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Delivery
+PORTVERSION= 0.13
+CATEGORIES= www graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= Efficient transformation and delivery of web images
+
+BUILD_DEPENDS= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-TransformPath>=1.00:${PORTSDIR}/devel/p5-Digest-TransformPath \
+ p5-HTML-Location>=1.01:${PORTSDIR}/www/p5-HTML-Location \
+ p5-File-Remove>=0.37:${PORTSDIR}/devel/p5-File-Remove \
+ p5-File-Slurp>=9999.12:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools \
+ p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Coerce>=0.14:${PORTSDIR}/devel/p5-Params-Coerce
+RUN_DEPENDS= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-TransformPath>=1.00:${PORTSDIR}/devel/p5-Digest-TransformPath \
+ p5-HTML-Location>=1.01:${PORTSDIR}/www/p5-HTML-Location \
+ p5-File-Remove>=0.37:${PORTSDIR}/devel/p5-File-Remove \
+ p5-File-Slurp>=9999.12:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools \
+ p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Coerce>=0.14:${PORTSDIR}/devel/p5-Params-Coerce
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::Delivery.3 Image::Delivery::Provider.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Image-Delivery/distinfo b/www/p5-Image-Delivery/distinfo
new file mode 100644
index 000000000000..d9d9a06fc909
--- /dev/null
+++ b/www/p5-Image-Delivery/distinfo
@@ -0,0 +1,3 @@
+MD5 (Image-Delivery-0.13.tar.gz) = 273665a22b4324fbaba375b758005faf
+SHA256 (Image-Delivery-0.13.tar.gz) = 132c2799d6b83fb779c4184e50cf713730955904640aa3bd9f190610c4cd6ab0
+SIZE (Image-Delivery-0.13.tar.gz) = 32346
diff --git a/www/p5-Image-Delivery/pkg-descr b/www/p5-Image-Delivery/pkg-descr
new file mode 100644
index 000000000000..75a28fc0a26e
--- /dev/null
+++ b/www/p5-Image-Delivery/pkg-descr
@@ -0,0 +1,13 @@
+Image::Delivery - Efficient transformation and delivery of web images
+
+Many web applications generate or otherwise deliver graphics as part
+of their interface. Getting the delivery of these images right is
+tricky, and developers usually need to make trade-offs in order
+to get a usable mechanism.
+
+Image::Delivery is an extremely sophisticated module for delivering
+these generated images. It is designed to be powerful, flexible,
+extensible, scalable, secure, stable and correct, and use a minimum
+of resources.
+
+WWW: http://search.cpan.org/dist/Image-Delivery/
diff --git a/www/p5-Image-Delivery/pkg-plist b/www/p5-Image-Delivery/pkg-plist
new file mode 100644
index 000000000000..cb115cf05b97
--- /dev/null
+++ b/www/p5-Image-Delivery/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Image/Delivery.pm
+%%SITE_PERL%%/Image/Delivery/Provider.pm
+%%SITE_PERL%%/Image/Delivery/Provider/File.pm
+%%SITE_PERL%%/Image/Delivery/Provider/IOHandle.pm
+%%SITE_PERL%%/Image/Delivery/Provider/Scalar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Delivery/.packlist
+@dirrm %%SITE_PERL%%/Image/Delivery/Provider
+@dirrm %%SITE_PERL%%/Image/Delivery
+@dirrmtry %%SITE_PERL%%/Image
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Image/Delivery/Provider
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Image/Delivery
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Image
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Delivery
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image