aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/motoya-ttfonts/Makefile65
-rw-r--r--japanese/motoya-ttfonts/distinfo2
-rw-r--r--japanese/motoya-ttfonts/files/fonts.alias.motoya8
-rw-r--r--japanese/motoya-ttfonts/files/fonts.dir.motoya9
-rw-r--r--japanese/motoya-ttfonts/pkg-deinstall13
-rw-r--r--japanese/motoya-ttfonts/pkg-descr4
-rw-r--r--japanese/motoya-ttfonts/pkg-install18
-rw-r--r--japanese/motoya-ttfonts/pkg-plist4
9 files changed, 124 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 0f04bb59e510..d5815f2b6ec0 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -212,6 +212,7 @@
SUBDIR += ming
SUBDIR += monafonts
SUBDIR += monafonts-ttf
+ SUBDIR += motoya-ttfonts
SUBDIR += mozilla-jlp
SUBDIR += mozilla-jlp-devel
SUBDIR += mplusfonts
diff --git a/japanese/motoya-ttfonts/Makefile b/japanese/motoya-ttfonts/Makefile
new file mode 100644
index 000000000000..2958e1e94011
--- /dev/null
+++ b/japanese/motoya-ttfonts/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: Motoya TrueType fonts
+# Date created: 2004-01-16
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= motoya-ttfonts
+PORTVERSION= 0.20040116
+CATEGORIES= japanese x11-fonts
+MASTER_SITES= #http://www.motoyafont.jp/dl/win/
+# You must accept following MOTOYA freefont LICENSE[1], and regist
+# free member for download. You can get a Japanese mail which
+# contains download URL.
+# http://www.motoyafont.jp/use_consent.htm [1]
+# http://www.motoyafont.jp/toroku.html [2]
+DISTFILES= nfa1.exe nfc1.exe
+DIST_SUBDIR= motoya
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Free Japanese TrueType fonts named 'MOTOYA'
+
+BUILD_DEPENDS+= lha:${PORTSDIR}/archivers/lha
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+FONTSDIR= lib/X11/fonts/TrueType
+MAKE_ENV= FONTSDIR=${FONTSDIR}
+PLIST_SUB= FONTSDIR=${FONTSDIR}
+
+pre-fetch:
+ @[ -f ${DISTDIR}/${DIST_SUBDIR}/nfa1.exe \
+ -a -f ${DISTDIR}/${DIST_SUBDIR}/nfc1.exe ] || ( \
+ ${ECHO} "****************************************************"; \
+ ${ECHO} "Please get nfa1.exe and nfc1.exe from"; \
+ ${ECHO} " http://www.motoyafont.jp/toroku.html"; \
+ ${ECHO} "And, you must accept following MOTOYA freefont LICENSE."; \
+ ${ECHO} " http://www.motoyafont.jp/use_consent.htm"; \
+ ${ECHO} "Then, put in ${DISTDIR}/${DIST_SUBDIR}/nf{a|c}1.exe."; \
+ ${ECHO} "****************************************************"; \
+ ${FALSE} \
+ )
+
+do-extract:
+.for file in ${DISTFILES}
+ @lha xiw=${WRKSRC} ${DISTDIR}/${DIST_SUBDIR}/${file} '*/*.ttc'
+.endfor
+
+do-install:
+.if !exists(${PREFIX}/${FONTSDIR})
+ @${ECHO} "***************************************************
+ @${ECHO} "Please add ${PREFIX}/${FONTSDIR} to your font path"
+ @${ECHO} "and load 'xtt' module in /etc/XF86Config."
+ @${ECHO} "***************************************************"
+ ${MKDIR} ${PREFIX}/${FONTSDIR}
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/*.ttc \
+ ${FILESDIR}/fonts.dir.motoya \
+ ${FILESDIR}/fonts.alias.motoya \
+ ${PREFIX}/${FONTSDIR}
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/japanese/motoya-ttfonts/distinfo b/japanese/motoya-ttfonts/distinfo
new file mode 100644
index 000000000000..5a8961cfe383
--- /dev/null
+++ b/japanese/motoya-ttfonts/distinfo
@@ -0,0 +1,2 @@
+MD5 (motoya/nfa1.exe) = 6a413960dae44a0906886583d2e94779
+MD5 (motoya/nfc1.exe) = e839b398a14c9ed11a88239c8d651fff
diff --git a/japanese/motoya-ttfonts/files/fonts.alias.motoya b/japanese/motoya-ttfonts/files/fonts.alias.motoya
new file mode 100644
index 000000000000..d1b74cc87d4b
--- /dev/null
+++ b/japanese/motoya-ttfonts/files/fonts.alias.motoya
@@ -0,0 +1,8 @@
+-motoya-aporo-medium-r-normal--0-0-0-p-jisx0201.1976-0 -motoya-mincho-medium-r-normal--0-0-0-p-jisx0201.1976-0
+-motoya-aporo-medium-r-normal--0-0-0-p-jisx0208.1983-0 -motoya-mincho-medium-r-normal--0-0-0-p-jisx0208.1983-0
+-motoya-aporo-medium-r-normal--0-0-0-c-jisx0201.1976-0 -motoya-mincho-medium-r-normal--0-0-0-c-jisx0201.1976-0
+-motoya-aporo-medium-r-normal--0-0-0-c-jisx0208.1983-0 -motoya-mincho-medium-r-normal--0-0-0-c-jisx0208.1983-0
+-motoya-cedar-medium-r-normal--0-0-0-p-jisx0201.1976-0 -motoya-gothic-medium-r-normal--0-0-0-p-jisx0201.1976-0
+-motoya-cedar-medium-r-normal--0-0-0-p-jisx0208.1983-0 -motoya-gothic-medium-r-normal--0-0-0-p-jisx0208.1983-0
+-motoya-cedar-medium-r-normal--0-0-0-c-jisx0201.1976-0 -motoya-gothic-medium-r-normal--0-0-0-c-jisx0201.1976-0
+-motoya-cedar-medium-r-normal--0-0-0-c-jisx0208.1983-0 -motoya-gothic-medium-r-normal--0-0-0-c-jisx0208.1983-0
diff --git a/japanese/motoya-ttfonts/files/fonts.dir.motoya b/japanese/motoya-ttfonts/files/fonts.dir.motoya
new file mode 100644
index 000000000000..3dcef9a1e104
--- /dev/null
+++ b/japanese/motoya-ttfonts/files/fonts.dir.motoya
@@ -0,0 +1,9 @@
+8
+bw=0.5:nfa1kp.ttc -motoya-aporo-medium-r-normal--0-0-0-p-jisx0201.1976-0
+nfa1kp.ttc -motoya-aporo-medium-r-normal--0-0-0-p-jisx0208.1983-0
+bw=0.5:nfa1kp.ttc -motoya-aporo-medium-r-normal--0-0-0-c-jisx0201.1976-0
+nfa1kp.ttc -motoya-aporo-medium-r-normal--0-0-0-c-jisx0208.1983-0
+bw=0.5:nfc1kp.ttc -motoya-cedar-medium-r-normal--0-0-0-p-jisx0201.1976-0
+nfc1kp.ttc -motoya-cedar-medium-r-normal--0-0-0-p-jisx0208.1983-0
+bw=0.5:nfc1kp.ttc -motoya-cedar-medium-r-normal--0-0-0-c-jisx0201.1976-0
+nfc1kp.ttc -motoya-cedar-medium-r-normal--0-0-0-c-jisx0208.1983-0
diff --git a/japanese/motoya-ttfonts/pkg-deinstall b/japanese/motoya-ttfonts/pkg-deinstall
new file mode 100644
index 000000000000..143467d2ee07
--- /dev/null
+++ b/japanese/motoya-ttfonts/pkg-deinstall
@@ -0,0 +1,13 @@
+#!/bin/sh
+if [ "$2" != "DEINSTALL" ]; then
+ exit 0
+fi
+FONTDIR=${PKG_PREFIX}/lib/X11/fonts/TrueType
+cd ${FONTDIR}
+sed -e '/-motoya-/d' fonts.dir > fonts.dir.tmp
+numfonts=$(echo $(cat fonts.dir.tmp | wc -l) - 1 | bc)
+echo ${numfonts} > fonts.dir
+sed -e 1d fonts.dir.tmp >> fonts.dir
+sed -e '/^-motoya-/d' fonts.alias > fonts.alias.tmp
+mv -f fonts.alias.tmp fonts.alias
+rm -f fonts.dir.tmp
diff --git a/japanese/motoya-ttfonts/pkg-descr b/japanese/motoya-ttfonts/pkg-descr
new file mode 100644
index 000000000000..f8fa4d064c04
--- /dev/null
+++ b/japanese/motoya-ttfonts/pkg-descr
@@ -0,0 +1,4 @@
+Free Japanese TrueType fonts named 'MOTOYA Aporo W1'
+and 'MOTOYA Cedar W1'.
+
+WWW: http://www.motoyafont.jp/
diff --git a/japanese/motoya-ttfonts/pkg-install b/japanese/motoya-ttfonts/pkg-install
new file mode 100644
index 000000000000..515bfa7dbdaa
--- /dev/null
+++ b/japanese/motoya-ttfonts/pkg-install
@@ -0,0 +1,18 @@
+#!/bin/sh
+FONTDIR=${PKG_PREFIX}/lib/X11/fonts/TrueType
+if [ "$2" = "PRE-INSTALL" ]; then
+ echo "Please add ${FONTDIR} to your /etc/XF86Config file"
+ exit 0
+fi
+cd ${FONTDIR}
+touch fonts.dir
+sed -e '/-motoya-/d' fonts.dir > fonts.dir.tmp
+numfonts=$(echo $(cat fonts.dir.tmp fonts.dir.motoya | wc -l) - 2 | bc)
+echo ${numfonts} > fonts.dir
+sed -e 1d fonts.dir.tmp >> fonts.dir
+sed -e 1d fonts.dir.motoya >> fonts.dir
+touch fonts.alias
+sed -e '/^-motoya-/d' fonts.alias > fonts.alias.tmp
+mv -f fonts.alias.tmp fonts.alias
+cat fonts.alias.motoya >> fonts.alias
+rm -f fonts.dir.tmp fonts.alias.tmp
diff --git a/japanese/motoya-ttfonts/pkg-plist b/japanese/motoya-ttfonts/pkg-plist
new file mode 100644
index 000000000000..9cfe1149d0d0
--- /dev/null
+++ b/japanese/motoya-ttfonts/pkg-plist
@@ -0,0 +1,4 @@
+%%FONTSDIR%%/fonts.alias.motoya
+%%FONTSDIR%%/fonts.dir.motoya
+%%FONTSDIR%%/nfa1kp.ttc
+%%FONTSDIR%%/nfc1kp.ttc