aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/mget/Makefile19
-rw-r--r--ftp/mget/distinfo2
-rw-r--r--ftp/mget/files/patch-Makefile18
-rw-r--r--ftp/mget/files/patch-mget.c13
-rw-r--r--ftp/mget/files/patch-mget.h14
5 files changed, 13 insertions, 53 deletions
diff --git a/ftp/mget/Makefile b/ftp/mget/Makefile
index 0161c6060356..ed664243abe5 100644
--- a/ftp/mget/Makefile
+++ b/ftp/mget/Makefile
@@ -7,19 +7,24 @@
#
PORTNAME= mget
-PORTVERSION= 1.3.0
-CATEGORIES= ftp
+PORTVERSION= 1.3.0.2
+CATEGORIES= ftp ipv6
MASTER_SITES= http://home.talkcity.com/LaGrangeLn/dbera/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-ALL_TARGET= ${PORTNAME}
+CFLAGS+= -DHAS_HERROR -DHAVE_GETOPT_LONG -DHAVE_INET_NTOP -DHAVE_IPV6 \
+ -I${LOCALBASE}/include ${PTHREAD_CFLAGS:S/"//g}
+LDFLAGS= -L${LOCALBASE}/lib -lgnugetopt ${PTHREAD_LIBS:S/"//g}
-post-patch:
- @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g ; \
- s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+pre-patch:
+ @find ${WRKSRC} -name '*.[ch]' | xargs ${PERL} -pi -e \
+ 's|#include <malloc.h>||g'
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o mget *.c ${LDFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mget ${PREFIX}/bin
diff --git a/ftp/mget/distinfo b/ftp/mget/distinfo
index b153b43f5568..286e6a91194f 100644
--- a/ftp/mget/distinfo
+++ b/ftp/mget/distinfo
@@ -1 +1 @@
-MD5 (mget-1.3.0.tar.gz) = fb7d29de46181f9939b5b11aa13aa8eb
+MD5 (mget-1.3.0.2.tar.gz) = ec78edddc43172bd00421e2323c35995
diff --git a/ftp/mget/files/patch-Makefile b/ftp/mget/files/patch-Makefile
deleted file mode 100644
index 615ed024a7ce..000000000000
--- a/ftp/mget/files/patch-Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.orig Sat Sep 22 00:28:48 2001
-+++ Makefile Sat Sep 22 00:29:33 2001
-@@ -2,12 +2,13 @@
- CC=gcc
- DEFS=-DHAS_HERROR -DHAVE_IPV6 -DHAVE_GETOPT
- DEBUG=
--CFLAGS=-Wall $(DEFS) $(DEBUG)
-+CFLAGS+=-Wall $(DEFS) $(DEBUG) -I%%LOCALBASE%%/include
- #CFLAGS=-Wall
--LDFLAGS=-lpthread
-+LDFLAGS=-lpthread -L%%LOCALBASE%%/lib -lgnugetopt
- #LDFLAGS=-lpthread -lsocket -lnsl
-
- mget: mget.o mgetutil.o
-+ ${CC} ${LDFLAGS} mget.o mgetutil.o -o mget
-
- mget.usriv: mget_usriv.o mgetutil.o
- $(CC) $(LDFLAGS) mget_usriv.o mgetutil.o -o mget.usriv
diff --git a/ftp/mget/files/patch-mget.c b/ftp/mget/files/patch-mget.c
deleted file mode 100644
index 1ee095746c2a..000000000000
--- a/ftp/mget/files/patch-mget.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- mget.c.orig Sat Sep 22 00:34:44 2001
-+++ mget.c Sat Sep 22 00:35:26 2001
-@@ -604,8 +604,10 @@
- return segment;
- }
-
-+/*
- #if !defined(linux) || !defined(HAVE_IPV6)
- char *inet_ntop(int af, INADDR *src, char *dst, size_t cnt){
- return inet_ntoa((INADDR)(*src));
- }
- #endif
-+*/
diff --git a/ftp/mget/files/patch-mget.h b/ftp/mget/files/patch-mget.h
deleted file mode 100644
index eedaa20bc27f..000000000000
--- a/ftp/mget/files/patch-mget.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- mget.h.orig Sat Sep 22 00:34:48 2001
-+++ mget.h Sat Sep 22 00:35:03 2001
-@@ -60,9 +60,11 @@
- #define herror(A) printf("%s\n",A)
- #endif
-
-+/*
- #if !defined(__linux__) || !defined(HAVE_IPV6)
- char *inet_ntop(int , INADDR *, char *, size_t );
- #endif
-+*/
-
- #ifndef NULL
- #define NULL 0 //some compilers complained