aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/fox-devel/Makefile67
-rw-r--r--x11-toolkits/fox-devel/distinfo4
-rw-r--r--x11-toolkits/fox-devel/files/patch-src::FXFile.cpp29
-rw-r--r--x11-toolkits/fox-devel/pkg-plist66
-rw-r--r--x11-toolkits/fox14/Makefile67
-rw-r--r--x11-toolkits/fox14/distinfo4
-rw-r--r--x11-toolkits/fox14/files/patch-src::FXFile.cpp29
-rw-r--r--x11-toolkits/fox14/pkg-plist66
8 files changed, 230 insertions, 102 deletions
diff --git a/x11-toolkits/fox-devel/Makefile b/x11-toolkits/fox-devel/Makefile
index 8012b35f0506..c86efc58fa8b 100644
--- a/x11-toolkits/fox-devel/Makefile
+++ b/x11-toolkits/fox-devel/Makefile
@@ -25,60 +25,69 @@ CONFLICTS= fox-1.0.*
LATEST_LINK= fox-devel
-MAJORVER= 1.1
-SHVER= 42
+MAJORVER= 1.2
+SHVER= 1
PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
+USE_GNOME= lthack
USE_GL= yes
-INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-#USE_MOTIF= yes
-USE_LIBTOOL_VER=13
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS+=--with-opengl=mesa --with-x \
- --enable-xthreads
+USE_LIBTOOL_VER= 13
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
+INSTALLS_SHLIB= yes
+
+MAN1= shutterbug.1 reswrap.1
+
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-MAN1= reswrap.1
+.include <bsd.port.pre.mk>
##
## Additional Options
##
#
+.if ${XFREE86_VERSION} < 4 || defined(WITHOUT_XFT)
+CONFIGURE_ARGS+= --with-xft=no
+.else
+CONFIGURE_ARGS+= --with-xft=yes
+CPPFLAGS+= `freetype-config --cflags`
+LDFLAGS+= `freetype-config --libs`
+.endif
+#
.if defined(WITHOUT_SHM)
-CONFIGURE_ARGS+=--with-shm=no
+CONFIGURE_ARGS+= --with-xshm=no
.else
-CONFIGURE_ARGS+=--with-shm=yes
+CONFIGURE_ARGS+= --with-xshm=yes
.endif
#
.if defined(WITH_CUPS)
-CONFIGURE_ARGS+=--enable-cups
+CONFIGURE_ARGS+= --enable-cups
.else
-CONFIGURE_ARGS+=--disable-cups
+CONFIGURE_ARGS+= --disable-cups
.endif
#
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
+CONFIGURE_ARGS+= --enable-debug
.else
-CONFIGURE_ARGS+=--enable-release
+CONFIGURE_ARGS+= --enable-release
.endif
#
.if defined(WITH_FOX_APPLICATIONS)
+MAN1+= PathFinder.1 adie.1 calculator.1
PLIST_SUB+= APPS=""
-
-MAN1+= PathFinder.1 adie.1 calculator.1
.else
PLIST_SUB+= APPS="@comment "
.endif
#
.if defined(WITH_OPTIMIZED_CXXFLAGS)
# turn distribution-recommended optimization flags back on
-CXXFLAGS+= -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
+CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
.endif
#
.if defined(WITH_PROFILING)
-CONFIGURE_ARGS+=--with-profiling=gprof
+CONFIGURE_ARGS+= --with-profiling=gprof
.endif
#
.if defined(NOPORTDOCS)
@@ -89,15 +98,11 @@ MAKE_ARGS+= DOC=doc
post-patch:
# CXXFLAGS safeness
-.if !defined(WITH_OPTIMIZED_CXXFLAGS)
- @${REINPLACE_CMD} -E -e \
- 's|-O2|${CXXFLAGS}|g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.else
@${REINPLACE_CMD} -E -e \
- 's|-O2|-O2 ${CXXFLAGS}|g' \
+ 's|-O2|${CXXFLAGS}|g ; \
+ s|-lc_r|${PTHREAD_LIBS}|g ; \
+ s|FOX_INTERFACE_VERSION=0|FOX_INTERFACE_VERSION=${SHVER}|g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
# doc prefix safeness
@${REINPLACE_CMD} -E -e \
's|^(htmldir).*$$|\1=${DOCSDIR}/html|' \
@@ -142,6 +147,10 @@ pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} 'You can disable Shared Memory support by defining WITHOUT_SHM'
.endif
+.if !defined(WITHOUT_XFT)
+ @${ECHO_MSG}
+ @${ECHO_MSG} 'You can disable Xft support by defining WITHOUT_XFT'
+.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/fox-devel/distinfo b/x11-toolkits/fox-devel/distinfo
index 633581441c7c..9756dff3b095 100644
--- a/x11-toolkits/fox-devel/distinfo
+++ b/x11-toolkits/fox-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (fox-1.1.42.tar.gz) = e3dec66f5eb28f3633650794104da013
-SIZE (fox-1.1.42.tar.gz) = 3133289
+MD5 (fox-1.2.1.tar.gz) = 87e78df306189087b76271fbfbcd73b1
+SIZE (fox-1.2.1.tar.gz) = 3770146
diff --git a/x11-toolkits/fox-devel/files/patch-src::FXFile.cpp b/x11-toolkits/fox-devel/files/patch-src::FXFile.cpp
new file mode 100644
index 000000000000..1edb77d8c85f
--- /dev/null
+++ b/x11-toolkits/fox-devel/files/patch-src::FXFile.cpp
@@ -0,0 +1,29 @@
+--- src/FXFile.cpp.orig Fri Apr 16 23:25:33 2004
++++ src/FXFile.cpp Sat May 22 13:13:48 2004
+@@ -159,7 +159,7 @@
+ // Get home directory for a given user
+ FXString FXFile::getUserDirectory(const FXString& user){
+ #ifndef WIN32
+-#ifdef FOX_THREAD_SAFE
++#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
+ struct passwd pwdresult,*pwd;
+ char buffer[1024];
+ if(user.empty()){
+@@ -1032,7 +1032,7 @@
+ FXString FXFile::owner(FXuint uid){
+ FXchar result[64];
+ #ifndef WIN32
+-#ifdef FOX_THREAD_SAFE
++#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
+ struct passwd pwdresult,*pwd;
+ char buffer[1024];
+ if(getpwuid_r(uid,&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
+@@ -1050,7 +1050,7 @@
+ FXString FXFile::group(FXuint gid){
+ FXchar result[64];
+ #ifndef WIN32
+-#ifdef FOX_THREAD_SAFE
++#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
+ ::group grpresult;
+ ::group *grp;
+ char buffer[1024];
diff --git a/x11-toolkits/fox-devel/pkg-plist b/x11-toolkits/fox-devel/pkg-plist
index 14f9e36dfada..1a7ff58565f0 100644
--- a/x11-toolkits/fox-devel/pkg-plist
+++ b/x11-toolkits/fox-devel/pkg-plist
@@ -10,9 +10,11 @@ include/fox-%%MAJORVER%%/FXArray.h
include/fox-%%MAJORVER%%/FXArrowButton.h
include/fox-%%MAJORVER%%/FXBMPIcon.h
include/fox-%%MAJORVER%%/FXBMPImage.h
+include/fox-%%MAJORVER%%/FXBZStream.h
include/fox-%%MAJORVER%%/FXBitmap.h
+include/fox-%%MAJORVER%%/FXBitmapFrame.h
+include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
-include/fox-%%MAJORVER%%/FXBZStream.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCanvas.h
include/fox-%%MAJORVER%%/FXCharset.h
@@ -70,9 +72,9 @@ include/fox-%%MAJORVER%%/FXGLSphere.h
include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
+include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
-include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXHash.h
include/fox-%%MAJORVER%%/FXHeader.h
include/fox-%%MAJORVER%%/FXHorizontalFrame.h
@@ -90,14 +92,14 @@ include/fox-%%MAJORVER%%/FXJPGImage.h
include/fox-%%MAJORVER%%/FXLabel.h
include/fox-%%MAJORVER%%/FXList.h
include/fox-%%MAJORVER%%/FXListBox.h
-include/fox-%%MAJORVER%%/FXMat3d.h
-include/fox-%%MAJORVER%%/FXMat3f.h
-include/fox-%%MAJORVER%%/FXMat4d.h
-include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMDIButton.h
include/fox-%%MAJORVER%%/FXMDIChild.h
include/fox-%%MAJORVER%%/FXMDIClient.h
include/fox-%%MAJORVER%%/FXMainWindow.h
+include/fox-%%MAJORVER%%/FXMat3d.h
+include/fox-%%MAJORVER%%/FXMat3f.h
+include/fox-%%MAJORVER%%/FXMat4d.h
+include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMatrix.h
include/fox-%%MAJORVER%%/FXMemoryStream.h
include/fox-%%MAJORVER%%/FXMenuBar.h
@@ -132,7 +134,9 @@ include/fox-%%MAJORVER%%/FXQuatf.h
include/fox-%%MAJORVER%%/FXRGBIcon.h
include/fox-%%MAJORVER%%/FXRGBImage.h
include/fox-%%MAJORVER%%/FXRadioButton.h
-include/fox-%%MAJORVER%%/FXRange.h
+include/fox-%%MAJORVER%%/FXRanged.h
+include/fox-%%MAJORVER%%/FXRangef.h
+include/fox-%%MAJORVER%%/FXRealSlider.h
include/fox-%%MAJORVER%%/FXRealSpinner.h
include/fox-%%MAJORVER%%/FXRecentFiles.h
include/fox-%%MAJORVER%%/FXRectangle.h
@@ -144,6 +148,7 @@ include/fox-%%MAJORVER%%/FXRootWindow.h
include/fox-%%MAJORVER%%/FXRuler.h
include/fox-%%MAJORVER%%/FXScrollArea.h
include/fox-%%MAJORVER%%/FXScrollBar.h
+include/fox-%%MAJORVER%%/FXScrollPane.h
include/fox-%%MAJORVER%%/FXScrollWindow.h
include/fox-%%MAJORVER%%/FXSearchDialog.h
include/fox-%%MAJORVER%%/FXSeparator.h
@@ -152,9 +157,10 @@ include/fox-%%MAJORVER%%/FXShell.h
include/fox-%%MAJORVER%%/FXShutter.h
include/fox-%%MAJORVER%%/FXSize.h
include/fox-%%MAJORVER%%/FXSlider.h
+include/fox-%%MAJORVER%%/FXSphered.h
+include/fox-%%MAJORVER%%/FXSpheref.h
include/fox-%%MAJORVER%%/FXSpinner.h
include/fox-%%MAJORVER%%/FXSplitter.h
-include/fox-%%MAJORVER%%/FXScrollPane.h
include/fox-%%MAJORVER%%/FXSpring.h
include/fox-%%MAJORVER%%/FXStatusBar.h
include/fox-%%MAJORVER%%/FXStatusLine.h
@@ -173,6 +179,7 @@ include/fox-%%MAJORVER%%/FXTable.h
include/fox-%%MAJORVER%%/FXText.h
include/fox-%%MAJORVER%%/FXTextCodec.h
include/fox-%%MAJORVER%%/FXTextField.h
+include/fox-%%MAJORVER%%/FXThread.h
include/fox-%%MAJORVER%%/FXToggleButton.h
include/fox-%%MAJORVER%%/FXToolBar.h
include/fox-%%MAJORVER%%/FXToolBarGrip.h
@@ -203,54 +210,63 @@ include/fox-%%MAJORVER%%/FXXBMIcon.h
include/fox-%%MAJORVER%%/FXXBMImage.h
include/fox-%%MAJORVER%%/FXXPMIcon.h
include/fox-%%MAJORVER%%/FXXPMImage.h
+include/fox-%%MAJORVER%%/chart/FXChart.h
include/fox-%%MAJORVER%%/fx.h
include/fox-%%MAJORVER%%/fx3d.h
include/fox-%%MAJORVER%%/fxdefs.h
include/fox-%%MAJORVER%%/fxkeys.h
include/fox-%%MAJORVER%%/fxver.h
include/fox-%%MAJORVER%%/xincs.h
-include/fox-%%MAJORVER%%/chart/FXChart.h
lib/libCHART-%%MAJORVER%%.a
-lib/libCHART-%%MAJORVER%%.la
lib/libCHART-%%MAJORVER%%.so
lib/libCHART-%%MAJORVER%%.so.%%SHVER%%
lib/libFOX-%%MAJORVER%%.a
-lib/libFOX-%%MAJORVER%%.la
lib/libFOX-%%MAJORVER%%.so
lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/adie.gif
%%PORTDOCS%%%%DOCSDIR%%/html/adie.html
-%%PORTDOCS%%%%DOCSDIR%%/html/adie.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_colors.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_del.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_edit.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_font.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_lang.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_pat.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_style.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_syntax.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_colors.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_edit.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_font.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_sty.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/analysisview.png
%%PORTDOCS%%%%DOCSDIR%%/html/app.html
+%%PORTDOCS%%%%DOCSDIR%%/html/aqx_linux_visualizacao_peq.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/arithmedrill-screenshot.png
%%PORTDOCS%%%%DOCSDIR%%/html/arithmedrill-screenshot_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/bigpenguin.png
+%%PORTDOCS%%%%DOCSDIR%%/html/boskalisday.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/boskalisnite.gif
%%PORTDOCS%%%%DOCSDIR%%/html/calc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/clipboard.html
+%%PORTDOCS%%%%DOCSDIR%%/html/clview_icon.gif
%%PORTDOCS%%%%DOCSDIR%%/html/colordialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/cometassay.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/consulting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/contact.gif
%%PORTDOCS%%%%DOCSDIR%%/html/datatarget.html
%%PORTDOCS%%%%DOCSDIR%%/html/dirdialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/dlgedit1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/dlgedit2.png
%%PORTDOCS%%%%DOCSDIR%%/html/doc.html
%%PORTDOCS%%%%DOCSDIR%%/html/download.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.cfg
%%PORTDOCS%%%%DOCSDIR%%/html/draganddrop.html
+%%PORTDOCS%%%%DOCSDIR%%/html/emso_screen.png
+%%PORTDOCS%%%%DOCSDIR%%/html/emso_screen_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/fifthplanet.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/filedialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/filefuncs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/filter.pl
%%PORTDOCS%%%%DOCSDIR%%/html/focus.html
%%PORTDOCS%%%%DOCSDIR%%/html/fontdialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/fonts.html
%%PORTDOCS%%%%DOCSDIR%%/html/footer.html
%%PORTDOCS%%%%DOCSDIR%%/html/foreword.html
+%%PORTDOCS%%%%DOCSDIR%%/html/fox.gif
%%PORTDOCS%%%%DOCSDIR%%/html/fox.html
%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc_prefdialog_01_small.jpg
@@ -270,10 +286,13 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/icons.html
%%PORTDOCS%%%%DOCSDIR%%/html/ill.gif
%%PORTDOCS%%%%DOCSDIR%%/html/ilr.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/imagedebugger.gif
%%PORTDOCS%%%%DOCSDIR%%/html/innernerd.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/install.html
%%PORTDOCS%%%%DOCSDIR%%/html/introduction.html
%%PORTDOCS%%%%DOCSDIR%%/html/iul.gif
%%PORTDOCS%%%%DOCSDIR%%/html/iur.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/layout.gif
%%PORTDOCS%%%%DOCSDIR%%/html/layout.html
%%PORTDOCS%%%%DOCSDIR%%/html/license.html
%%PORTDOCS%%%%DOCSDIR%%/html/line.gif
@@ -283,6 +302,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/mouse.gif
%%PORTDOCS%%%%DOCSDIR%%/html/nerd_inside.gif
%%PORTDOCS%%%%DOCSDIR%%/html/news.html
+%%PORTDOCS%%%%DOCSDIR%%/html/news1.html
%%PORTDOCS%%%%DOCSDIR%%/html/oldfox.html
%%PORTDOCS%%%%DOCSDIR%%/html/oll.gif
%%PORTDOCS%%%%DOCSDIR%%/html/olr.gif
@@ -300,8 +320,11 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/registry.html
%%PORTDOCS%%%%DOCSDIR%%/html/replacedialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/rex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rezound_thumb.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/scenegraphnavigator.gif
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots.html
%%PORTDOCS%%%%DOCSDIR%%/html/scribble.png
+%%PORTDOCS%%%%DOCSDIR%%/html/scriptolutions.gif
%%PORTDOCS%%%%DOCSDIR%%/html/searchdialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/serialization.html
%%PORTDOCS%%%%DOCSDIR%%/html/sgitextedit.png
@@ -315,13 +338,16 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
%%PORTDOCS%%%%DOCSDIR%%/html/table.png
%%PORTDOCS%%%%DOCSDIR%%/html/timers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tmp_vision_snap.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/top.html
%%PORTDOCS%%%%DOCSDIR%%/html/tux.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/tux_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/udine_physics.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour2.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour2_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/widget.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/widgets.html
%%PORTDOCS%%%%DOCSDIR%%/html/win32-libraries.png
%%PORTDOCS%%%%DOCSDIR%%/html/win32-linkoutput.png
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 8012b35f0506..c86efc58fa8b 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -25,60 +25,69 @@ CONFLICTS= fox-1.0.*
LATEST_LINK= fox-devel
-MAJORVER= 1.1
-SHVER= 42
+MAJORVER= 1.2
+SHVER= 1
PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
+USE_GNOME= lthack
USE_GL= yes
-INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-#USE_MOTIF= yes
-USE_LIBTOOL_VER=13
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS+=--with-opengl=mesa --with-x \
- --enable-xthreads
+USE_LIBTOOL_VER= 13
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
+INSTALLS_SHLIB= yes
+
+MAN1= shutterbug.1 reswrap.1
+
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-MAN1= reswrap.1
+.include <bsd.port.pre.mk>
##
## Additional Options
##
#
+.if ${XFREE86_VERSION} < 4 || defined(WITHOUT_XFT)
+CONFIGURE_ARGS+= --with-xft=no
+.else
+CONFIGURE_ARGS+= --with-xft=yes
+CPPFLAGS+= `freetype-config --cflags`
+LDFLAGS+= `freetype-config --libs`
+.endif
+#
.if defined(WITHOUT_SHM)
-CONFIGURE_ARGS+=--with-shm=no
+CONFIGURE_ARGS+= --with-xshm=no
.else
-CONFIGURE_ARGS+=--with-shm=yes
+CONFIGURE_ARGS+= --with-xshm=yes
.endif
#
.if defined(WITH_CUPS)
-CONFIGURE_ARGS+=--enable-cups
+CONFIGURE_ARGS+= --enable-cups
.else
-CONFIGURE_ARGS+=--disable-cups
+CONFIGURE_ARGS+= --disable-cups
.endif
#
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
+CONFIGURE_ARGS+= --enable-debug
.else
-CONFIGURE_ARGS+=--enable-release
+CONFIGURE_ARGS+= --enable-release
.endif
#
.if defined(WITH_FOX_APPLICATIONS)
+MAN1+= PathFinder.1 adie.1 calculator.1
PLIST_SUB+= APPS=""
-
-MAN1+= PathFinder.1 adie.1 calculator.1
.else
PLIST_SUB+= APPS="@comment "
.endif
#
.if defined(WITH_OPTIMIZED_CXXFLAGS)
# turn distribution-recommended optimization flags back on
-CXXFLAGS+= -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
+CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
.endif
#
.if defined(WITH_PROFILING)
-CONFIGURE_ARGS+=--with-profiling=gprof
+CONFIGURE_ARGS+= --with-profiling=gprof
.endif
#
.if defined(NOPORTDOCS)
@@ -89,15 +98,11 @@ MAKE_ARGS+= DOC=doc
post-patch:
# CXXFLAGS safeness
-.if !defined(WITH_OPTIMIZED_CXXFLAGS)
- @${REINPLACE_CMD} -E -e \
- 's|-O2|${CXXFLAGS}|g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.else
@${REINPLACE_CMD} -E -e \
- 's|-O2|-O2 ${CXXFLAGS}|g' \
+ 's|-O2|${CXXFLAGS}|g ; \
+ s|-lc_r|${PTHREAD_LIBS}|g ; \
+ s|FOX_INTERFACE_VERSION=0|FOX_INTERFACE_VERSION=${SHVER}|g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
# doc prefix safeness
@${REINPLACE_CMD} -E -e \
's|^(htmldir).*$$|\1=${DOCSDIR}/html|' \
@@ -142,6 +147,10 @@ pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} 'You can disable Shared Memory support by defining WITHOUT_SHM'
.endif
+.if !defined(WITHOUT_XFT)
+ @${ECHO_MSG}
+ @${ECHO_MSG} 'You can disable Xft support by defining WITHOUT_XFT'
+.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/fox14/distinfo b/x11-toolkits/fox14/distinfo
index 633581441c7c..9756dff3b095 100644
--- a/x11-toolkits/fox14/distinfo
+++ b/x11-toolkits/fox14/distinfo
@@ -1,2 +1,2 @@
-MD5 (fox-1.1.42.tar.gz) = e3dec66f5eb28f3633650794104da013
-SIZE (fox-1.1.42.tar.gz) = 3133289
+MD5 (fox-1.2.1.tar.gz) = 87e78df306189087b76271fbfbcd73b1
+SIZE (fox-1.2.1.tar.gz) = 3770146
diff --git a/x11-toolkits/fox14/files/patch-src::FXFile.cpp b/x11-toolkits/fox14/files/patch-src::FXFile.cpp
new file mode 100644
index 000000000000..1edb77d8c85f
--- /dev/null
+++ b/x11-toolkits/fox14/files/patch-src::FXFile.cpp
@@ -0,0 +1,29 @@
+--- src/FXFile.cpp.orig Fri Apr 16 23:25:33 2004
++++ src/FXFile.cpp Sat May 22 13:13:48 2004
+@@ -159,7 +159,7 @@
+ // Get home directory for a given user
+ FXString FXFile::getUserDirectory(const FXString& user){
+ #ifndef WIN32
+-#ifdef FOX_THREAD_SAFE
++#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
+ struct passwd pwdresult,*pwd;
+ char buffer[1024];
+ if(user.empty()){
+@@ -1032,7 +1032,7 @@
+ FXString FXFile::owner(FXuint uid){
+ FXchar result[64];
+ #ifndef WIN32
+-#ifdef FOX_THREAD_SAFE
++#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
+ struct passwd pwdresult,*pwd;
+ char buffer[1024];
+ if(getpwuid_r(uid,&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
+@@ -1050,7 +1050,7 @@
+ FXString FXFile::group(FXuint gid){
+ FXchar result[64];
+ #ifndef WIN32
+-#ifdef FOX_THREAD_SAFE
++#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
+ ::group grpresult;
+ ::group *grp;
+ char buffer[1024];
diff --git a/x11-toolkits/fox14/pkg-plist b/x11-toolkits/fox14/pkg-plist
index 14f9e36dfada..1a7ff58565f0 100644
--- a/x11-toolkits/fox14/pkg-plist
+++ b/x11-toolkits/fox14/pkg-plist
@@ -10,9 +10,11 @@ include/fox-%%MAJORVER%%/FXArray.h
include/fox-%%MAJORVER%%/FXArrowButton.h
include/fox-%%MAJORVER%%/FXBMPIcon.h
include/fox-%%MAJORVER%%/FXBMPImage.h
+include/fox-%%MAJORVER%%/FXBZStream.h
include/fox-%%MAJORVER%%/FXBitmap.h
+include/fox-%%MAJORVER%%/FXBitmapFrame.h
+include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
-include/fox-%%MAJORVER%%/FXBZStream.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCanvas.h
include/fox-%%MAJORVER%%/FXCharset.h
@@ -70,9 +72,9 @@ include/fox-%%MAJORVER%%/FXGLSphere.h
include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
+include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
-include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXHash.h
include/fox-%%MAJORVER%%/FXHeader.h
include/fox-%%MAJORVER%%/FXHorizontalFrame.h
@@ -90,14 +92,14 @@ include/fox-%%MAJORVER%%/FXJPGImage.h
include/fox-%%MAJORVER%%/FXLabel.h
include/fox-%%MAJORVER%%/FXList.h
include/fox-%%MAJORVER%%/FXListBox.h
-include/fox-%%MAJORVER%%/FXMat3d.h
-include/fox-%%MAJORVER%%/FXMat3f.h
-include/fox-%%MAJORVER%%/FXMat4d.h
-include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMDIButton.h
include/fox-%%MAJORVER%%/FXMDIChild.h
include/fox-%%MAJORVER%%/FXMDIClient.h
include/fox-%%MAJORVER%%/FXMainWindow.h
+include/fox-%%MAJORVER%%/FXMat3d.h
+include/fox-%%MAJORVER%%/FXMat3f.h
+include/fox-%%MAJORVER%%/FXMat4d.h
+include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMatrix.h
include/fox-%%MAJORVER%%/FXMemoryStream.h
include/fox-%%MAJORVER%%/FXMenuBar.h
@@ -132,7 +134,9 @@ include/fox-%%MAJORVER%%/FXQuatf.h
include/fox-%%MAJORVER%%/FXRGBIcon.h
include/fox-%%MAJORVER%%/FXRGBImage.h
include/fox-%%MAJORVER%%/FXRadioButton.h
-include/fox-%%MAJORVER%%/FXRange.h
+include/fox-%%MAJORVER%%/FXRanged.h
+include/fox-%%MAJORVER%%/FXRangef.h
+include/fox-%%MAJORVER%%/FXRealSlider.h
include/fox-%%MAJORVER%%/FXRealSpinner.h
include/fox-%%MAJORVER%%/FXRecentFiles.h
include/fox-%%MAJORVER%%/FXRectangle.h
@@ -144,6 +148,7 @@ include/fox-%%MAJORVER%%/FXRootWindow.h
include/fox-%%MAJORVER%%/FXRuler.h
include/fox-%%MAJORVER%%/FXScrollArea.h
include/fox-%%MAJORVER%%/FXScrollBar.h
+include/fox-%%MAJORVER%%/FXScrollPane.h
include/fox-%%MAJORVER%%/FXScrollWindow.h
include/fox-%%MAJORVER%%/FXSearchDialog.h
include/fox-%%MAJORVER%%/FXSeparator.h
@@ -152,9 +157,10 @@ include/fox-%%MAJORVER%%/FXShell.h
include/fox-%%MAJORVER%%/FXShutter.h
include/fox-%%MAJORVER%%/FXSize.h
include/fox-%%MAJORVER%%/FXSlider.h
+include/fox-%%MAJORVER%%/FXSphered.h
+include/fox-%%MAJORVER%%/FXSpheref.h
include/fox-%%MAJORVER%%/FXSpinner.h
include/fox-%%MAJORVER%%/FXSplitter.h
-include/fox-%%MAJORVER%%/FXScrollPane.h
include/fox-%%MAJORVER%%/FXSpring.h
include/fox-%%MAJORVER%%/FXStatusBar.h
include/fox-%%MAJORVER%%/FXStatusLine.h
@@ -173,6 +179,7 @@ include/fox-%%MAJORVER%%/FXTable.h
include/fox-%%MAJORVER%%/FXText.h
include/fox-%%MAJORVER%%/FXTextCodec.h
include/fox-%%MAJORVER%%/FXTextField.h
+include/fox-%%MAJORVER%%/FXThread.h
include/fox-%%MAJORVER%%/FXToggleButton.h
include/fox-%%MAJORVER%%/FXToolBar.h
include/fox-%%MAJORVER%%/FXToolBarGrip.h
@@ -203,54 +210,63 @@ include/fox-%%MAJORVER%%/FXXBMIcon.h
include/fox-%%MAJORVER%%/FXXBMImage.h
include/fox-%%MAJORVER%%/FXXPMIcon.h
include/fox-%%MAJORVER%%/FXXPMImage.h
+include/fox-%%MAJORVER%%/chart/FXChart.h
include/fox-%%MAJORVER%%/fx.h
include/fox-%%MAJORVER%%/fx3d.h
include/fox-%%MAJORVER%%/fxdefs.h
include/fox-%%MAJORVER%%/fxkeys.h
include/fox-%%MAJORVER%%/fxver.h
include/fox-%%MAJORVER%%/xincs.h
-include/fox-%%MAJORVER%%/chart/FXChart.h
lib/libCHART-%%MAJORVER%%.a
-lib/libCHART-%%MAJORVER%%.la
lib/libCHART-%%MAJORVER%%.so
lib/libCHART-%%MAJORVER%%.so.%%SHVER%%
lib/libFOX-%%MAJORVER%%.a
-lib/libFOX-%%MAJORVER%%.la
lib/libFOX-%%MAJORVER%%.so
lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/adie.gif
%%PORTDOCS%%%%DOCSDIR%%/html/adie.html
-%%PORTDOCS%%%%DOCSDIR%%/html/adie.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_colors.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_del.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_edit.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_font.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_lang.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_pat.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_style.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_syntax.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_colors.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_edit.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_font.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/adie_sty.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/analysisview.png
%%PORTDOCS%%%%DOCSDIR%%/html/app.html
+%%PORTDOCS%%%%DOCSDIR%%/html/aqx_linux_visualizacao_peq.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/arithmedrill-screenshot.png
%%PORTDOCS%%%%DOCSDIR%%/html/arithmedrill-screenshot_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/bigpenguin.png
+%%PORTDOCS%%%%DOCSDIR%%/html/boskalisday.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/boskalisnite.gif
%%PORTDOCS%%%%DOCSDIR%%/html/calc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/clipboard.html
+%%PORTDOCS%%%%DOCSDIR%%/html/clview_icon.gif
%%PORTDOCS%%%%DOCSDIR%%/html/colordialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/cometassay.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/consulting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/contact.gif
%%PORTDOCS%%%%DOCSDIR%%/html/datatarget.html
%%PORTDOCS%%%%DOCSDIR%%/html/dirdialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/dlgedit1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/dlgedit2.png
%%PORTDOCS%%%%DOCSDIR%%/html/doc.html
%%PORTDOCS%%%%DOCSDIR%%/html/download.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.cfg
%%PORTDOCS%%%%DOCSDIR%%/html/draganddrop.html
+%%PORTDOCS%%%%DOCSDIR%%/html/emso_screen.png
+%%PORTDOCS%%%%DOCSDIR%%/html/emso_screen_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/fifthplanet.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/filedialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/filefuncs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/filter.pl
%%PORTDOCS%%%%DOCSDIR%%/html/focus.html
%%PORTDOCS%%%%DOCSDIR%%/html/fontdialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/fonts.html
%%PORTDOCS%%%%DOCSDIR%%/html/footer.html
%%PORTDOCS%%%%DOCSDIR%%/html/foreword.html
+%%PORTDOCS%%%%DOCSDIR%%/html/fox.gif
%%PORTDOCS%%%%DOCSDIR%%/html/fox.html
%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc_prefdialog_01_small.jpg
@@ -270,10 +286,13 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/icons.html
%%PORTDOCS%%%%DOCSDIR%%/html/ill.gif
%%PORTDOCS%%%%DOCSDIR%%/html/ilr.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/imagedebugger.gif
%%PORTDOCS%%%%DOCSDIR%%/html/innernerd.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/install.html
%%PORTDOCS%%%%DOCSDIR%%/html/introduction.html
%%PORTDOCS%%%%DOCSDIR%%/html/iul.gif
%%PORTDOCS%%%%DOCSDIR%%/html/iur.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/layout.gif
%%PORTDOCS%%%%DOCSDIR%%/html/layout.html
%%PORTDOCS%%%%DOCSDIR%%/html/license.html
%%PORTDOCS%%%%DOCSDIR%%/html/line.gif
@@ -283,6 +302,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/mouse.gif
%%PORTDOCS%%%%DOCSDIR%%/html/nerd_inside.gif
%%PORTDOCS%%%%DOCSDIR%%/html/news.html
+%%PORTDOCS%%%%DOCSDIR%%/html/news1.html
%%PORTDOCS%%%%DOCSDIR%%/html/oldfox.html
%%PORTDOCS%%%%DOCSDIR%%/html/oll.gif
%%PORTDOCS%%%%DOCSDIR%%/html/olr.gif
@@ -300,8 +320,11 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/registry.html
%%PORTDOCS%%%%DOCSDIR%%/html/replacedialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/rex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rezound_thumb.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/scenegraphnavigator.gif
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots.html
%%PORTDOCS%%%%DOCSDIR%%/html/scribble.png
+%%PORTDOCS%%%%DOCSDIR%%/html/scriptolutions.gif
%%PORTDOCS%%%%DOCSDIR%%/html/searchdialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/serialization.html
%%PORTDOCS%%%%DOCSDIR%%/html/sgitextedit.png
@@ -315,13 +338,16 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
%%PORTDOCS%%%%DOCSDIR%%/html/table.png
%%PORTDOCS%%%%DOCSDIR%%/html/timers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tmp_vision_snap.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/top.html
%%PORTDOCS%%%%DOCSDIR%%/html/tux.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/tux_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/udine_physics.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour2.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour2_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/widget.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/widgets.html
%%PORTDOCS%%%%DOCSDIR%%/html/win32-libraries.png
%%PORTDOCS%%%%DOCSDIR%%/html/win32-linkoutput.png