aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/algol68g/Makefile59
-rw-r--r--lang/algol68g/distinfo6
-rw-r--r--lang/algol68g/files/patch-configure43
-rw-r--r--lang/algol68g/files/patch-source_algol68g.h15
-rw-r--r--lang/algol68g/pkg-descr7
6 files changed, 131 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index f256e6b0c2c6..17f263ea47e7 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -10,6 +10,7 @@
SUBDIR += abcl
SUBDIR += afnix
SUBDIR += alisp
+ SUBDIR += algol68g
SUBDIR += arena
SUBDIR += asn1c
SUBDIR += atlast
diff --git a/lang/algol68g/Makefile b/lang/algol68g/Makefile
new file mode 100644
index 000000000000..fbc214ce035c
--- /dev/null
+++ b/lang/algol68g/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: xshttpd
+# Date created: 9 September 2010
+# Whom: Johan van Selst <johans@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= algol68g
+PORTVERSION= 2.0.0
+CATEGORIES= lang
+MASTER_SITES= http://www.xs4all.nl/~jmvdveer/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tgz
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= Alogol 68 Genie compiler
+
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
+
+OPTIONS= PLOT "GNU plot support" On \
+ PGSQL "Postgresql support" On
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= -macosx
+CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
+MAKEFILE= makefile
+
+MAN1= a68g.1
+PLIST_FILES= bin/a68g include/a68g.h
+
+.include <bsd.port.options.mk>
+
+.ifdef WITH_PLOT
+LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
+.endif
+
+.ifdef WITH_PGSQL
+USE_PGSQL= yes
+.endif
+
+post-install:
+ @:
+.ifndef NOPORTEXAMPLES
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
+.endif
+.ifndef NOPORTDOCS
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${PORTDOCS} ${DOCSDIR}
+
+PORTDOCS= a68g-doc.pdf
+DISTFILES+= ${PORTDOCS}
+.endif
+
+.ifndef NOPORTEXAMPLES
+PORTEXAMPLES= *
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/algol68g/distinfo b/lang/algol68g/distinfo
new file mode 100644
index 000000000000..5c8afe6c13bd
--- /dev/null
+++ b/lang/algol68g/distinfo
@@ -0,0 +1,6 @@
+MD5 (algol68g-2.0.0.tgz) = fd2baa4c86d70c09f8c9d8117368f826
+SHA256 (algol68g-2.0.0.tgz) = 9ce74cecd22945d00384fe97746cf21c030caaa10d1cf31b01f09dc8d986173c
+SIZE (algol68g-2.0.0.tgz) = 369264
+MD5 (a68g-doc.pdf) = 5618ad6dae4376411e14961a1e134e56
+SHA256 (a68g-doc.pdf) = 064b6761207d937aa704d245fc871a072f5a33ea23a346cb136ec8b2078ea321
+SIZE (a68g-doc.pdf) = 2997138
diff --git a/lang/algol68g/files/patch-configure b/lang/algol68g/files/patch-configure
new file mode 100644
index 000000000000..9b1a29e06dd6
--- /dev/null
+++ b/lang/algol68g/files/patch-configure
@@ -0,0 +1,43 @@
+--- configure.orig 2010-09-07 00:54:27.000000000 +0200
++++ configure 2010-09-09 23:01:01.000000000 +0200
+@@ -38,7 +38,7 @@ PWD=`pwd`
+ SYS_INC=/usr/include
+ SYS_LIB=/usr/lib
+ SYS_BIN=/usr/bin
+-SYS_LOC=/usr/local
++SYS_LOC=$LOCALBASE
+ LOC_INC=$SYS_LOC/include
+ LOC_LIB=$SYS_LOC/lib
+ A68G_CHECK="./regression-$VERSION_NUMBER"
+@@ -865,11 +865,11 @@ then
+ echo "SQL_DIR=$SQL_DIR">>$BUILD_FILE
+ echo "SQL_LIBS=-lpq" 1>>$BUILD_FILE
+ echo "SQL_FLAG=-DENABLE_POSTGRESQL" 1>>$BUILD_FILE
+- elif [ -f $SYS_LIB/libpq.so -o -f $SYS_LIB/libpq.a -o -f $SYS_LIB/libpq.dylib ]
++ elif [ -f $LOC_LIB/libpq.so -o -f $SYS_LIB/libpq.a -o -f $SYS_LIB/libpq.dylib ]
+ then
+ libpostgresql=yes
+ echo "yes"
+- echo "SQL_DIR=`dirname $SYS_LIB`">>$BUILD_FILE
++ echo "SQL_DIR=`dirname $LOC_LIB`">>$BUILD_FILE
+ echo "SQL_LIBS=-lpq" 1>>$BUILD_FILE
+ echo "SQL_FLAG=-DENABLE_POSTGRESQL" 1>>$BUILD_FILE
+ else
+@@ -996,7 +996,7 @@ FLAGS=$(CPPFLAGS) $(STD_CFLAGS) $(POSIX_
+ all: a68g
+ a68g: $(CS)
+ @echo "building a68g ..."
+- @$(CC) $(CS) -Wl $(CFLAGS) $(STD_LD_FLAGS) $(POSIX_THREADS_LIBS) $(PLOTUTILS_LIBS) $(GSL_LIBS) $(CURSES_LIBS) $(SQL_LIBS) $(READLINE_LIBS) -lm -ldl $(LD_FLAGS) -o a68g
++ @$(CC) $(CS) -Wl $(CFLAGS) $(STD_LD_FLAGS) $(POSIX_THREADS_LIBS) $(PLOTUTILS_LIBS) $(GSL_LIBS) $(CURSES_LIBS) $(SQL_LIBS) $(READLINE_LIBS) -lm $(LD_FLAGS) -o a68g
+ $(CS): $(HS)
+ .c.o:
+ @echo "compiling $<"
+@@ -1142,7 +1142,7 @@ int main (int argc, char **argv) {
+ printf ("%s", PACKAGE_VERSION);
+ }
+ _ACEOF
+- gcc pgvers.c -I$SQL_DIR/include -o pgvers
++ gcc pgvers.c -I$LOC_INC -o pgvers
+ echo "#define A68_PG_VERSION \"`./pgvers`\"" 1>>$CONFIG_FILE
+ rm pgvers*
+ else
diff --git a/lang/algol68g/files/patch-source_algol68g.h b/lang/algol68g/files/patch-source_algol68g.h
new file mode 100644
index 000000000000..f8e95dec9dbd
--- /dev/null
+++ b/lang/algol68g/files/patch-source_algol68g.h
@@ -0,0 +1,15 @@
+--- source/algol68g.h.orig 2010-09-09 10:16:58.000000000 +0200
++++ source/algol68g.h 2010-09-09 09:58:41.000000000 +0200
+@@ -65,12 +65,6 @@ typedef unsigned STATUS_MASK;
+ #endif
+ #endif
+
+-#if defined ENABLE_MACOSX
+-#define __off_t off_t
+-#define __pid_t pid_t
+-#define __mode_t mode_t
+-#endif
+-
+ #if defined ENABLE_POSTGRESQL
+ #include <libpq-fe.h>
+ #endif
diff --git a/lang/algol68g/pkg-descr b/lang/algol68g/pkg-descr
new file mode 100644
index 000000000000..99fd85e21338
--- /dev/null
+++ b/lang/algol68g/pkg-descr
@@ -0,0 +1,7 @@
+The development of Algol played an important role in establishing
+computer science as an academic discipline. The Algol 68 Genie project
+preserves Algol 68 out of educational as well as scientific-historical
+interest, by making available Algol 68 Genie; a recent, well-featured
+implementation written from scratch.
+
+WWW: http://www.xs4all.nl/~jmvdveer/algol.html