aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/doscan/Makefile31
-rw-r--r--security/doscan/distinfo1
-rw-r--r--security/doscan/files/patch-src::subnets.c10
-rw-r--r--security/doscan/pkg-descr24
-rw-r--r--security/doscan/pkg-plist3
6 files changed, 70 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1ce4f7312d90..5480de9971b6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -58,6 +58,7 @@
SUBDIR += digest
SUBDIR += dirmngr
SUBDIR += donkey
+ SUBDIR += doscan
SUBDIR += dropbear
SUBDIR += drweb
SUBDIR += drweb-postfix
diff --git a/security/doscan/Makefile b/security/doscan/Makefile
new file mode 100644
index 000000000000..1beae4ecdd98
--- /dev/null
+++ b/security/doscan/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: doscan
+# Date created: 24 Sept 2003
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= doscan
+PORTVERSION= 0.1.6
+CATEGORIES= security net
+MASTER_SITES= http://static.enyo.de/fw/releases/doscan/
+
+MAINTAINER= Janos.Mohacsi@bsd.hu
+COMMENT= Tool to quickly scan your network for machines listening on a TCP port
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+DOC_FILES= README
+MAN1= doscan.1
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/doscan/distinfo b/security/doscan/distinfo
new file mode 100644
index 000000000000..d2b4d76f1819
--- /dev/null
+++ b/security/doscan/distinfo
@@ -0,0 +1 @@
+MD5 (doscan-0.1.6.tar.gz) = e915c705c69e76d30f65333ea39625b1
diff --git a/security/doscan/files/patch-src::subnets.c b/security/doscan/files/patch-src::subnets.c
new file mode 100644
index 000000000000..59a4b80cac6d
--- /dev/null
+++ b/security/doscan/files/patch-src::subnets.c
@@ -0,0 +1,10 @@
+--- src/subnets.c.orig Wed Sep 24 13:28:27 2003
++++ src/subnets.c Wed Sep 24 13:29:59 2003
+@@ -37,7 +37,6 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <malloc.h>
+
+ static ipv4_prefix_t *subnets = 0;
+ /* list of subnets, terminated by the 0/0 prefix */
diff --git a/security/doscan/pkg-descr b/security/doscan/pkg-descr
new file mode 100644
index 000000000000..3dea29469016
--- /dev/null
+++ b/security/doscan/pkg-descr
@@ -0,0 +1,24 @@
+Doscan is a tool to quickly scan your network for machines listening on a
+TCP port, opening thousands of TCP connections in parallel.
+Features
+ High scanning rate: five to ten minutes per 100,000 addresses (which
+are sparsely populated with hosts), with rather conservative timeouts.
+ Load distribution: doscan scans the addresses in a seemingly random
+order. If your scan host is connected to a central router, this ensures
+that the load is distributed across your network, and you are
+stress-tesing just a single router, and not your edge devices.
+ Low memory consumption: memory usage is proportional to the number
+of hosts which have responded so far, and to the number of parallel
+connections. The total number of addresses does not influence memory usage
+in any way.
+ Can collect responses: doscan optionally records data which is sent
+by the hosts which are being scanned. You can even specify a regular
+expresson to extract part of a server banner, and a message to send to
+trigger a response (great for determining HTTP server versions).
+ Extensibility: It is possible to add special handlers for TCP-based
+protocols, using a straightforward interface.
+ It supports scanning the vulnerable Microsoft DCOM implementation.
+
+WWW: http://www.enyo.de/fw/software/doscan/
+
+Janos Mohacsi <janos.mohacsi@bsd.hu>
diff --git a/security/doscan/pkg-plist b/security/doscan/pkg-plist
new file mode 100644
index 000000000000..039472891c3d
--- /dev/null
+++ b/security/doscan/pkg-plist
@@ -0,0 +1,3 @@
+bin/doscan
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%