aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-torch-geometric/Makefile32
-rw-r--r--misc/py-torch-geometric/distinfo3
-rw-r--r--misc/py-torch-geometric/pkg-descr12
4 files changed, 48 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 8c05866b6585..a65f73d0d3e3 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -467,6 +467,7 @@
SUBDIR += py-tflite
SUBDIR += py-tflite-support
SUBDIR += py-toil
+ SUBDIR += py-torch-geometric
SUBDIR += py-torchvision
SUBDIR += py-tqdm
SUBDIR += py-tvm
diff --git a/misc/py-torch-geometric/Makefile b/misc/py-torch-geometric/Makefile
new file mode 100644
index 000000000000..eb87968fba2e
--- /dev/null
+++ b/misc/py-torch-geometric/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= torch-geometric
+DISTVERSION= 2.3.1
+CATEGORIES= misc python # machine-learning
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Graph neural network library for PyTorch
+WWW= https://pyg.org/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=5.8.0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.7+
+USE_PYTHON= pep517 autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-torch-geometric/distinfo b/misc/py-torch-geometric/distinfo
new file mode 100644
index 000000000000..bd2587a23655
--- /dev/null
+++ b/misc/py-torch-geometric/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685400945
+SHA256 (torch_geometric-2.3.1.tar.gz) = 454fd0bbc128a17a4b9d15010ba9f66d48ec8cd7277991b888a7770263fa125d
+SIZE (torch_geometric-2.3.1.tar.gz) = 661639
diff --git a/misc/py-torch-geometric/pkg-descr b/misc/py-torch-geometric/pkg-descr
new file mode 100644
index 000000000000..b8a47aa9a745
--- /dev/null
+++ b/misc/py-torch-geometric/pkg-descr
@@ -0,0 +1,12 @@
+PyG (PyTorch Geometric) is a library built upon PyTorch to easily write and
+train Graph Neural Networks (GNNs) for a wide range of applications related
+to structured data.
+
+It consists of various methods for deep learning on graphs and other irregular
+structures, also known as geometric deep learning, from a variety of published
+papers. In addition, it consists of easy-to-use mini-batch loaders for
+operating on many small and single giant graphs, multi GPU-support,
+torch.compile support, DataPipe support, a large number of common benchmark
+datasets (based on simple interfaces to create your own), the GraphGym
+experiment manager, and helpful transforms, both for learning on arbitrary
+graphs as well as on 3D meshes or point clouds.