aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/libjxr/Makefile3
-rw-r--r--net-mgmt/pmacct/Makefile3
-rw-r--r--science/cdf/Makefile3
-rw-r--r--science/hdf/Makefile6
-rw-r--r--security/clambc/Makefile3
-rw-r--r--security/samhain/Makefile4
-rw-r--r--sysutils/fluent-bit/Makefile5
-rw-r--r--sysutils/radeontop/Makefile3
-rw-r--r--sysutils/rovclock/Makefile5
-rw-r--r--textproc/senna/Makefile2
-rw-r--r--www/anyterm/Makefile2
11 files changed, 37 insertions, 2 deletions
diff --git a/graphics/libjxr/Makefile b/graphics/libjxr/Makefile
index 40a1356ef78c..b5a2ecdca19f 100644
--- a/graphics/libjxr/Makefile
+++ b/graphics/libjxr/Makefile
@@ -13,6 +13,9 @@ COMMENT= Library for JPEG XR, a.k.a. Windows MediaTM Photo
LICENSE= BSD
+BROKEN_aarch64= fails to link: cc: error: linker command failed with exit code 1 (use -v to see invocation)
+BROKEN_mips64= fails to build
+
USES= dos2unix uidfix
USE_LDCONFIG= yes
MAKEFILE= BSDmakefile # created by do-configure
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index d87644323e50..4ba4767f9c1c 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -12,6 +12,9 @@ COMMENT= Accounting and aggregation tool for IPv4 and IPv6 traffic
LICENSE= GPLv2
+BROKEN_aarch64= fails to build: undefined reference to sbrk
+BROKEN_powerp64= fails to build: cc: Internal error: Segmentation fault (program ld)
+
USE_RC_SUBR= pmacctd nfacctd sfacctd
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index 0b5399d3169f..4e19a6582d94 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -18,6 +18,9 @@ LICENSE_NAME= NASA/Goddard Space Flight Center
LICENSE_FILE= ${WRKSRC}/CDF_copyright.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_aarch64= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
+BROKEN_armv6= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
+
USES= fortran ncurses
USE_LDCONFIG= yes
MAKE_FLAGS= INSTALLDIR=${STAGEDIR}${PREFIX} OS=freebsd ENV=gnu \
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 01e7fb8fb177..9deb7cf9efaa 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -12,10 +12,12 @@ MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/HDF${PORTVERSION}/src/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libsz.so:science/szip
+BROKEN_powerpc64= Does not build: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'you'
+NOT_FOR_ARCHS= aarch64 armv6
+NOT_FOR_ARCHS_REASON= fails to compile: no machine type has been defined
+
CONFLICTS_INSTALL= netcdf-4.[0-9]*
USES= fortran jpeg libtool tar:bzip2
diff --git a/security/clambc/Makefile b/security/clambc/Makefile
index 9f186aaa3b71..f3d0c3a67ead 100644
--- a/security/clambc/Makefile
+++ b/security/clambc/Makefile
@@ -12,6 +12,9 @@ COMMENT= Bytecode signature compiler for ClamAV
LICENSE= GPLv2
+NOT_FOR_ARCHS= aarch64
+NOT_FOR_ARCHS_REASON= fails to configure: error: Can not set target to build
+
USES= gmake libtool perl5
ALL_TARGET= clambc-only
GNU_CONFIGURE= yes
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index b9da767bc3ec..69a36943d115 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -12,6 +12,10 @@ COMMENT= Samhain Intrusion Detection System
LICENSE= GPLv2
+BROKEN_aarch64= fails to build: undefined reference to sbrk
+BROKEN_mips= fails to configure: error: Could not find the libwrap library
+BROKEN_mips64= fails to configure: error: Could not find the libwrap library
+
OPTIONS_DEFINE= ASM DB_RELOAD DEBUG DNMALLOC ENCRYPT GNUPG IPV6 KCHECK LIBWRAP \
LOGFILE_MONITOR LOGIN_WATCH MAIL MOUNTS_CHECK MYSQL ODBC PGSQL \
PORT_CHECK PROCESS_CHECK POSIX_ACL PRELUDE PTRACE SRP STATIC \
diff --git a/sysutils/fluent-bit/Makefile b/sysutils/fluent-bit/Makefile
index 121465ba7ea7..562038945150 100644
--- a/sysutils/fluent-bit/Makefile
+++ b/sysutils/fluent-bit/Makefile
@@ -11,6 +11,11 @@ COMMENT= Fast and lightweight data forwarder
LICENSE= APACHE20
+BROKEN_aarch64= fails to build: error: unknown type name thread_local
+BROKEN_armv6= fails to configure: failure in cmake
+BROKEN_mips= fails to build: conflicting types for 'restrict'
+BROKEN_mips64= fails to build: conflicting types for 'restrict'
+
USES= cmake
post-stage:
diff --git a/sysutils/radeontop/Makefile b/sysutils/radeontop/Makefile
index dc606e95bdb5..88ee6926f344 100644
--- a/sysutils/radeontop/Makefile
+++ b/sysutils/radeontop/Makefile
@@ -14,6 +14,9 @@ LICENSE= GPLv3
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
libdrm.so:graphics/libdrm
+NOT_FOR_ARCHS= aarch64 armv6 mips mips64
+NOT_FOR_ARCHS_REASON= fails to compile: fatal error: amdgpu_drm.h file not found
+
USE_GITHUB= yes
GH_ACCOUNT= clbr
diff --git a/sysutils/rovclock/Makefile b/sysutils/rovclock/Makefile
index ac5cece70a9b..6481501bb577 100644
--- a/sysutils/rovclock/Makefile
+++ b/sysutils/rovclock/Makefile
@@ -11,6 +11,11 @@ COMMENT= Overclocking utility for ATI Radeon video cards
LICENSE= GPLv2
+BROKEN_aarch64= fails to install: undefined reference to outl
+BROKEN_armv6= fails to install: undefined reference to outl
+BROKEN_mips= fails to install: undefined reference to outl
+BROKEN_mips64= fails to install: undefined reference to outl
+
USES= tar:bzip2
PLIST_FILES= man/man8/${PORTNAME}.8.gz sbin/${PORTNAME}
diff --git a/textproc/senna/Makefile b/textproc/senna/Makefile
index 46d73b51a08e..de257bcdb1ef 100644
--- a/textproc/senna/Makefile
+++ b/textproc/senna/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SFJP/senna/46945
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Embeddable Fulltext Search Engine
+BROKEN_aarch64= does not build: libsenna.so: undefined reference to SEN_ATOMIC_ADD_EX
+BROKEN_armv6= does not build: libsenna.so: undefined reference to SEN_ATOMIC_ADD_EX
BROKEN_powerpc64= does not build: relocation truncated to fit: R_PPC64_TOC16_DS
BROKEN_sparc64= does not build
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index fd9842fdaf01..6b63ac0750d4 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:devel/boost-libs
+BROKEN_aarch64= does not build: libstdc++.so: undefined reference to __floatunditf@GCC_4.2.0
+BROKEN_armv6= does not build: libstdc++.so: undefined reference to __floatunditf@GCC_4.2.0
BROKEN_powerpc64= Does not build: ld: cannot find -lboost_system
USE_RC_SUBR= anytermd