aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/p5-DBIWrapper/Makefile9
-rw-r--r--databases/p5-DBIWrapper/distinfo2
-rw-r--r--databases/p5-DBIWrapper/pkg-plist7
3 files changed, 14 insertions, 4 deletions
diff --git a/databases/p5-DBIWrapper/Makefile b/databases/p5-DBIWrapper/Makefile
index a9b612c4d572..3ae13049b9f6 100644
--- a/databases/p5-DBIWrapper/Makefile
+++ b/databases/p5-DBIWrapper/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DBIWrapper
-PORTVERSION= 0.16
+PORTVERSION= 0.17
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dbiwrapper
@@ -15,12 +15,15 @@ DISTNAME= dbi_wrapper-${PORTVERSION}
MAINTAINER= petef@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+
+
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= DBIWrapper.3
+MAN3= DBIWrapper.3 DBIWrapper::ResultSet.3 DBIWrapper::XMLParser.3
.include <bsd.port.mk>
diff --git a/databases/p5-DBIWrapper/distinfo b/databases/p5-DBIWrapper/distinfo
index a7a857a4a78b..d0d3bd132d27 100644
--- a/databases/p5-DBIWrapper/distinfo
+++ b/databases/p5-DBIWrapper/distinfo
@@ -1 +1 @@
-MD5 (dbi_wrapper-0.16.tar.gz) = 80355f052fd9ec10c1daa8490a4a587d
+MD5 (dbi_wrapper-0.17.tar.gz) = 63df78a0d08cece4d3186a7fc3ebbd30
diff --git a/databases/p5-DBIWrapper/pkg-plist b/databases/p5-DBIWrapper/pkg-plist
index 17a378d1469d..0494d8251188 100644
--- a/databases/p5-DBIWrapper/pkg-plist
+++ b/databases/p5-DBIWrapper/pkg-plist
@@ -1,5 +1,12 @@
lib/perl5/site_perl/%%PERL_VER%%/DBIWrapper.pm
+lib/perl5/site_perl/%%PERL_VER%%/DBIWrapper/ResultSet.pm
+lib/perl5/site_perl/%%PERL_VER%%/DBIWrapper/XMLParser.pm
lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/ResultSet/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/XMLParser/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIWrapper/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIWrapper
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/XMLParser
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/ResultSet
@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/DBIWrapper