aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--finance/Makefile1
-rw-r--r--finance/cointop/Makefile32
-rw-r--r--finance/cointop/distinfo3
-rw-r--r--finance/cointop/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index c54252976968..1815f474f75b 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -27,6 +27,7 @@
SUBDIR += beanie
SUBDIR += bitcoin-armory
SUBDIR += cbb
+ SUBDIR += cointop
SUBDIR += electrum
SUBDIR += expense
SUBDIR += fixc
diff --git a/finance/cointop/Makefile b/finance/cointop/Makefile
new file mode 100644
index 000000000000..b61575730ad1
--- /dev/null
+++ b/finance/cointop/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= cointop
+PORTVERSION= 1.0.6
+CATEGORIES= finance
+
+MAINTAINER= ndowens.fbsd@yandex.com
+COMMENT= Light cryptocurrency coin stats
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= miguelmota
+GH_PROJECT= cointop
+
+PLIST_FILES= bin/cointop
+
+do-build:
+ @${MKDIR} ${WRKSRC}/github.com/${GH_ACCOUNT}
+ @${RLN} ${WRKSRC} ${WRKSRC}/github.com/${GH_ACCOUNT}/${PORTNAME}
+ @${RLN} ${WRKSRC} ${WRKSRC}/src
+ cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
+ ${GO_CMD} build -ldflags "-X main.Version=${DISTVERSION}" -o bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/finance/cointop/distinfo b/finance/cointop/distinfo
new file mode 100644
index 000000000000..c1ffc758c49f
--- /dev/null
+++ b/finance/cointop/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531543729
+SHA256 (miguelmota-cointop-1.0.6_GH0.tar.gz) = 6188f21e7fcdfe686324a30a5ccc89a684e2a9acd81f2b042309ec0b28c26272
+SIZE (miguelmota-cointop-1.0.6_GH0.tar.gz) = 3988031
diff --git a/finance/cointop/pkg-descr b/finance/cointop/pkg-descr
new file mode 100644
index 000000000000..75951afb0aee
--- /dev/null
+++ b/finance/cointop/pkg-descr
@@ -0,0 +1,5 @@
+WWW: https://github.com/miguelmota/cointop
+
+Fast and lightweight terminal based UI application
+for tracking and monitoring cryptocurrency coins
+in real-time; inspired by htop with vim-inspired keys