aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/portfind/Makefile23
-rw-r--r--ports-mgmt/portfind/distinfo2
-rw-r--r--ports-mgmt/portfind/pkg-descr3
-rw-r--r--ports-mgmt/portfind/pkg-plist2
5 files changed, 31 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index e321d342a7b7..6a301bad1079 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -44,6 +44,7 @@
SUBDIR += portdowngrade
SUBDIR += porteasy
SUBDIR += portell
+ SUBDIR += portfind
SUBDIR += portless
SUBDIR += portlint
SUBDIR += portmaster
diff --git a/ports-mgmt/portfind/Makefile b/ports-mgmt/portfind/Makefile
new file mode 100644
index 000000000000..0270ae941d77
--- /dev/null
+++ b/ports-mgmt/portfind/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= portfind
+PORTVERSION= 1.6.1
+CATEGORIES= ports-mgmt perl5
+MASTER_SITES= http://dynsoft.com/files/
+
+MAINTAINER= thorsten@dynsoft.com
+COMMENT= Search the ports tree
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+RUN_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+
+USES= perl5
+USE_PERL5= build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/portfind ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/portfind.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portfind/distinfo b/ports-mgmt/portfind/distinfo
new file mode 100644
index 000000000000..3c9d621152bd
--- /dev/null
+++ b/ports-mgmt/portfind/distinfo
@@ -0,0 +1,2 @@
+SHA256 (portfind-1.6.1.tar.gz) = 18b80f94b62e6979d495ea428972f41549a0eaf634655388b8d7d2bb0772ecbe
+SIZE (portfind-1.6.1.tar.gz) = 5334
diff --git a/ports-mgmt/portfind/pkg-descr b/ports-mgmt/portfind/pkg-descr
new file mode 100644
index 000000000000..9f0066e42f64
--- /dev/null
+++ b/ports-mgmt/portfind/pkg-descr
@@ -0,0 +1,3 @@
+Use portfind to search in the ports tree.
+
+WWW: http://www.dynsoft.com
diff --git a/ports-mgmt/portfind/pkg-plist b/ports-mgmt/portfind/pkg-plist
new file mode 100644
index 000000000000..f4708813c131
--- /dev/null
+++ b/ports-mgmt/portfind/pkg-plist
@@ -0,0 +1,2 @@
+bin/portfind
+man/man1/portfind.1.gz