aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/poedit/Makefile8
-rw-r--r--ftp/filezilla/Makefile8
-rw-r--r--ftp/wxdfast/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index bbd00a69c2e4..ab6e6a08cc98 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -41,4 +41,10 @@ post-patch:
's/for version in .*;/for version in ${BDB_VER};/ ; \
s/-ldb-$$version/-l${BDB_LIB_NAME}/' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000 && ${ARCH} == i386
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 5a9c0a2cdeb3..f13efe1edcc1 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -30,4 +30,10 @@ post-patch:
@${REINPLACE_CMD} -Ee 's|(dummy) wxrc|\1 ${WXRC_CMD:T}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000 && ${ARCH} == i386
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/wxdfast/Makefile b/ftp/wxdfast/Makefile
index 5a889bc8febf..062d156984bb 100644
--- a/ftp/wxdfast/Makefile
+++ b/ftp/wxdfast/Makefile
@@ -28,4 +28,10 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's|pt_BR||' ${WRKSRC}/man/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000 && ${ARCH} == i386
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>