aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/astrolog/Makefile15
-rw-r--r--misc/bb/Makefile10
-rw-r--r--misc/callid/Makefile10
-rw-r--r--misc/cmatrix/Makefile10
-rw-r--r--misc/crosspad/Makefile10
-rw-r--r--misc/dotfile/Makefile10
-rw-r--r--misc/dtach/Makefile10
-rw-r--r--misc/dvorakng/Makefile15
-rw-r--r--misc/explosions/Makefile11
-rw-r--r--misc/gctpc/Makefile12
-rw-r--r--misc/geekcode/Makefile12
-rw-r--r--misc/gnome-osd/Makefile12
-rw-r--r--misc/iselect/Makefile15
-rw-r--r--misc/kcd/Makefile10
-rw-r--r--misc/linm/Makefile12
-rw-r--r--misc/mtail/Makefile12
-rw-r--r--misc/pdfmap/Makefile13
-rw-r--r--misc/quotes/Makefile12
-rw-r--r--misc/rname/Makefile10
-rw-r--r--misc/salias/Makefile13
-rw-r--r--misc/tcb/Makefile10
-rw-r--r--misc/telbook/Makefile9
-rw-r--r--misc/termatrix/Makefile10
-rw-r--r--misc/terraform/Makefile13
-rw-r--r--misc/tet/Makefile14
-rw-r--r--misc/tkman/Makefile12
-rw-r--r--misc/upclient/Makefile8
-rw-r--r--misc/wmScoreBoard/Makefile10
-rw-r--r--misc/wmpal/Makefile12
-rw-r--r--misc/xpns/Makefile13
30 files changed, 141 insertions, 204 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index 2c89e418d2a3..05799dfc3b0b 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: astrolog
-#
-# Date created: 31 July 1995
-# Whom: faulkner@cactus.org
-#
+# Created by: faulkner@cactus.org
# $FreeBSD$
-#
PORTNAME= astrolog
PORTVERSION= 5.41g
@@ -13,11 +8,11 @@ CATEGORIES= misc astro
MASTER_SITES= ftp://ftp.astro.com/pub/swisseph/ephe/archive_gzip/:ephe \
ftp://ftp.astro.com/pub/swisseph/:libswe \
http://astrolog.offline.ee/astrolog/changed/:dist
-DISTFILES= a541gsrc.tar.gz:dist ${EPHE} \
+DISTFILES= a541gsrc.tar.gz:dist ${EPHE} \
swe_unix_src_1.78.00.tar.gz:libswe
MAINTAINER= ports@FreeBSD.org
-COMMENT= An astrology program for X11 and alpha-numeric terminals
+COMMENT= Astrology program for X11 and alpha-numeric terminals
# Swiss Ephemeris GPLv2 licensed, see
# http://www.astro.com/ftp/swisseph/LICENSE.TXT
@@ -44,6 +39,8 @@ NO_WRKSUBDIR= yes
DOCS= helpfile.540 readme.541 changes.txt
+.include <bsd.port.options.mk>
+
post-extract:
${RM} ${WRKDIR}/swe[a-z]*
@@ -57,7 +54,7 @@ do-install:
${INSTALL_DATA} astrolog.dat ${PREFIX}/lib/astrolog; \
fi
cd ${WRKSRC} && ${INSTALL_PROGRAM} astrolog ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
index 82406aa3c7a4..8a5923899782 100644
--- a/misc/bb/Makefile
+++ b/misc/bb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bb
-# Date created: 22 June 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= bb
PORTVERSION= 1.3.r1
@@ -25,12 +21,14 @@ PORTDOCS= README
PLIST_FILES= bin/bb share/bb/bb.s3m share/bb/bb2.s3m share/bb/bb3.s3m
PLIST_DIRS= share/bb
+.include <bsd.port.options.mk>
+
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -E -e "s@#include +<malloc.h>@#include <stdlib.h>@g" \
-e 's, REGISTERS \(3\),,g'
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/misc/callid/Makefile b/misc/callid/Makefile
index 15eff6afca1c..b979d6ecfd77 100644
--- a/misc/callid/Makefile
+++ b/misc/callid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: callid
-# Date created: 19 February 2004
-# Whom: M. Possamai
-#
+# Created by: M. Possamai
# $FreeBSD$
-#
PORTNAME= callid
PORTVERSION= 1.2
@@ -25,6 +21,8 @@ PORTDOCS= CHANGES README TODO make-db.mysql
RUN_DEPENDS+= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+.include <bsd.port.options.mk>
+
pre-everything::
@${ECHO} ""
@${ECHO} "You have to configure PHP with MYSQL support."
@@ -40,7 +38,7 @@ do-install:
@${MKDIR} ${PREFIX}/www/callid/images
@${INSTALL_DATA} ${WRKSRC}/src/images/*.jpg ${PREFIX}/www/callid/images
@${INSTALL_DATA} -m 550 ${WRKSRC}/sbin/call-logd ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
diff --git a/misc/cmatrix/Makefile b/misc/cmatrix/Makefile
index c97c5f3936e1..9fbb146a566f 100644
--- a/misc/cmatrix/Makefile
+++ b/misc/cmatrix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cmatrix
-# Date created: 1 May 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= cmatrix
PORTVERSION= 1.2a
@@ -21,10 +17,12 @@ GNU_CONFIGURE= yes
PORTDOCS= ChangeLog README TODO
PLIST_FILES= bin/cmatrix
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cmatrix ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cmatrix.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/misc/crosspad/Makefile b/misc/crosspad/Makefile
index 1fcca06ac2ca..0e56af22880b 100644
--- a/misc/crosspad/Makefile
+++ b/misc/crosspad/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: crosspad
-# Date created: 23 September 1998
-# Whom: itojun@itojun.org
-#
+# Created by: itojun@itojun.org
# $FreeBSD$
-#
PORTNAME= crosspad
PORTVERSION= 19991202
@@ -21,8 +17,10 @@ MAN1= crosspad2ps.1 crosspad2eps.1 crosspad2tgif.1 crosspad2idraw.1 \
DOCS= PROTOCOL README.english README.japanese
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/crosspad
for i in $(DOCS); do \
${INSTALL_DATA} ${WRKSRC}/../$$i ${PREFIX}/share/doc/crosspad; \
diff --git a/misc/dotfile/Makefile b/misc/dotfile/Makefile
index 8bcb0f4792fe..b4e12d01a328 100644
--- a/misc/dotfile/Makefile
+++ b/misc/dotfile/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dotfile
-# Date created: 11/12/96
-# Whom: oly@world.std.com
-#
+# Created by: oly@world.std.com
# $FreeBSD$
-#
PORTNAME= dotfile
PORTVERSION= 2.4.1
@@ -12,7 +8,7 @@ CATEGORIES= misc tk
MASTER_SITES= http://www.blackie.dk/dotfile/download/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A GUI dotfile generator program to create .config files
+COMMENT= GUI dotfile generator program to create .config files
BUILD_DEPENDS= formail:${PORTSDIR}/mail/procmail
@@ -49,7 +45,7 @@ do-install:
cd ${WRKSRC} && ${SETENV} LC_ALL=C ${MAKE} install
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/dotfile
@${MKDIR} ${DOCSDIR}/procmail
@${MKDIR} ${DOCSDIR}/tcsh
diff --git a/misc/dtach/Makefile b/misc/dtach/Makefile
index 832e626a9432..1eb80c5fb842 100644
--- a/misc/dtach/Makefile
+++ b/misc/dtach/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dtach
-# Date created: 21 Jun 2004
-# Whom: Bjorn Lindstrom <bkhl@elektrubadur.se>
-#
+# Created by: Bjorn Lindstrom <bkhl@elektrubadur.se>
# $FreeBSD$
-#
PORTNAME= dtach
PORTVERSION= 0.8
@@ -21,11 +17,13 @@ MAN1= dtach.1
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/dtach ${PREFIX}/bin/
@${INSTALL_MAN} ${WRKSRC}/dtach.1 ${MAN1PREFIX}/man/man1/
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}/
@cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
diff --git a/misc/dvorakng/Makefile b/misc/dvorakng/Makefile
index 8091d72c3ee9..a7fc96843ba5 100644
--- a/misc/dvorakng/Makefile
+++ b/misc/dvorakng/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: dvorakNG
-# Date created: Mar 26, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= dvorakng
PORTVERSION= 0.5.0
@@ -13,7 +8,7 @@ CATEGORIES= misc
MASTER_SITES= http://www.free.of.pl/n/nopik/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Dvorak typing tutor
+COMMENT= Dvorak typing tutor
USE_BZIP2= yes
@@ -21,14 +16,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ARGS= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS} ${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.include <bsd.port.options.mk>
+
PLIST_FILES= bin/dvorakng
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= README TODO
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dvorakng ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/misc/explosions/Makefile b/misc/explosions/Makefile
index a1f554ee9c96..92f853a21f2d 100644
--- a/misc/explosions/Makefile
+++ b/misc/explosions/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: explosions
-# Date created: 8 August 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= explosions
PORTVERSION= 0.2005.07.31
@@ -19,6 +15,8 @@ USE_SDL= sdl image
USE_GMAKE= yes
USE_PERL5_BUILD=yes
+.include <bsd.port.options.mk>
+
post-patch:
@${PERL} -pi -e 's!CFLAGS=-Wall -O2!CFLAGS+=-Wall!; \
s!sdl-config!${SDL_CONFIG}!' \
@@ -30,7 +28,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/explosions ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/spark?.png ${DATADIR}
-.if !defined(NOPORTDOCS)
+
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in BUGS.txt CHANGES.txt README.txt
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/misc/gctpc/Makefile b/misc/gctpc/Makefile
index bb756c18aa16..7ba37b120f92 100644
--- a/misc/gctpc/Makefile
+++ b/misc/gctpc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gctpc
-# Date created: 26 Apr 2001
-# Whom: Randall Hopper <aa8vb@nc.rr.com>
-#
+# Created by: Randall Hopper <aa8vb@nc.rr.com>
# $FreeBSD$
-#
PORTNAME= gctpc
PORTVERSION= 1.3
@@ -14,10 +10,12 @@ DISTNAME= gctpc
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
-COMMENT= An USGS General Cartographic Transformation Package (GCTP)
+COMMENT= USGS General Cartographic Transformation Package (GCTP)
WRKSRC= ${WRKDIR}/${PORTNAME}/source
+.include <bsd.port.options.mk>
+
USE_GMAKE= yes
ALL_TARGET= libgctpc.so.1
@@ -30,7 +28,7 @@ do-install:
${MKDIR} ${PREFIX}/include/gctpc
${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/gctpc
${INSTALL_DATA} ${FILESDIR}/*.h ${PREFIX}/include/gctpc
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/../doc/* ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/../README ${DOCSDIR}/README.main
diff --git a/misc/geekcode/Makefile b/misc/geekcode/Makefile
index 878d841055a6..3313c2ff4c60 100644
--- a/misc/geekcode/Makefile
+++ b/misc/geekcode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: geekcode generator
-# Date created: 30 Aug 1999
-# Whom: Chris Piazza <cpiazza@FreeBSD.org>
-#
+# Created by: Chris Piazza <cpiazza@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= geekcode
PORTVERSION= 1.7.3
@@ -11,16 +7,18 @@ CATEGORIES= misc
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Geek Code Generator
+COMMENT= Geek Code Generator
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
PLIST_FILES= bin/geekcode
PORTDOCS= geekcode.txt
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/geekcode ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/geekcode.txt ${DOCSDIR}
.endif
diff --git a/misc/gnome-osd/Makefile b/misc/gnome-osd/Makefile
index 9d290ec51235..1abd088d7e4b 100644
--- a/misc/gnome-osd/Makefile
+++ b/misc/gnome-osd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnome-osd
-# Date created: 21 Aug 2004
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= gnome-osd
PORTVERSION= 0.20.0
@@ -13,7 +9,7 @@ MASTER_SITES= http://launchpadlibrarian.net/63944370/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An On-Screen-Display infrastructure using Pango text rendering
+COMMENT= On-Screen-Display infrastructure using Pango text rendering
USE_GNOME= gnomehack gnomeprefix intlhack pygnome2
USE_PYTHON= yes
@@ -27,8 +23,10 @@ MAN1= gnome-osd-client.1
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS NEWS README
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/misc/iselect/Makefile b/misc/iselect/Makefile
index aa119234991a..64bc08a7984e 100644
--- a/misc/iselect/Makefile
+++ b/misc/iselect/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iselect
-# Date created: 03-Jan-1998
-# Whom: Ralf S. Engelschall <rse@engelschall.com>
-#
+# Created by: Ralf S. Engelschall <rse@engelschall.com>
# $FreeBSD$
-#
PORTNAME= iselect
PORTVERSION= 1.4.0
@@ -14,11 +10,16 @@ MASTER_SITE_SUBDIR= tool/iselect
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive Selection Tool
+OPTIONS_DEFINE= SLANG
+SLANG_DESC= Link with slang
+
GNU_CONFIGURE= yes
MAN1= iselect.1
-.if defined(WITH_SLANG)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSLANG}
LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
CONFIGURE_ARGS+= --with-incdir=${LOCALBASE}/include \
--with-libdir=${LOCALBASE}/lib
@@ -30,7 +31,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iselect ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/iselect.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/example && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
diff --git a/misc/kcd/Makefile b/misc/kcd/Makefile
index 82dffad6732f..236abb4c3a80 100644
--- a/misc/kcd/Makefile
+++ b/misc/kcd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kcd
-# Date created: 5 May 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= kcd
PORTVERSION= 7.15.0
@@ -25,6 +21,8 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
MAN1= kcd.1
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/kcd-inst ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/kcdscr ${PREFIX}/bin
@@ -35,7 +33,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/po/${i}.gmo \
${PREFIX}/share/locale/${i}/LC_MESSAGES/kcd.mo
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
diff --git a/misc/linm/Makefile b/misc/linm/Makefile
index 5d3cb04b5813..f81b95073065 100644
--- a/misc/linm/Makefile
+++ b/misc/linm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: linm
-# Date created: 24 Jan 2005
-# Whom: cjh@FreeBSD.org
-#
+# Created by: cjh@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= linm
PORTVERSION= ${LINM_VER}.1
@@ -34,17 +30,19 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
#.endif
-CONFIGURE_ARGS+= --enable-cfgpath="${PREFIX}/etc/linm" --enable-kolocalepath="${PREFIX}/share/locale/ko/LC_MESSAGES"
+CONFIGURE_ARGS+= --enable-cfgpath="${PREFIX}/etc/linm" --enable-kolocalepath="${PREFIX}/share/locale/ko/LC_MESSAGES"
LINM_VER= 0.7.7
WRKSRC= ${WRKDIR}/linm-${LINM_VER}
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|Panel::SetCur|SetCur|' ${WRKSRC}/panel/common/panel.h
@${REINPLACE_CMD} -e 's|Position::Show|Show|' ${WRKSRC}/src/ncurses/dialog.h
post-install:
-.if !defined (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/linm
.for file in AUTHORS COPYING ChangeLog README README.ko_euckr README.ko_utf8
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/misc/mtail/Makefile b/misc/mtail/Makefile
index 030cdd5e71c6..ad8a246072db 100644
--- a/misc/mtail/Makefile
+++ b/misc/mtail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mtail
-# Date created: 9 August 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mtail
PORTVERSION= 1.1.1
@@ -20,16 +16,18 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= CHANGES LICENSE README
PORTEXAMPLES= mtailrc
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e '1s|/.*|${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}/
@cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
-.ifndef NOPORTEXAMPLES
+.if ${PORT_OPTIONS:MEXAMPLES}
@${INSTALL} -d ${EXAMPLESDIR}/
@${INSTALL_DATA} ${WRKSRC}/mtailrc.sample ${EXAMPLESDIR}/mtailrc
.endif
diff --git a/misc/pdfmap/Makefile b/misc/pdfmap/Makefile
index c19fa1356c2b..0b839902e074 100644
--- a/misc/pdfmap/Makefile
+++ b/misc/pdfmap/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: pdfmap
-# Date created: Mar 24, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= pdfmap
PORTVERSION= 2.00
@@ -25,11 +20,13 @@ USE_PYDISTUTILS= yes
DOCS= CREDITS NEWS README TODO doc/*.html
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
index 3575052bdbc9..fac82ec18f4e 100644
--- a/misc/quotes/Makefile
+++ b/misc/quotes/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quotes
-# Date created: 9 February 1999
-# Whom: Dima Sivachenko
-#
+# Created by: Dima Sivachenko
# $FreeBSD$
-#
PORTNAME= quotes
DISTVERSION= 1.7-2
@@ -19,6 +15,8 @@ COMMENT= Quote, currency, and Slashdot headline fetcher based on Perl
NO_BUILD= yes
USE_PERL5= yes
+.include <bsd.port.options.mk>
+
post-patch:
@ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/quotes
@ ${PERL} -pi -e "s:/usr/local/lib/Quotes:${PREFIX}/etc:g" ${WRKSRC}/quotes
@@ -30,11 +28,11 @@ do-install:
@ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${PREFIX}/bin
@ ${INSTALL_SCRIPT} ${WRKSRC}/quotesmailer ${PREFIX}/bin
@ ${INSTALL_DATA} ${WRKSRC}/sample.quotesrc ${PREFIX}/etc/quotesrc.sample
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@ ${MKDIR} ${DOCSDIR}
@ ${INSTALL_DATA} ${WRKSRC}/quotes.txt ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@ ${MKDIR} ${EXAMPLESDIR}
@ ${INSTALL_DATA} ${WRKSRC}/QuExample.pm ${EXAMPLESDIR}
.endif
diff --git a/misc/rname/Makefile b/misc/rname/Makefile
index 09edecf572dd..7145560db852 100644
--- a/misc/rname/Makefile
+++ b/misc/rname/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rname
-# Date created: 26 October 2000
-# Whom: roam@FreeBSD.org
-#
+# Created by: roam@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= rname
PORTVERSION= 1.0
@@ -17,7 +13,9 @@ COMMENT= Execute a program with a fake name
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install install-doc
.endif
diff --git a/misc/salias/Makefile b/misc/salias/Makefile
index 2aa97175e2b9..f3abbafad473 100644
--- a/misc/salias/Makefile
+++ b/misc/salias/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: salias
-# Date created: May 16, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= salias
PORTVERSION= 0.3.1
@@ -13,7 +8,7 @@ CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}/C%20${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A command-line tool to alias arguments of other programs
+COMMENT= CLI tool to alias arguments of other programs
USE_BZIP2= yes
USE_GNOME= glib20
@@ -23,7 +18,9 @@ GNU_CONFIGURE= yes
MAN1= salias.1
DOCS= NEWS README
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
diff --git a/misc/tcb/Makefile b/misc/tcb/Makefile
index 178a99d879eb..11610fa1a4c1 100644
--- a/misc/tcb/Makefile
+++ b/misc/tcb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tcb
-# Date created: 1 December 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= tcb
PORTVERSION= 1.4a
@@ -19,13 +15,15 @@ USE_GMAKE= yes
MAN1= tcb.1
+.include <bsd.port.options.mk>
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/tcb ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/tcb
@ ${INSTALL_DATA} ${WRKSRC}/tcbrc ${PREFIX}/share/tcb
@ ${INSTALL_DATA} ${WRKSRC}/doc/HELP ${PREFIX}/share/tcb
@ ${INSTALL_MAN} ${WRKSRC}/doc/tcb.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@ ${MKDIR} ${PREFIX}/share/doc/tcb
@ ${INSTALL_DATA} ${WRKSRC}/doc/CHANGES ${PREFIX}/share/doc/tcb
@ ${INSTALL_DATA} ${WRKSRC}/doc/COPYING ${PREFIX}/share/doc/tcb
diff --git a/misc/telbook/Makefile b/misc/telbook/Makefile
index c90d6dd5effe..66933c3d7da9 100644
--- a/misc/telbook/Makefile
+++ b/misc/telbook/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: telbook
-# Date created: 19 May 2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
PORTNAME= telbook
@@ -21,9 +18,11 @@ USE_BZIP2= yes
PORTDOCS= README
PLIST_FILES= bin/telbook
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/telbook ${PREFIX}/bin
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/misc/termatrix/Makefile b/misc/termatrix/Makefile
index 1c130b855f11..308870e588bf 100644
--- a/misc/termatrix/Makefile
+++ b/misc/termatrix/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: termatrix
-# Date created: 2007/07/30
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= termatrix
PORTVERSION= 0.2
@@ -17,13 +13,15 @@ COMMENT= Emulates Matrix terminal's "green tears" effect
PLIST_FILES= bin/termatrix
PORTDOCS= README
+.include <bsd.port.options.mk>
+
do-build:
${CC} ${CFLAGS} ${CPPFLAGS} -o ${WRKSRC}/termatrix \
${WRKSRC}/termatrix.c ${LDFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/termatrix ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
diff --git a/misc/terraform/Makefile b/misc/terraform/Makefile
index a23500d3a49d..d34ba7109908 100644
--- a/misc/terraform/Makefile
+++ b/misc/terraform/Makefile
@@ -1,15 +1,10 @@
-# ex:ts=8
-# Ports collection makefile for: terraform
-# Date created: Feb 8, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= terraform
PORTVERSION= 0.9.5
-PORTREVISION= 1
DISTVERSIONPREFIX= src-
+PORTREVISION= 1
CATEGORIES= misc gnome
MASTER_SITES= GOOGLE_CODE
EXTRACT_SUFX= .tgz
@@ -34,6 +29,8 @@ MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s| desktop-links docs | |' \
${WRKSRC}/Makefile.in
@@ -48,7 +45,7 @@ post-install:
@${MKDIR} ${PREFIX}/share/pixmaps
${INSTALL_DATA} ${WRKSRC}/desktop-links/terraform.png \
${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in FAQ.sgml README.sgml UsersGuide.sgml i18n.txt
${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
diff --git a/misc/tet/Makefile b/misc/tet/Makefile
index 1cb33bc5b074..54756e1c1c0b 100644
--- a/misc/tet/Makefile
+++ b/misc/tet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tet
-# Date created: 02 Oct 1998
-# Whom: jkoshy
-#
+# Created by: jkoshy
# $FreeBSD$
-#
PORTNAME= tet
PORTVERSION= 3.7
@@ -18,7 +14,7 @@ DIST_SUBDIR= tet/${PORTVERSION}
EXTRACT_ONLY= ${PORTNAME}${PORTVERSION}-unsup.src.tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= An test execution framework from the Open Group
+COMMENT= Test execution framework from the Open Group
NO_PACKAGE= $${TET_ROOT} needs to be set at compile time.
HAS_CONFIGURE= yes
@@ -27,7 +23,9 @@ PLIST= ${WRKDIR}/PLIST
TET_CONFIG_TARGET?= inet # options are `lite', `xti' and `inet'
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
TET_DOCS= 37_all_pdf.zip
DISTFILES+= ${TET_DOCS}:docs
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
@@ -66,7 +64,7 @@ do-build:
.endif
cd ${TET_ROOT}/src && ${MAKE} ${ALL_TARGET}
cd ${TET_ROOT}/src && ${MAKE} ${INSTALL_TARGET}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${TET_ROOT}/doc
${UNZIP_CMD} -d ${TET_ROOT}/doc ${DISTDIR}/${DIST_SUBDIR}/${TET_DOCS}
.endif
diff --git a/misc/tkman/Makefile b/misc/tkman/Makefile
index 6fb53f9755e6..8ed3a45de332 100644
--- a/misc/tkman/Makefile
+++ b/misc/tkman/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tkman
-# Date created: 27 Dec 1994
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tkman
PORTVERSION= 2.2
@@ -12,7 +8,7 @@ CATEGORIES= misc tk
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Tcl/Tk based manual browser
+COMMENT= Tcl/Tk based manual browser
RUN_DEPENDS= glimpse:${PORTSDIR}/textproc/glimpse \
rman:${PORTSDIR}/textproc/rman
@@ -28,6 +24,8 @@ MAKE_ARGS= WISH="${WISH}" \
manformat="{groff -Tlatin1 -te -mandoc}" \
manprint="{groff -mandoc -Tps -te -l}"
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/bin/wish|${WISH}|' \
${WRKSRC}/contrib/tkmanclient
@@ -37,7 +35,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/retkman ${PREFIX}/bin
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manual.html ${DOCSDIR}
.endif
diff --git a/misc/upclient/Makefile b/misc/upclient/Makefile
index bc0e5a0807ca..a0995b293647 100644
--- a/misc/upclient/Makefile
+++ b/misc/upclient/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: upclient
-# Date created: 20 Aug 1999
-# Whom: Kelly Yancey <kbyanc@posi.net>
-#
+# Created by: Kelly Yancey <kbyanc@posi.net>
# $FreeBSD$
-#
PORTNAME= upclient
PORTVERSION= 5.0.b8
@@ -76,7 +72,7 @@ install-conf:
.endif
install-doc:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${DOC_FILES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/misc/wmScoreBoard/Makefile b/misc/wmScoreBoard/Makefile
index 22c06c79386e..9e9431eb9dce 100644
--- a/misc/wmScoreBoard/Makefile
+++ b/misc/wmScoreBoard/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmScoreBoard
-# Date created: Sun Jun 24 17:08:15 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= wmScoreBoard
PORTVERSION= 0.30
@@ -21,8 +17,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_GMAKE= yes
USE_XORG= xpm
+.include <bsd.port.options.mk>
+
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docs in BUGS CHANGES HINTS README
@${INSTALL_DATA} ${WRKSRC}/../${docs} ${DOCSDIR}
diff --git a/misc/wmpal/Makefile b/misc/wmpal/Makefile
index a60b23906ad6..1b2a47b94ddb 100644
--- a/misc/wmpal/Makefile
+++ b/misc/wmpal/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmpal
-# Date created: 20 April 2001
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= wmpal
PORTVERSION= 0.6.1
@@ -11,7 +7,7 @@ CATEGORIES= misc windowmaker
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A one of the most useless dockapps in the world
+COMMENT= One of the most useless dockapps in the world
USE_XORG= xpm
GNU_CONFIGURE= yes
@@ -21,11 +17,13 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= README
PLIST_FILES= bin/wmpal
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|"dino"|"daemon"|g' ${WRKSRC}/wmpal.c
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/misc/xpns/Makefile b/misc/xpns/Makefile
index 840a231575dd..ad68b52434cb 100644
--- a/misc/xpns/Makefile
+++ b/misc/xpns/Makefile
@@ -1,16 +1,13 @@
-# New ports collection makefile for: xpns
-# Date created: 6 Apr 97
-# Whom: Pedro Giffuni
-#
+# Created by: Pedro Giffuni
# $FreeBSD$
-#
PORTNAME= xpns
PORTVERSION= 1.0
PORTREVISION= 3
CATEGORIES= misc cad
MASTER_SITES= http://robotics.ee.uwa.edu.au/pns/ftp/
-DISTFILES= pns_source.tar.Z
+DISTNAME= pns_source.tar
+EXTRACT_SUFX= .Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Petri-Net Simulator for Xwindows
@@ -20,6 +17,8 @@ USE_XORG= x11 xaw
MAKEFILE= makefile
ALL_TARGET= pns
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/xpns
@@ -30,7 +29,7 @@ do-install:
${MKDIR} ${PREFIX}/share/xpns
${INSTALL_DATA} ${WRKSRC}/pns.hlp ${PREFIX}/share/xpns
${INSTALL_DATA} ${WRKSRC}/pns.shell ${PREFIX}/share/xpns
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/xpns
${INSTALL_DATA} ${WRKSRC}/*.net ${PREFIX}/share/doc/xpns
.endif