aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/mesa-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/mesa-devel/Makefile b/graphics/mesa-devel/Makefile
index 815ffa05c644..6ebedca86fbd 100644
--- a/graphics/mesa-devel/Makefile
+++ b/graphics/mesa-devel/Makefile
@@ -84,7 +84,7 @@ radv_BUILD_DEPENDS= glslangValidator:graphics/glslang
COINST_DESC= Allow co-installation with another Mesa port
COINST_MESON_ON= -Degl-lib-suffix=${PKGNAMESUFFIX}
-COINST_RUN_DEPENDS= ${LOCALBASE}/share/glvnd/egl_vendor.d/50_${PORTNAME}.json:graphics/mesa-dri
+COINST_RUN_DEPENDS= mesa-dri>0:graphics/mesa-dri # ICD
COINST_PLIST_SUB= SUFFIX=${PKGNAMESUFFIX}
COINST_SUB_FILES= libmap.conf
COINST_SUB_LIST= SUFFIX=${PKGNAMESUFFIX}
@@ -117,7 +117,7 @@ OPENCL_MESON_TRUE= gallium-rusticl
OPENCL_MESON_ON= -Dgallium-opencl=icd
OPENCL_VARS= LLVM_USES=llvm:15,lib # chase libclc + rust (LTO)
.if ${MACHINE_ARCH} != aarch64 # XXX missing in ONLY_FOR_ARCHS
-OPENCL_VARS+= COINST_RUN_DEPENDS+=${LOCALBASE}/etc/OpenCL/vendors/${PORTNAME}.icd:lang/clover
+OPENCL_VARS+= COINST_RUN_DEPENDS+=clover>0:lang/clover # ICD
.endif
OPENCL_IMPLIES= LLVM ${"${PORT_OPTIONS:Miris}":?iris:radeonsi} # any from OPTIONS_GROUP_GALLIUM