aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gcvs/Makefile1
-rw-r--r--devel/gcvs/files/patch-TextBinary.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 68189e4c506b..c5a64cfb0d44 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcvs
PORTVERSION= 1.0b5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cvsgui
diff --git a/devel/gcvs/files/patch-TextBinary.cpp b/devel/gcvs/files/patch-TextBinary.cpp
new file mode 100644
index 000000000000..2584d18fa1ef
--- /dev/null
+++ b/devel/gcvs/files/patch-TextBinary.cpp
@@ -0,0 +1,12 @@
+--- common/TextBinary.cpp.orig Tue Feb 19 17:36:02 2002
++++ common/TextBinary.cpp Fri Dec 20 18:35:39 2002
+@@ -472,8 +472,7 @@
+ else
+ {
+ ext = tmp + 1;
+- base = file;
+- base[tmp - file] = '\0';
++ base.set(file, tmp - file - 1);
+ }
+ }
+