aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/strace/Makefile22
-rw-r--r--devel/strace/distinfo2
-rw-r--r--devel/strace/files/patch-configure63
-rw-r--r--devel/strace/files/patch-file.c20
4 files changed, 58 insertions, 49 deletions
diff --git a/devel/strace/Makefile b/devel/strace/Makefile
index 740d542b5ff3..3f6cca2dd323 100644
--- a/devel/strace/Makefile
+++ b/devel/strace/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= strace
-PORTVERSION= 4.4.94
+PORTVERSION= 4.5.1
CATEGORIES= devel sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,16 +15,32 @@ MAINTAINER= alex@rinet.ru
COMMENT= A portable process tracer
USE_BZIP2= yes
+USE_PERL5= yes # for strace-graph
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386
MAN1= strace.1
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} 's,/usr/bin/perl,${PERL},' ${WRKSRC}/strace-graph
+
do-install:
- -${MKDIR} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/strace ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/strace-graph ${PREFIX}/bin
- -${MKDIR} ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/strace.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in AUTHORS COPYRIGHT CREDITS ChangeLog NEWS PORTING \
+ README README-freebsd README-svr4 TODO
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/devel/strace/distinfo b/devel/strace/distinfo
index 9486e8157a55..f4eb950ef3f2 100644
--- a/devel/strace/distinfo
+++ b/devel/strace/distinfo
@@ -1 +1 @@
-MD5 (strace-4.4.94.tar.bz2) = 483890e6ea930f8c09ccae55121ca7ac
+MD5 (strace-4.5.1.tar.bz2) = 11657c64e4289d8cfc48302e890f1a5b
diff --git a/devel/strace/files/patch-configure b/devel/strace/files/patch-configure
index 9c8b033da9c3..df459bacb200 100644
--- a/devel/strace/files/patch-configure
+++ b/devel/strace/files/patch-configure
@@ -1,45 +1,18 @@
-*** configure Thu Feb 20 05:55:30 2003
---- /tmp/w/configure Tue Feb 25 14:47:53 2003
-***************
-*** 5602,5606 ****
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-! #include <netinet/in.h
-
- int
---- 5602,5607 ----
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-! #include <sys/types.h>
-! #include <netinet/in.h>
-
- int
-***************
-*** 5638,5642 ****
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-! #include <netinet/in.h
-
- int
---- 5639,5644 ----
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-! #include <sys/types.h>
-! #include <netinet/in.h>
-
- int
-***************
-*** 6490,6493 ****
---- 6492,6496 ----
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+ #include <sys/types.h>
- #include <netinet/in.h>
-
-***************
-*** 6749,6752 ****
---- 6752,6756 ----
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+ #include <sys/types.h>
- #include <sys/socket.h>
+--- configure.orig Fri Nov 7 03:24:18 2003
++++ configure Fri Jan 2 19:08:31 2004
+@@ -6501,6 +6501,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <sys/types.h>
+ #include <netinet/in.h>
+
+ #include <$ac_header>
+@@ -6760,6 +6761,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <sys/types.h>
+ #include <sys/socket.h>
+
+ int
diff --git a/devel/strace/files/patch-file.c b/devel/strace/files/patch-file.c
new file mode 100644
index 000000000000..fa363c4e967a
--- /dev/null
+++ b/devel/strace/files/patch-file.c
@@ -0,0 +1,20 @@
+--- file.c.orig Thu Nov 13 23:32:27 2003
++++ file.c Fri Jan 2 19:11:23 2004
+@@ -1387,7 +1387,7 @@
+ statbuf.f_bsize, statbuf.f_blocks, statbuf.f_bfree);
+ tprintf("f_bavail=%u, f_files=%u, f_ffree=%u, f_fsid={%d, %d}, f_namelen=%u",
+ statbuf.f_bavail,statbuf.f_files, statbuf.f_ffree,
+- statbuf.f_fsid.__val[0], statbuf.f_fsid.__val[1],
++ statbuf.f_fsid.val[0], statbuf.f_fsid.val[1],
+ statbuf.f_namelen);
+ #else /* !ALPHA */
+ tprintf("{f_type=%s, f_bsize=%lu, f_blocks=%lu, f_bfree=%lu, ",
+@@ -1399,7 +1399,7 @@
+ (unsigned long)statbuf.f_bavail,
+ (unsigned long)statbuf.f_files,
+ (unsigned long)statbuf.f_ffree,
+- statbuf.f_fsid.__val[0], statbuf.f_fsid.__val[1]);
++ statbuf.f_fsid.val[0], statbuf.f_fsid.val[1]);
+ #ifdef LINUX
+ tprintf(", f_namelen=%lu", (unsigned long)statbuf.f_namelen);
+ #endif /* LINUX */