aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/Xft/Makefile10
-rw-r--r--x11-fonts/libXft/Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-fonts/Xft/Makefile b/x11-fonts/Xft/Makefile
index c729f83857aa..f5839ff9ddb5 100644
--- a/x11-fonts/Xft/Makefile
+++ b/x11-fonts/Xft/Makefile
@@ -26,7 +26,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
WRKSRC= ${WRKDIR}/${DISTNAME}/Xft
+.include <bsd.port.pre.mk>
+
+# TODO Add a check to make sure we're not using XFree86 4.3.x which will
+# have Xft2 included by default.
+.if ${XFREE86_VERSION} == 3
+BROKEN= Xft2 requires XFree86 4.x to build.
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index c729f83857aa..f5839ff9ddb5 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -26,7 +26,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
WRKSRC= ${WRKDIR}/${DISTNAME}/Xft
+.include <bsd.port.pre.mk>
+
+# TODO Add a check to make sure we're not using XFree86 4.3.x which will
+# have Xft2 included by default.
+.if ${XFREE86_VERSION} == 3
+BROKEN= Xft2 requires XFree86 4.x to build.
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>