aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/bioapitool/Makefile27
-rw-r--r--security/bioapitool/distinfo3
-rw-r--r--security/bioapitool/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 781bbed47717..c3c365fb273f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -33,6 +33,7 @@
SUBDIR += beecrypt
SUBDIR += bfbtester
SUBDIR += bioapi
+ SUBDIR += bioapitool
SUBDIR += bjorb
SUBDIR += borzoi
SUBDIR += botan
diff --git a/security/bioapitool/Makefile b/security/bioapitool/Makefile
new file mode 100644
index 000000000000..c65db356ffbc
--- /dev/null
+++ b/security/bioapitool/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: bioapitool
+# Date created: 12 January 2006
+# Whom: Fredrik Lindberg <fli@shapeshifter.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bioapitool
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://shapeshifter.se/pub/bioapitool/
+
+MAINTAINER= fli@shapeshifter.se
+COMMENT= BioAPI management utility
+
+LIB_DEPENDS= bioapi100.0:${PORTSDIR}/security/bioapi
+
+MAN1= bioapitool.1
+PLIST_FILES= sbin/bioapitool
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= needs at least FreeBSD 5.0-RELEASE
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/bioapitool/distinfo b/security/bioapitool/distinfo
new file mode 100644
index 000000000000..b8332662c02c
--- /dev/null
+++ b/security/bioapitool/distinfo
@@ -0,0 +1,3 @@
+MD5 (bioapitool-1.0.tar.gz) = fcda08f5b067ed59a111ad30687989e7
+SHA256 (bioapitool-1.0.tar.gz) = 0cab7564742f8e698163e077b40fd821e5b5fa6bf76c5940f21eaf7ea51ba5cb
+SIZE (bioapitool-1.0.tar.gz) = 5458
diff --git a/security/bioapitool/pkg-descr b/security/bioapitool/pkg-descr
new file mode 100644
index 000000000000..41d988107df9
--- /dev/null
+++ b/security/bioapitool/pkg-descr
@@ -0,0 +1,4 @@
+bioapitool is a small BioAPI management utility which allows enrollment and
+verification of BIR entries.
+
+WWW: http://shapeshifter.se/code/bioapitool