aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-property/Makefile43
-rw-r--r--devel/ruby-property/distinfo1
-rw-r--r--devel/ruby-property/pkg-comment1
-rw-r--r--devel/ruby-property/pkg-descr7
-rw-r--r--devel/ruby-property/pkg-plist10
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ruby-python/Makefile44
-rw-r--r--lang/ruby-python/distinfo1
-rw-r--r--lang/ruby-python/files/patch-aa11
-rw-r--r--lang/ruby-python/pkg-comment1
-rw-r--r--lang/ruby-python/pkg-descr14
-rw-r--r--lang/ruby-python/pkg-plist26
-rw-r--r--math/Makefile1
-rw-r--r--math/ruby-bigfloat/Makefile36
-rw-r--r--math/ruby-bigfloat/distinfo1
-rw-r--r--math/ruby-bigfloat/pkg-comment1
-rw-r--r--math/ruby-bigfloat/pkg-descr4
-rw-r--r--math/ruby-bigfloat/pkg-plist6
19 files changed, 210 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ddf5dcb4420d..257bc79374cd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -262,6 +262,7 @@
SUBDIR += rinfo
SUBDIR += robodoc
SUBDIR += rpc2
+ SUBDIR += ruby-property
SUBDIR += rvm
SUBDIR += sdcc
SUBDIR += sdl
diff --git a/devel/ruby-property/Makefile b/devel/ruby-property/Makefile
new file mode 100644
index 000000000000..2390878e7a1a
--- /dev/null
+++ b/devel/ruby-property/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: Ruby-property
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= property
+PORTVERSION= 19990308
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+post-patch:
+ ${PERL} -i -pe 's|rubyapi.css|../rubyapi.css|g' ${WRKSRC}/Properties-ja.html
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/property.rb ${PREFIX}/lib/ruby/${RUBY_VER}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/property/ja
+.for f in property-example.rb test.default property.README Properties.html rubyapi.css
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/property
+.endfor
+.for f in property.README.ja Properties-ja.html
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/property/ja
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-property/distinfo b/devel/ruby-property/distinfo
new file mode 100644
index 000000000000..39ae7dc3d4cf
--- /dev/null
+++ b/devel/ruby-property/distinfo
@@ -0,0 +1 @@
+MD5 (ruby-property-19990308.tar.gz) = e7629a1df441fc30fee05f8421a74346
diff --git a/devel/ruby-property/pkg-comment b/devel/ruby-property/pkg-comment
new file mode 100644
index 000000000000..6979b15551a3
--- /dev/null
+++ b/devel/ruby-property/pkg-comment
@@ -0,0 +1 @@
+Simple properties scheme for Ruby
diff --git a/devel/ruby-property/pkg-descr b/devel/ruby-property/pkg-descr
new file mode 100644
index 000000000000..d7e76cbc328e
--- /dev/null
+++ b/devel/ruby-property/pkg-descr
@@ -0,0 +1,7 @@
+property.rb - simple properties scheme
+
+This library, developed after java.util.Properties class of Java
+Language, provides simple properties scheme for application
+configurations, resources, locale data, etc.
+
+WWW: http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/index.html
diff --git a/devel/ruby-property/pkg-plist b/devel/ruby-property/pkg-plist
new file mode 100644
index 000000000000..4128014c8007
--- /dev/null
+++ b/devel/ruby-property/pkg-plist
@@ -0,0 +1,10 @@
+lib/ruby/%%RUBY_VER%%/property.rb
+share/doc/ruby/property/property-example.rb
+share/doc/ruby/property/test.default
+share/doc/ruby/property/property.README
+share/doc/ruby/property/Properties.html
+share/doc/ruby/property/rubyapi.css
+share/doc/ruby/property/ja/property.README.ja
+share/doc/ruby/property/ja/Properties-ja.html
+@dirrm share/doc/ruby/property/ja
+@dirrm share/doc/ruby/property
diff --git a/lang/Makefile b/lang/Makefile
index 2b5c77f57f00..9e10aaefca8a 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -95,6 +95,7 @@
SUBDIR += python-doc-postscript-letter
SUBDIR += rexx-imc
SUBDIR += ruby
+ SUBDIR += ruby-python
SUBDIR += scheme48
SUBDIR += schemetoc
SUBDIR += scm
diff --git a/lang/ruby-python/Makefile b/lang/ruby-python/Makefile
new file mode 100644
index 000000000000..c758e43634bf
--- /dev/null
+++ b/lang/ruby-python/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/Python
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= python
+PORTVERSION= 0.3.2
+CATEGORIES= lang # ruby
+MASTER_SITES= http://www.goto.info.waseda.ac.jp/~fukusima/ruby/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
+ python:${PORTSDIR}/lang/python
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
+ python:${PORTSDIR}/lang/python
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb; \
+ ${PERL} -i -pe 's/-lc\b/-lc_r/g' Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/python/examples/Lib
+ ${MKDIR} ${PREFIX}/share/doc/ruby/python/ja
+ cd ${WRKSRC}; find examples -exec ${INSTALL_DATA} {} ${PREFIX}/share/doc/ruby/python/{} \;
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${WRKSRC}/doc/* \
+ ${PREFIX}/share/doc/ruby/python/
+ ${INSTALL_DATA} ${WRKSRC}/README.ja ${WRKSRC}/doc-ja/* \
+ ${PREFIX}/share/doc/ruby/python/ja/
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/ruby-python/distinfo b/lang/ruby-python/distinfo
new file mode 100644
index 000000000000..40d35363df37
--- /dev/null
+++ b/lang/ruby-python/distinfo
@@ -0,0 +1 @@
+MD5 (ruby-python-0.3.2.tar.gz) = 52a19aba436d5197ff5d39f03a5a5246
diff --git a/lang/ruby-python/files/patch-aa b/lang/ruby-python/files/patch-aa
new file mode 100644
index 000000000000..f1d7e93eff57
--- /dev/null
+++ b/lang/ruby-python/files/patch-aa
@@ -0,0 +1,11 @@
+--- extconf.rb.orig Sun Nov 7 15:38:30 1999
++++ extconf.rb Mon Aug 7 12:34:46 2000
+@@ -29,7 +30,7 @@
+ exit(1) unless File.exists? py_makefile
+
+ $CFLAGS = "-I#{py_includedir}"
+-$LDFLAGS = "-L#{py_configdir}"
++$LDFLAGS = "-L#{py_configdir} -pthread"
+
+ # If python is linked with extra libraries (e.g. -lpthread on Linux,
+ # -lsocket on Solaris, etc.), have_library test will fail and built
diff --git a/lang/ruby-python/pkg-comment b/lang/ruby-python/pkg-comment
new file mode 100644
index 000000000000..afbf51886c4e
--- /dev/null
+++ b/lang/ruby-python/pkg-comment
@@ -0,0 +1 @@
+Ruby extension library for embedding Python in Ruby
diff --git a/lang/ruby-python/pkg-descr b/lang/ruby-python/pkg-descr
new file mode 100644
index 000000000000..52f1faa2570c
--- /dev/null
+++ b/lang/ruby-python/pkg-descr
@@ -0,0 +1,14 @@
+Ruby extension library for embedding Python in Ruby. With this
+library, Ruby scripts can directly call arbitrary Python modules.
+Both extension modules and modules written in Python can be used.
+
+Ruby and Python have some differences as described here. This library
+enables Ruby users to have the advantages of both languages:
+
+ - Straightforward and easy-to-learn OO functionality of Ruby.
+ - Plenty of modules written for Python.
+
+If you are attracted by Python modules but not fully satisfied with
+Python's syntax or type system, try this library!
+
+WWW: http://www.goto.info.waseda.ac.jp/~fukusima/ruby/python-e.html
diff --git a/lang/ruby-python/pkg-plist b/lang/ruby-python/pkg-plist
new file mode 100644
index 000000000000..90d7811eb5f7
--- /dev/null
+++ b/lang/ruby-python/pkg-plist
@@ -0,0 +1,26 @@
+lib/ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/python.so
+share/doc/ruby/python/examples/Lib/BaseHTTPServer.rb
+share/doc/ruby/python/examples/Lib/README
+share/doc/ruby/python/examples/Lib/base64.rb
+share/doc/ruby/python/examples/Lib/rfc822.rb
+share/doc/ruby/python/examples/Lib/urllib.rb
+share/doc/ruby/python/examples/hello.rb
+share/doc/ruby/python/examples/html.py
+share/doc/ruby/python/examples/html.rb
+share/doc/ruby/python/ja/README.ja
+share/doc/ruby/python/ja/Mapping.html
+share/doc/ruby/python/ja/Object.html
+share/doc/ruby/python/ja/Py.html
+share/doc/ruby/python/ja/Sequence.html
+share/doc/ruby/python/ja/index.html
+share/doc/ruby/python/ChangeLog
+share/doc/ruby/python/README
+share/doc/ruby/python/Mapping.html
+share/doc/ruby/python/Object.html
+share/doc/ruby/python/Py.html
+share/doc/ruby/python/Sequence.html
+share/doc/ruby/python/index.html
+@dirrm share/doc/ruby/python/examples/Lib
+@dirrm share/doc/ruby/python/examples
+@dirrm share/doc/ruby/python/ja
+@dirrm share/doc/ruby/python
diff --git a/math/Makefile b/math/Makefile
index bb1b617e30d9..079557f2ba4c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -52,6 +52,7 @@
SUBDIR += pygist
SUBDIR += rcalc
SUBDIR += rng
+ SUBDIR += ruby-bigfloat
SUBDIR += sc
SUBDIR += siag
SUBDIR += simpack
diff --git a/math/ruby-bigfloat/Makefile b/math/ruby-bigfloat/Makefile
new file mode 100644
index 000000000000..aab0c9307217
--- /dev/null
+++ b/math/ruby-bigfloat/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Ruby-BigFloat
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bigfloat
+PORTVERSION= 1.1.3
+CATEGORIES= math # ruby
+MASTER_SITES= http://www.tinyforest.gr.jp/ruby/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_WRKSUBDIR= yes
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/bigfloat/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/bigfloat_en.html ${PREFIX}/share/doc/ruby/bigfloat
+ ${INSTALL_DATA} ${WRKSRC}/bigfloat.html ${PREFIX}/share/doc/ruby/bigfloat/ja
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ruby-bigfloat/distinfo b/math/ruby-bigfloat/distinfo
new file mode 100644
index 000000000000..46a19362c612
--- /dev/null
+++ b/math/ruby-bigfloat/distinfo
@@ -0,0 +1 @@
+MD5 (bigfloat-1.1.3.tar.gz) = 7049e4ba02d609893c65475cd1405cea
diff --git a/math/ruby-bigfloat/pkg-comment b/math/ruby-bigfloat/pkg-comment
new file mode 100644
index 000000000000..bfc402f766e7
--- /dev/null
+++ b/math/ruby-bigfloat/pkg-comment
@@ -0,0 +1 @@
+Variable precision floating library for Ruby
diff --git a/math/ruby-bigfloat/pkg-descr b/math/ruby-bigfloat/pkg-descr
new file mode 100644
index 000000000000..8627861ce7a0
--- /dev/null
+++ b/math/ruby-bigfloat/pkg-descr
@@ -0,0 +1,4 @@
+BigFloat is an extension library for Ruby. Using BigFloat class, you
+can obtain any number of significant digits in computation.
+
+WWW: http://www.tinyforest.gr.jp/ruby/bigfloat_en.html
diff --git a/math/ruby-bigfloat/pkg-plist b/math/ruby-bigfloat/pkg-plist
new file mode 100644
index 000000000000..b637ee6a6319
--- /dev/null
+++ b/math/ruby-bigfloat/pkg-plist
@@ -0,0 +1,6 @@
+lib/ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/BigFloat.so
+share/doc/ruby/bigfloat/ja/bigfloat.html
+share/doc/ruby/bigfloat/README
+share/doc/ruby/bigfloat/bigfloat_en.html
+@dirrm share/doc/ruby/bigfloat/ja
+@dirrm share/doc/ruby/bigfloat