aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/rubygem-archive-zip/Makefile22
-rw-r--r--archivers/rubygem-archive-zip/distinfo2
-rw-r--r--archivers/rubygem-archive-zip/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index d45374cd3d5d..9c56fe2ed2c2 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -158,6 +158,7 @@
SUBDIR += ruby-libarchive
SUBDIR += ruby-zip
SUBDIR += rubygem-archive-tar-minitar
+ SUBDIR += rubygem-archive-zip
SUBDIR += rubygem-bzip2
SUBDIR += rubygem-rubyzip2
SUBDIR += rvm
diff --git a/archivers/rubygem-archive-zip/Makefile b/archivers/rubygem-archive-zip/Makefile
new file mode 100644
index 000000000000..e7ed8f6a8813
--- /dev/null
+++ b/archivers/rubygem-archive-zip/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rubygem-archive-zip
+# Date created: 2011-08-06
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= archive-zip
+PORTVERSION= 0.3.0
+CATEGORIES= archivers rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Provides interface to working with ZIP archives
+
+RUN_DEPENDS= rubygem-io-like>=0.1.0:${PORTSDIR}/devel/rubygem-io-like
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/rubygem-archive-zip/distinfo b/archivers/rubygem-archive-zip/distinfo
new file mode 100644
index 000000000000..4569a68616d5
--- /dev/null
+++ b/archivers/rubygem-archive-zip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/archive-zip-0.3.0.gem) = 9f8745d2a675db6db230db530845e3ce2f5109e872111a7ed42b2ba261475ef8
+SIZE (rubygem/archive-zip-0.3.0.gem) = 48640
diff --git a/archivers/rubygem-archive-zip/pkg-descr b/archivers/rubygem-archive-zip/pkg-descr
new file mode 100644
index 000000000000..42dedb633702
--- /dev/null
+++ b/archivers/rubygem-archive-zip/pkg-descr
@@ -0,0 +1,10 @@
+The Archive::Zip library intends to provide a simple, yet complete and
+Ruby-esque, interface to working with ZIP archives.
+
+Basic archive creation and extraction can be handled using only a few methods.
+More complex operations involving the manipulation of existing archives in place
+(adding, removing, and modifying entries) are also possible with a little more
+work. Even adding advanced features such as new compression codecs are
+supported with a moderate amount of effort.
+
+WWW: https://github.com/javanthropus/archive-zip