aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ansilove/Makefile4
-rw-r--r--graphics/ansilove/distinfo6
-rw-r--r--graphics/ansilove/pkg-descr26
-rw-r--r--graphics/libansilove/Makefile31
-rw-r--r--graphics/libansilove/distinfo3
-rw-r--r--graphics/libansilove/pkg-descr15
-rw-r--r--graphics/libansilove/pkg-plist4
8 files changed, 79 insertions, 11 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8da28db464a2..e4aaaa27aba0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -442,6 +442,7 @@
SUBDIR += libGLw
SUBDIR += libQGLViewer
SUBDIR += libafterimage
+ SUBDIR += libansilove
SUBDIR += libart_lgpl
SUBDIR += libboard
SUBDIR += libbpg
diff --git a/graphics/ansilove/Makefile b/graphics/ansilove/Makefile
index 58c341be9378..ec2f87919854 100644
--- a/graphics/ansilove/Makefile
+++ b/graphics/ansilove/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ansilove
-PORTVERSION= 3.0.9
+PORTVERSION= 4.0.0
CATEGORIES= graphics textproc
MAINTAINER= amdmi3@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= ANSi / ASCII art to PNG converter
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libgd.so:graphics/gd
+LIB_DEPENDS= libansilove.so:graphics/libansilove
USE_GITHUB= yes
diff --git a/graphics/ansilove/distinfo b/graphics/ansilove/distinfo
index ddaaf8414699..17b699a0ffe9 100644
--- a/graphics/ansilove/distinfo
+++ b/graphics/ansilove/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1530017694
-SHA256 (ansilove-ansilove-3.0.9_GH0.tar.gz) = 3117b083f3a97da6f3d24963d46b83af2fb6967c5c33940d0b097386f338b919
-SIZE (ansilove-ansilove-3.0.9_GH0.tar.gz) = 162408
+TIMESTAMP = 1547826832
+SHA256 (ansilove-ansilove-4.0.0_GH0.tar.gz) = 2107a7bcb1b69f65924eb00acafce537ed049b92b84582202408ab3b86f02ea1
+SIZE (ansilove-ansilove-4.0.0_GH0.tar.gz) = 121250
diff --git a/graphics/ansilove/pkg-descr b/graphics/ansilove/pkg-descr
index 205d18af8569..cdacaba55c4c 100644
--- a/graphics/ansilove/pkg-descr
+++ b/graphics/ansilove/pkg-descr
@@ -1,10 +1,24 @@
ANSi / ASCII art to PNG converter
-- Supports 7 textmode formats:
- ANS/PCB/BiN/ADF/iDF/TND/XBiN
-- Supports 14 MS-DOS charsets
-- 80x25, 80x50 and Amiga fonts
-- Supports SAUCE and iCE colors
-- Small output size (4-bit PNG)
+The following formats are supported:
+- .ANS - ANSi (ANSI escape sequences: ANSI X3.64 standard)
+- .PCB - PCBoard Bulletin Board System (BBS) own file format
+- .BIN - Binary format (raw memory copy of text mode video memory)
+- .ADF - Artworx format, supporting custom character sets and palettes
+- .IDF - iCE Draw format, supporting custom character sets and palettes
+- .TND - TundraDraw format, supporting 24-bit color mode
+- .XB - The eXtended Binary XBin format, supporting custom character
+ sets and palettes
+
+AnsiLove/C is capabable of processing:
+- SAUCE records
+- DOS and Amiga fonts (embedded binary dump)
+- iCE colors
+
+Even more:
+- Output files are highly optimized 4-bit PNGs.
+- Optionally generates additional (and proper) Retina @2x PNG.
+- You can use custom options for adjusting output results.
+- Built-in support for rendering Amiga ASCII.
WWW: https://github.com/ansilove/ansilove
diff --git a/graphics/libansilove/Makefile b/graphics/libansilove/Makefile
new file mode 100644
index 000000000000..f577473a256b
--- /dev/null
+++ b/graphics/libansilove/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libansilove
+PORTVERSION= 1.1.0
+CATEGORIES= graphics
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Library for converting ANSI, ASCII, and other formats to PNG
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgd.so:graphics/gd
+
+USE_GITHUB= yes
+GH_ACCOUNT= ansilove
+
+USES= cmake
+
+PORTDOCS= AUTHORS ChangeLog README.md THANKS TODO
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/libansilove/distinfo b/graphics/libansilove/distinfo
new file mode 100644
index 000000000000..43881bf03750
--- /dev/null
+++ b/graphics/libansilove/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548174933
+SHA256 (ansilove-libansilove-1.1.0_GH0.tar.gz) = 6370c688ab9fe74f2b10355053b5dc09474d65fd132a82e3fd8cd8622b161a67
+SIZE (ansilove-libansilove-1.1.0_GH0.tar.gz) = 54536
diff --git a/graphics/libansilove/pkg-descr b/graphics/libansilove/pkg-descr
new file mode 100644
index 000000000000..4cb46dd86e10
--- /dev/null
+++ b/graphics/libansilove/pkg-descr
@@ -0,0 +1,15 @@
+libansilove is a library to convert ANSi and artscene related file
+formats into PNG images.
+
+The following formats are supported:
+
+- .ANS - ANSi (ANSI escape sequences: ANSI X3.64 standard)
+- .PCB - PCBoard Bulletin Board System (BBS) own file format
+- .BIN - Binary format (raw memory copy of text mode video memory)
+- .ADF - Artworx format, supporting custom character sets and palettes
+- .IDF - iCE Draw format, supporting custom character sets and palettes
+- .TND - TundraDraw format, supporting 24-bit color mode
+- .XB - The eXtended Binary XBin format, supporting custom character
+ sets and palettes
+
+WWW: https://www.ansilove.org/
diff --git a/graphics/libansilove/pkg-plist b/graphics/libansilove/pkg-plist
new file mode 100644
index 000000000000..a17a2c773993
--- /dev/null
+++ b/graphics/libansilove/pkg-plist
@@ -0,0 +1,4 @@
+include/ansilove.h
+lib/libansilove.so
+lib/libansilove.so.1
+lib/libansilove.so.1.1.0