aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.php.mk3
-rw-r--r--archivers/php5-bz2/files/patch-bz2_filter.c13
-rw-r--r--databases/php5-mssql/files/patch-php_mssql.c23
-rw-r--r--databases/php5-mssql/files/patch-php_mssql.h12
-rw-r--r--databases/php5-sybase_ct/files/patch-php_sybase_ct.c12
-rw-r--r--lang/php5-extensions/Makefile8
-rw-r--r--lang/php5/Makefile3
-rw-r--r--lang/php5/Makefile.ext12
-rw-r--r--lang/php5/distinfo6
-rw-r--r--lang/php5/files/patch-acinclude.m419
-rw-r--r--lang/php5/pkg-plist2
-rw-r--r--lang/php53/Makefile3
-rw-r--r--lang/php53/Makefile.ext12
-rw-r--r--lang/php53/distinfo6
-rw-r--r--lang/php53/files/patch-acinclude.m419
-rw-r--r--lang/php53/pkg-plist2
-rw-r--r--textproc/php5-wddx/files/patch-wddx.c35
17 files changed, 97 insertions, 93 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index dcba081fc71f..877ababe1d01 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -262,7 +262,7 @@ _USE_PHP_ALL= bcmath bz2 calendar ctype curl dba dbase \
_USE_PHP_VER4= ${_USE_PHP_ALL} crack dbx dio domxml mcal mcve \
mnogosearch oracle overload xslt yp
_USE_PHP_VER5= ${_USE_PHP_ALL} dom mysqli simplexml soap sqlite \
- tidy xmlreader xsl
+ tidy xmlreader xmlwriter xsl
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
bz2_DEPENDS= archivers/php${PHP_VER}-bz2
@@ -331,6 +331,7 @@ wddx_DEPENDS= textproc/php${PHP_VER}-wddx
xml_DEPENDS= textproc/php${PHP_VER}-xml
xmlreader_DEPENDS= textproc/php${PHP_VER}-xmlreader
xmlrpc_DEPENDS= net/php${PHP_VER}-xmlrpc
+xmlwriter_DEPENDS= textproc/php${PHP_VER}-xmlwriter
xsl_DEPENDS= textproc/php${PHP_VER}-xsl
xslt_DEPENDS= textproc/php${PHP_VER}-xslt
yaz_DEPENDS= net/pecl-yaz
diff --git a/archivers/php5-bz2/files/patch-bz2_filter.c b/archivers/php5-bz2/files/patch-bz2_filter.c
deleted file mode 100644
index f64c3c461fc5..000000000000
--- a/archivers/php5-bz2/files/patch-bz2_filter.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- bz2_filter.c.orig Mon Dec 12 22:40:14 2005
-+++ bz2_filter.c Mon Dec 12 22:40:29 2005
-@@ -18,6 +18,10 @@
-
- /* $Id: bz2_filter.c,v 1.3 2005/08/03 14:06:39 sniper Exp $ */
-
-+#ifdef HAVE_CONFIG_H
-+#include "config.h"
-+#endif
-+
- #include "php.h"
- #include "php_bz2.h"
-
diff --git a/databases/php5-mssql/files/patch-php_mssql.c b/databases/php5-mssql/files/patch-php_mssql.c
deleted file mode 100644
index 73eaa6a30057..000000000000
--- a/databases/php5-mssql/files/patch-php_mssql.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- php_mssql.c 2005/12/06 18:47:14 1.152.2.10
-+++ php_mssql.c 2005/12/21 22:43:06 1.152.2.11
-@@ -141,6 +141,9 @@
- STD_PHP_INI_BOOLEAN("mssql.datetimeconvert", "1", PHP_INI_ALL, OnUpdateBool, datetimeconvert, zend_mssql_globals, mssql_globals)
- STD_PHP_INI_BOOLEAN("mssql.secure_connection", "0", PHP_INI_SYSTEM, OnUpdateBool, secure_connection, zend_mssql_globals, mssql_globals)
- STD_PHP_INI_ENTRY_EX("mssql.max_procs", "-1", PHP_INI_ALL, OnUpdateLong, max_procs, zend_mssql_globals, mssql_globals, display_link_numbers)
-+#ifdef HAVE_FREETDS
-+ STD_PHP_INI_ENTRY("mssql.charset", "", PHP_INI_ALL, OnUpdateString, charset, zend_mssql_globals, mssql_globals)
-+#endif
- PHP_INI_END()
-
- /* error handler */
-@@ -495,7 +498,9 @@
- #endif
-
- #ifdef HAVE_FREETDS
-- DBSETLCHARSET(mssql.login, "ISO-8859-1");
-+ if (MS_SQL_G(charset) && strlen(MS_SQL_G(charset))) {
-+ DBSETLCHARSET(mssql.login, MS_SQL_G(charset));
-+ }
- #endif
-
- DBSETLAPP(mssql.login,MS_SQL_G(appname));
diff --git a/databases/php5-mssql/files/patch-php_mssql.h b/databases/php5-mssql/files/patch-php_mssql.h
deleted file mode 100644
index d8aefeadb1a0..000000000000
--- a/databases/php5-mssql/files/patch-php_mssql.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- php_mssql.h 2005/12/06 01:25:16 1.42.2.1
-+++ php_mssql.h 2005/12/21 22:43:06 1.42.2.2
-@@ -158,6 +158,9 @@
- zend_bool allow_persistent;
- char *appname;
- char *server_message;
-+#ifdef HAVE_FREETDS
-+ char *charset;
-+#endif
- long min_error_severity, min_message_severity;
- long cfg_min_error_severity, cfg_min_message_severity;
- long connect_timeout, timeout;
diff --git a/databases/php5-sybase_ct/files/patch-php_sybase_ct.c b/databases/php5-sybase_ct/files/patch-php_sybase_ct.c
deleted file mode 100644
index 612af257d4e2..000000000000
--- a/databases/php5-sybase_ct/files/patch-php_sybase_ct.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- php_sybase_ct.c.orig Mon Dec 12 23:04:09 2005
-+++ php_sybase_ct.c Mon Dec 12 23:05:24 2005
-@@ -467,8 +467,8 @@
- static int php_sybase_do_connect_internal(sybase_link *sybase, char *host, char *user, char *passwd, char *charset, char *appname)
- {
- CS_LOCALE *tmp_locale;
-- TSRMLS_FETCH();
- long packetsize;
-+ TSRMLS_FETCH();
-
- /* set a CS_CONNECTION record */
- if (ct_con_alloc(SybCtG(context), &sybase->connection)!=CS_SUCCEED) {
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 684197494eb2..d1bbb2cfe67a 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -32,6 +32,8 @@ WITH_SIMPLEXML= yes
WITH_SQLITE= yes
WITH_TOKENIZER= yes
WITH_XML= yes
+WITH_XMLREADER= yes
+WITH_XMLWRITER= yes
OPTIONS= BCMATH "bc style precision math functions" off \
BZ2 "bzip2 library support" off \
@@ -88,8 +90,9 @@ OPTIONS= BCMATH "bc style precision math functions" off \
TOKENIZER "tokenizer support" on \
WDDX "WDDX support (implies XML)" off \
XML "XML support" on \
- XMLREADER "XMLReader support" off \
+ XMLREADER "XMLReader support" on \
XMLRPC "XMLRPC-EPI support" off \
+ XMLWRITER "XMLWriter support" on \
XSL "XSL support (Implies DOM)" off \
YAZ "YAZ support (ANSI/NISO Z39.50)" off \
ZIP "ZIP support" off \
@@ -110,7 +113,8 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA DBASE \
NCURSES ODBC OPENSSL PANDA PCNTL PCRE PDF PGSQL POSIX \
PSPELL READLINE RECODE SESSION SHMOP SIMPLEXML SNMP SOAP \
SOCKETS SQLITE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
- TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XSL YAZ ZIP ZLIB
+ TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XMLWRITER XSL \
+ YAZ ZIP ZLIB
SEL_OPTIONS= yes
.for opt in ${ALL_OPTIONS}
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index d192cdc78474..c3edd2427f86 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.1.1
+PORTVERSION= 5.1.2
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= --enable-versioning \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --enable-reflection \
--enable-spl
USE_GNOME= libxml2
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index c59f4d3c035f..b5d56d805179 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -61,9 +61,6 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= simplexml
-USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -353,7 +350,7 @@ CONFIGURE_ARGS+=--with-xmlreader \
USE_GNOME= libxml2
-USE_PHP= xml
+USE_PHP= dom
USE_PHP_BUILD= yes
.endif
@@ -371,6 +368,13 @@ USE_PHP= xml
USE_PHP_BUILD= yes
.endif
+.if ${PHP_MODNAME} == "xmlwriter"
+CONFIGURE_ARGS+=--with-xmlwriter \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
+.endif
+
.if ${PHP_MODNAME} == "xsl"
CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index 238205cbbe25..190c276dee62 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,3 +1,3 @@
-MD5 (php-5.1.1.tar.bz2) = 70a7c90de182d1a1901c390b844153c7
-SHA256 (php-5.1.1.tar.bz2) = 29fee6733868019bc702f7a2b54d95bd9d20d01fc9e9e6681f3d32f50b5f28cd
-SIZE (php-5.1.1.tar.bz2) = 6149470
+MD5 (php-5.1.2.tar.bz2) = 79cee17e9db85be878000a2a4198378e
+SHA256 (php-5.1.2.tar.bz2) = a18399360e1c5dcbdfed4f7215ae8fd2a5e057c24b86392392e832216aa63202
+SIZE (php-5.1.2.tar.bz2) = 6319905
diff --git a/lang/php5/files/patch-acinclude.m4 b/lang/php5/files/patch-acinclude.m4
index 925902e0e2e8..14396604f6e6 100644
--- a/lang/php5/files/patch-acinclude.m4
+++ b/lang/php5/files/patch-acinclude.m4
@@ -1,6 +1,19 @@
---- acinclude.m4.orig Tue Jul 26 00:31:07 2005
-+++ acinclude.m4 Wed Nov 16 09:30:03 2005
-@@ -1707,9 +1707,9 @@
+--- acinclude.m4.orig Sat Dec 24 12:38:05 2005
++++ acinclude.m4 Mon Jan 16 12:20:17 2006
+@@ -1021,12 +1021,6 @@
+ build to be successful.
+ ])
+ fi
+- if test "x$is_it_shared" = "x" && test "x$3" != "xtrue"; then
+- AC_MSG_ERROR([
+-You've configured extension $1, which depends on extension $2,
+-but you've either not enabled $2, or have disabled it.
+-])
+- fi
+ dnl Some systems require that we link $2 to $1 when building
+ ])
+
+@@ -2151,9 +2145,9 @@
test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
dnl Fallbacks for different configure options
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index e66190e08479..a2fb357af332 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -56,7 +56,6 @@ include/php/Zend/zend_objects_API.h
include/php/Zend/zend_operators.h
include/php/Zend/zend_ptr_stack.h
include/php/Zend/zend_qsort.h
-include/php/Zend/zend_reflection_api.h
include/php/Zend/zend_stack.h
include/php/Zend/zend_static_allocator.h
include/php/Zend/zend_stream.h
@@ -127,7 +126,6 @@ include/php/ext/standard/php_smart_str.h
include/php/ext/standard/php_smart_str_public.h
include/php/ext/standard/php_standard.h
include/php/ext/standard/php_string.h
-include/php/ext/standard/php_sunfuncs.h
include/php/ext/standard/php_type.h
include/php/ext/standard/php_uuencode.h
include/php/ext/standard/php_var.h
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index d192cdc78474..c3edd2427f86 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.1.1
+PORTVERSION= 5.1.2
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= --enable-versioning \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --enable-reflection \
--enable-spl
USE_GNOME= libxml2
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index c59f4d3c035f..b5d56d805179 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -61,9 +61,6 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= simplexml
-USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -353,7 +350,7 @@ CONFIGURE_ARGS+=--with-xmlreader \
USE_GNOME= libxml2
-USE_PHP= xml
+USE_PHP= dom
USE_PHP_BUILD= yes
.endif
@@ -371,6 +368,13 @@ USE_PHP= xml
USE_PHP_BUILD= yes
.endif
+.if ${PHP_MODNAME} == "xmlwriter"
+CONFIGURE_ARGS+=--with-xmlwriter \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
+.endif
+
.if ${PHP_MODNAME} == "xsl"
CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index 238205cbbe25..190c276dee62 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,3 +1,3 @@
-MD5 (php-5.1.1.tar.bz2) = 70a7c90de182d1a1901c390b844153c7
-SHA256 (php-5.1.1.tar.bz2) = 29fee6733868019bc702f7a2b54d95bd9d20d01fc9e9e6681f3d32f50b5f28cd
-SIZE (php-5.1.1.tar.bz2) = 6149470
+MD5 (php-5.1.2.tar.bz2) = 79cee17e9db85be878000a2a4198378e
+SHA256 (php-5.1.2.tar.bz2) = a18399360e1c5dcbdfed4f7215ae8fd2a5e057c24b86392392e832216aa63202
+SIZE (php-5.1.2.tar.bz2) = 6319905
diff --git a/lang/php53/files/patch-acinclude.m4 b/lang/php53/files/patch-acinclude.m4
index 925902e0e2e8..14396604f6e6 100644
--- a/lang/php53/files/patch-acinclude.m4
+++ b/lang/php53/files/patch-acinclude.m4
@@ -1,6 +1,19 @@
---- acinclude.m4.orig Tue Jul 26 00:31:07 2005
-+++ acinclude.m4 Wed Nov 16 09:30:03 2005
-@@ -1707,9 +1707,9 @@
+--- acinclude.m4.orig Sat Dec 24 12:38:05 2005
++++ acinclude.m4 Mon Jan 16 12:20:17 2006
+@@ -1021,12 +1021,6 @@
+ build to be successful.
+ ])
+ fi
+- if test "x$is_it_shared" = "x" && test "x$3" != "xtrue"; then
+- AC_MSG_ERROR([
+-You've configured extension $1, which depends on extension $2,
+-but you've either not enabled $2, or have disabled it.
+-])
+- fi
+ dnl Some systems require that we link $2 to $1 when building
+ ])
+
+@@ -2151,9 +2145,9 @@
test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
dnl Fallbacks for different configure options
diff --git a/lang/php53/pkg-plist b/lang/php53/pkg-plist
index e66190e08479..a2fb357af332 100644
--- a/lang/php53/pkg-plist
+++ b/lang/php53/pkg-plist
@@ -56,7 +56,6 @@ include/php/Zend/zend_objects_API.h
include/php/Zend/zend_operators.h
include/php/Zend/zend_ptr_stack.h
include/php/Zend/zend_qsort.h
-include/php/Zend/zend_reflection_api.h
include/php/Zend/zend_stack.h
include/php/Zend/zend_static_allocator.h
include/php/Zend/zend_stream.h
@@ -127,7 +126,6 @@ include/php/ext/standard/php_smart_str.h
include/php/ext/standard/php_smart_str_public.h
include/php/ext/standard/php_standard.h
include/php/ext/standard/php_string.h
-include/php/ext/standard/php_sunfuncs.h
include/php/ext/standard/php_type.h
include/php/ext/standard/php_uuencode.h
include/php/ext/standard/php_var.h
diff --git a/textproc/php5-wddx/files/patch-wddx.c b/textproc/php5-wddx/files/patch-wddx.c
index 0a26af4abf7c..a8a6a79fe47f 100644
--- a/textproc/php5-wddx/files/patch-wddx.c
+++ b/textproc/php5-wddx/files/patch-wddx.c
@@ -1,13 +1,40 @@
---- wddx.c.orig Mon Jul 26 08:56:21 2004
-+++ wddx.c Mon Jul 26 08:56:40 2004
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
@@ -18,6 +18,10 @@
- /* $Id: wddx.c,v 1.96.2.5.2.1 2004/07/13 13:15:30 iliaa Exp $ */
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+#ifdef HAVE_CONFIG_H
+# include "config.h"
+#endif
+
#include "php.h"
- #include "php_wddx.h"
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else