aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-MySQL/Makefile24
-rw-r--r--security/p5-Crypt-MySQL/distinfo3
-rw-r--r--security/p5-Crypt-MySQL/pkg-descr4
-rw-r--r--security/p5-Crypt-MySQL/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7961d040bab1..6a06399bfc81 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -305,6 +305,7 @@
SUBDIR += p5-Crypt-HCE_SHA
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-Lite
+ SUBDIR += p5-Crypt-MySQL
SUBDIR += p5-Crypt-NULL
SUBDIR += p5-Crypt-OFB
SUBDIR += p5-Crypt-OTP
diff --git a/security/p5-Crypt-MySQL/Makefile b/security/p5-Crypt-MySQL/Makefile
new file mode 100644
index 000000000000..39c229446fb7
--- /dev/null
+++ b/security/p5-Crypt-MySQL/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-MySQL
+# Date created: 17 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-MySQL
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to compare MySQL passwords without libmysqlclient
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::MySQL.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-MySQL/distinfo b/security/p5-Crypt-MySQL/distinfo
new file mode 100644
index 000000000000..95d06b90a0db
--- /dev/null
+++ b/security/p5-Crypt-MySQL/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-MySQL-0.02.tar.gz) = dfaf418d37f4f690f8e69a2e03e74371
+SHA256 (Crypt-MySQL-0.02.tar.gz) = fb85eacc4d00aac9d9d903a075ede34506a1c8902a75ddbb4e0e918dd5b6e182
+SIZE (Crypt-MySQL-0.02.tar.gz) = 2371
diff --git a/security/p5-Crypt-MySQL/pkg-descr b/security/p5-Crypt-MySQL/pkg-descr
new file mode 100644
index 000000000000..52af1a4cf0f3
--- /dev/null
+++ b/security/p5-Crypt-MySQL/pkg-descr
@@ -0,0 +1,4 @@
+Crypt::MySQL emulates MySQL PASSWORD() SQL function, without libmysqlclient.
+You can compare encrypted passwords, without real MySQL environment.
+
+WWW: http://search.cpan.org/dist/Crypt-MySQL/
diff --git a/security/p5-Crypt-MySQL/pkg-plist b/security/p5-Crypt-MySQL/pkg-plist
new file mode 100644
index 000000000000..50cbc65e6a38
--- /dev/null
+++ b/security/p5-Crypt-MySQL/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/MySQL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/MySQL/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/MySQL/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/MySQL/MySQL.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/MySQL/MySQL.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/MySQL
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true