aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-sphinxcontrib-napoleon/Makefile23
-rw-r--r--textproc/py-sphinxcontrib-napoleon/distinfo3
-rw-r--r--textproc/py-sphinxcontrib-napoleon/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0c7bd6be4b9f..7fe29b0d63f9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1368,6 +1368,7 @@
SUBDIR += py-sphinxcontrib-htmlhelp
SUBDIR += py-sphinxcontrib-httpdomain
SUBDIR += py-sphinxcontrib-jsmath
+ SUBDIR += py-sphinxcontrib-napoleon
SUBDIR += py-sphinxcontrib-newsfeed
SUBDIR += py-sphinxcontrib-programoutput
SUBDIR += py-sphinxcontrib-qthelp
diff --git a/textproc/py-sphinxcontrib-napoleon/Makefile b/textproc/py-sphinxcontrib-napoleon/Makefile
new file mode 100644
index 000000000000..851d7c9513ee
--- /dev/null
+++ b/textproc/py-sphinxcontrib-napoleon/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= sphinxcontrib-napoleon
+DISTVERSION= 0.7
+CATEGORIES= textproc
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Sphinx extension that parses both NumPy and Google style docstrings
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pockets>=0.3:devel/py-pockets@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-sphinxcontrib-napoleon/distinfo b/textproc/py-sphinxcontrib-napoleon/distinfo
new file mode 100644
index 000000000000..be7b9141ae6e
--- /dev/null
+++ b/textproc/py-sphinxcontrib-napoleon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1589655696
+SHA256 (sphinxcontrib-napoleon-0.7.tar.gz) = 407382beed396e9f2d7f3043fad6afda95719204a1e1a231ac865f40abcbfcf8
+SIZE (sphinxcontrib-napoleon-0.7.tar.gz) = 21232
diff --git a/textproc/py-sphinxcontrib-napoleon/pkg-descr b/textproc/py-sphinxcontrib-napoleon/pkg-descr
new file mode 100644
index 000000000000..22c3eb27795c
--- /dev/null
+++ b/textproc/py-sphinxcontrib-napoleon/pkg-descr
@@ -0,0 +1,6 @@
+Napoleon is a pre-processor that parses NumPy and Google style docstrings and
+converts them to reStructuredText before Sphinx attempts to parse them. This
+happens in an intermediate step while Sphinx is processing the documentation,
+so it doesn't modify any of the docstrings in your actual source code files.
+
+WWW: https://pypi.org/project/sphinxcontrib-napoleon/