aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/kdemultimedia4/Makefile1
-rw-r--r--multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp43
2 files changed, 44 insertions, 0 deletions
diff --git a/multimedia/kdemultimedia4/Makefile b/multimedia/kdemultimedia4/Makefile
index ebb7d96f8efd..e2dc5eaed5d2 100644
--- a/multimedia/kdemultimedia4/Makefile
+++ b/multimedia/kdemultimedia4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kdemultimedia
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp b/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp
new file mode 100644
index 000000000000..db7a814182d8
--- /dev/null
+++ b/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp
@@ -0,0 +1,43 @@
+--- kioslave/audiocd/audiocd.cpp.orig 2009-09-03 16:55:47.000000000 +0200
++++ kioslave/audiocd/audiocd.cpp 2009-09-03 19:36:22.000000000 +0200
+@@ -225,20 +225,21 @@
+ // name associated with the device, which throws the rest of audiocd
+ // for a loop.
+ //
++ QString devname;
+ if ( !(drive->dev) || (COOKED_IOCTL == drive->interface) )
+ {
+ // For ATAPI devices, we have no real choice. Use the
+ // user selected value, even if there is none.
+ //
+ kWarning(7117) << "Found an ATAPI device, assuming it is the one specified by the user.";
+- d->cd.setDevice( d->device );
++ devname = d->device;
+ }
+ else
+ {
+ kDebug(7117) << "Found a SCSI or ATAPICAM device.";
+ if ( strlen(drive->dev->device_path) > 0 )
+ {
+- d->cd.setDevice( drive->dev->device_path );
++ devname = drive->dev->device_path;
+ }
+ else
+ {
+@@ -246,13 +247,14 @@
+ // circumstances, so build a representation from
+ // the unit number and SCSI device name.
+ //
+- QString devname = QString::fromLatin1( "/dev/%1%2" )
++ devname = QString::fromLatin1( "/dev/%1%2" )
+ .arg( drive->dev->given_dev_name )
+ .arg( drive->dev->given_unit_number ) ;
+ kDebug(7117) << " Using derived name " << devname;
+- d->cd.setDevice( devname );
+ }
+ }
++ if (d->cd.deviceName() != devname)
++ d->cd.setDevice( devname );
+ #else
+ #ifdef __GNUC__
+ #warning audiocd ioslave is not going to work for you