aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/html/Makefile6
-rw-r--r--textproc/iso12083/Makefile6
-rw-r--r--textproc/openfts/Makefile19
-rw-r--r--textproc/openfts/pkg-plist9
-rw-r--r--textproc/sgmlformat/Makefile9
-rw-r--r--textproc/sgmlformat/files/patch-sgmlfmt__Makefile19
-rw-r--r--textproc/sgmlformat/files/patch-transpec-_Makefile16
-rw-r--r--textproc/sgmlformat/pkg-plist3
8 files changed, 59 insertions, 28 deletions
diff --git a/textproc/html/Makefile b/textproc/html/Makefile
index 961f47950166..8d7bb697e549 100644
--- a/textproc/html/Makefile
+++ b/textproc/html/Makefile
@@ -21,11 +21,10 @@ NO_WRKSUBDIR= yes
PLIST_SUB= DTD_NAME=${PORTNAME} XMLCATMGR=${XMLCATMGR}
PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
-INSTDIR= ${PREFIX}/share/sgml/html
+INSTDIR= ${STAGEDIR}${PREFIX}/share/sgml/html
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
-NO_STAGE= yes
pre-su-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
@@ -34,7 +33,4 @@ do-install:
@${CHMOD} ${SHAREMODE} `${FIND} ${INSTDIR} -type f`
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}
-post-install:
- @${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${PORTNAME}/catalog
-
.include <bsd.port.mk>
diff --git a/textproc/iso12083/Makefile b/textproc/iso12083/Makefile
index 8d902feac0ca..7ace079b9ef5 100644
--- a/textproc/iso12083/Makefile
+++ b/textproc/iso12083/Makefile
@@ -23,11 +23,10 @@ NO_WRKSUBDIR= yes
PLIST_SUB= DTD_NAME=${PORTNAME} XMLCATMGR=${XMLCATMGR}
PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
-INSTDIR= ${PREFIX}/share/sgml/iso12083
+INSTDIR= ${STAGEDIR}${PREFIX}/share/sgml/iso12083
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
-NO_STAGE= yes
pre-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
@@ -37,7 +36,4 @@ do-install:
done
@${INSTALL_DATA} ${FILESDIR}/catalog ${INSTDIR}/catalog
-post-install:
- @${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${PORTNAME}/catalog
-
.include <bsd.port.mk>
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index 3ef7ddfd3c0b..313e6655442c 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -17,29 +17,22 @@ USE_PGSQL= yes
USES= perl5
USE_PERL5= configure
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-MAN3= Search::OpenFTS.3 Search::OpenFTS::Base.3 \
- Search::OpenFTS::Dict::PorterEng.3 Search::OpenFTS::Dict::Snowball.3 \
- Search::OpenFTS::Dict::Synonym.3 Search::OpenFTS::Dict::UnknownDict.3 \
- Search::OpenFTS::Index.3 Search::OpenFTS::Morph::ISpell.3 \
- Search::OpenFTS::Parser.3
-
PORTDOCS= Changes INSTALL README primer.html
post-install:
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${STAGEDIR}${EXAMPLESDIR}."
.endif
.if !defined(NOPORTDOCS)
@${CP} -p ${WRKSRC}/doc/primer.html ${WRKSRC}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${STAGEDIR}${DOCSDIR}."
.endif
# Sample DB initialization.
diff --git a/textproc/openfts/pkg-plist b/textproc/openfts/pkg-plist
index 750367388f47..3eac270d506c 100644
--- a/textproc/openfts/pkg-plist
+++ b/textproc/openfts/pkg-plist
@@ -1,3 +1,12 @@
+%%PERL5_MAN3%%/Search::OpenFTS.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Base.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Dict::PorterEng.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Dict::Snowball.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Dict::Synonym.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Dict::UnknownDict.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Index.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Morph::ISpell.3.gz
+%%PERL5_MAN3%%/Search::OpenFTS::Parser.3.gz
%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Base.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/PorterEng.pm
diff --git a/textproc/sgmlformat/Makefile b/textproc/sgmlformat/Makefile
index c01dd6bd9cf1..c700daa8ffcb 100644
--- a/textproc/sgmlformat/Makefile
+++ b/textproc/sgmlformat/Makefile
@@ -13,15 +13,11 @@ COMMENT= Generates groff and HTML from linuxdoc and docbook SGML documents
USES= perl5
USE_PERL5= run
-
-MAN1= instant.1 sgmlfmt.1
-MAN5= transpec.5
-MANCOMPRESSED= yes
+MAKE_ENV= STAGEDIR=${STAGEDIR}
# There are two ports that satisfy the nsgmls requirement.
# Jade is preferred.
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} != "i386"
@@ -44,6 +40,9 @@ post-patch:
@${REINPLACE_CMD} -e 's,nsgmls,onsgmls,g' ${WRKSRC}/instant/traninit.c
.endif
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/sgml/transpec
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/textproc/sgmlformat/files/patch-sgmlfmt__Makefile b/textproc/sgmlformat/files/patch-sgmlfmt__Makefile
new file mode 100644
index 000000000000..5a96eaab31a4
--- /dev/null
+++ b/textproc/sgmlformat/files/patch-sgmlfmt__Makefile
@@ -0,0 +1,19 @@
+--- ./sgmlfmt/Makefile.orig 2014-06-10 08:00:07.272462749 +0900
++++ ./sgmlfmt/Makefile 2014-06-10 08:01:56.855462177 +0900
+@@ -1,6 +1,6 @@
+ # $Id$
+
+-FILES= sgmlfmt
++SCRIPTS= sgmlfmt
+ CLEANFILES= sgmlfmt
+ MAN1= sgmlfmt.1
+
+@@ -13,7 +13,7 @@
+ sed -e 's|##PERL##|${PREFIX}/bin/perl|' -e 's|##PREFIX##|${PREFIX}|' < sgmlfmt.pl > sgmlfmt
+ .endif
+
+-afterinstall:
++no-afterinstall:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} ${FILES} \
+ ${BINDIR}
+
diff --git a/textproc/sgmlformat/files/patch-transpec-_Makefile b/textproc/sgmlformat/files/patch-transpec-_Makefile
new file mode 100644
index 000000000000..853560dd630e
--- /dev/null
+++ b/textproc/sgmlformat/files/patch-transpec-_Makefile
@@ -0,0 +1,16 @@
+--- transpec/Makefile.orig 2014-06-10 21:01:50.280462342 +0900
++++ transpec/Makefile 2014-06-10 21:42:02.463462646 +0900
+@@ -9,11 +9,9 @@
+
+ all clean cleandir depend lint tags:
+
+-beforeinstall:
+- @mkdir -p ${TRANSPEC_DIR}
+-
+ afterinstall:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 444 ${FILES} \
+- ${TRANSPEC_DIR}
++ ${STAGEDIR}${PREFIX}/share/sgml/transpec/
+
+ .include <bsd.prog.mk>
++
diff --git a/textproc/sgmlformat/pkg-plist b/textproc/sgmlformat/pkg-plist
index 51518b60ed22..8ab8e592aa2d 100644
--- a/textproc/sgmlformat/pkg-plist
+++ b/textproc/sgmlformat/pkg-plist
@@ -12,6 +12,9 @@ bin/roff.cmap
bin/roff.sdata
bin/sgmlfmt
bin/transpec.dtd
+man/man1/instant.1.gz
+man/man1/sgmlfmt.1.gz
+man/man5/transpec.5.gz
share/sgml/transpec/catalog
share/sgml/transpec/docbook-html.ts
share/sgml/transpec/docbook-roff.ts