aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/exiv2/Makefile1
-rw-r--r--graphics/exiv2/files/patch-src-tiffcomposite.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 185e3481946a..040467271a31 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exiv2
PORTVERSION= 0.18
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
diff --git a/graphics/exiv2/files/patch-src-tiffcomposite.cpp b/graphics/exiv2/files/patch-src-tiffcomposite.cpp
new file mode 100644
index 000000000000..4022db8bbcfd
--- /dev/null
+++ b/graphics/exiv2/files/patch-src-tiffcomposite.cpp
@@ -0,0 +1,20 @@
+Index: tiffcomposite.cpp
+===================================================================
+--- src/tiffcomposite.cpp (revision 1742)
++++ src/tiffcomposite.cpp (revision 1743)
+@@ -688,9 +688,13 @@
+
+ uint32_t TiffMnEntry::doCount() const
+ {
+- // Count of tag Exif.Photo.MakerNote is the size of the Makernote in bytes
++ if (!mn_) {
++ return TiffEntryBase::doCount();
++ }
++ // Count of IFD makernote in tag Exif.Photo.MakerNote is the size of the
++ // Makernote in bytes
+ assert(tiffType() == ttUndefined);
+- return size();
++ return mn_->size();
+ }
+
+ uint32_t TiffArrayEntry::doCount() const