aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-anonfunc/Makefile21
-rw-r--r--devel/py-anonfunc/distinfo1
-rw-r--r--devel/py-anonfunc/pkg-descr2
-rw-r--r--devel/py-anonfunc/pkg-plist5
5 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 54e65c14b28a..afa67b553136 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -926,6 +926,7 @@
SUBDIR += ptypes
SUBDIR += publib
SUBDIR += pwlib
+ SUBDIR += py-anonfunc
SUBDIR += py-ansistyle
SUBDIR += py-cheetah
SUBDIR += py-ciphon
diff --git a/devel/py-anonfunc/Makefile b/devel/py-anonfunc/Makefile
new file mode 100644
index 000000000000..bcba11a8e539
--- /dev/null
+++ b/devel/py-anonfunc/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-anonfunc
+# Date created: 3 January 2004
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+
+PORTNAME= anonfunc
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~perky/distfiles/
+MASTER_SITE_SUBDIR= perky
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= Python module that provides easy anonymous function
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-anonfunc/distinfo b/devel/py-anonfunc/distinfo
new file mode 100644
index 000000000000..cf21657ee53d
--- /dev/null
+++ b/devel/py-anonfunc/distinfo
@@ -0,0 +1 @@
+MD5 (anonfunc-1.0.tar.gz) = 277990cdf180ea78b1e4e9e65888c343
diff --git a/devel/py-anonfunc/pkg-descr b/devel/py-anonfunc/pkg-descr
new file mode 100644
index 000000000000..dae80f4ac19b
--- /dev/null
+++ b/devel/py-anonfunc/pkg-descr
@@ -0,0 +1,2 @@
+This package provides very simple proxy object that creates
+anonymous functions based on they got operated.
diff --git a/devel/py-anonfunc/pkg-plist b/devel/py-anonfunc/pkg-plist
new file mode 100644
index 000000000000..48c3d0d22bed
--- /dev/null
+++ b/devel/py-anonfunc/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/anonfunc.pth
+%%PYTHON_SITELIBDIR%%/anonfunc.so
+%%PYTHON_SITELIBDIR%%/anonfuncalias.py
+%%PYTHON_SITELIBDIR%%/anonfuncalias.pyc
+%%PYTHON_SITELIBDIR%%/anonfuncalias.pyo