aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/oniguruma/Makefile9
-rw-r--r--devel/oniguruma/distinfo6
-rw-r--r--devel/oniguruma/files/onig-config54
-rw-r--r--devel/oniguruma/pkg-plist1
-rw-r--r--devel/oniguruma4/Makefile9
-rw-r--r--devel/oniguruma4/distinfo6
-rw-r--r--devel/oniguruma4/files/onig-config54
-rw-r--r--devel/oniguruma4/pkg-plist1
-rw-r--r--devel/oniguruma5/Makefile9
-rw-r--r--devel/oniguruma5/distinfo6
-rw-r--r--devel/oniguruma5/files/onig-config54
-rw-r--r--devel/oniguruma5/pkg-plist1
12 files changed, 195 insertions, 15 deletions
diff --git a/devel/oniguruma/Makefile b/devel/oniguruma/Makefile
index 5562eea4aff5..b53a733f74ec 100644
--- a/devel/oniguruma/Makefile
+++ b/devel/oniguruma/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= oniguruma
-PORTVERSION= 2.5.6
+PORTVERSION= 2.5.7
CATEGORIES= devel
MASTER_SITES= http://www.geocities.jp/kosako3/oniguruma/archive/
DISTNAME= onigd${PORTVERSION:S/./_/g}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= A BSDL Regular Expressions library compatible with POSIX/GNU/Perl
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -23,7 +23,12 @@ GNU_CONFIGURE= yes
DOCS= HISTORY README doc/*
+post-configure:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${FILESDIR}/onig-config > ${WRKSRC}/onig-config
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
diff --git a/devel/oniguruma/distinfo b/devel/oniguruma/distinfo
index b2306ebdf24f..3772e21f3365 100644
--- a/devel/oniguruma/distinfo
+++ b/devel/oniguruma/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/onigd2_5_6.tar.gz) = b3de8f1445ea90b220cb9c76dc709fb6
-SHA256 (ruby/onigd2_5_6.tar.gz) = e37bf3ee1a0e2e84f86f07b065513a13df2cc57e202f67845e38aa29a7bca15d
-SIZE (ruby/onigd2_5_6.tar.gz) = 212610
+MD5 (ruby/onigd2_5_7.tar.gz) = dcaa0b3608990791a5348e94b2f427d5
+SHA256 (ruby/onigd2_5_7.tar.gz) = 205b2857d77efc4caa3b98eaf91fd1cc8b8722b497df933d1fbd23f7a5186549
+SIZE (ruby/onigd2_5_7.tar.gz) = 215529
diff --git a/devel/oniguruma/files/onig-config b/devel/oniguruma/files/onig-config
new file mode 100644
index 000000000000..5ad4f48a0b1e
--- /dev/null
+++ b/devel/oniguruma/files/onig-config
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+prefix=%%PREFIX%%
+exec_prefix=${prefix}
+exec_prefix_set=no
+
+usage="\
+Usage: onig-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--cflags] [--libs] [--static-libs]"
+
+if test $# -eq 0; then
+ echo "${usage}" 1>&2
+ exit 1
+fi
+
+while test $# -gt 0; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) optarg= ;;
+ esac
+
+ case $1 in
+ --prefix=*)
+ prefix=$optarg
+ if test $exec_prefix_set = no ; then
+ exec_prefix=$optarg
+ fi
+ ;;
+ --prefix)
+ echo $prefix
+ ;;
+ --exec-prefix=*)
+ exec_prefix=$optarg
+ exec_prefix_set=yes
+ ;;
+ --exec-prefix)
+ echo $exec_prefix
+ ;;
+ --version)
+ echo 1.2.9
+ ;;
+ --cflags)
+ echo -I${prefix}/include
+ ;;
+ --libs|--static-libs)
+ libdirs="-L${exec_prefix}/lib -Wl,-rpath,${exec_prefix}/lib"
+ echo $libdirs -lonig
+ ;;
+ *)
+ echo "${usage}" 1>&2
+ exit 1
+ ;;
+ esac
+ shift
+done
diff --git a/devel/oniguruma/pkg-plist b/devel/oniguruma/pkg-plist
index f3e13650fc2c..320c9ee5b5a8 100644
--- a/devel/oniguruma/pkg-plist
+++ b/devel/oniguruma/pkg-plist
@@ -1,3 +1,4 @@
+bin/onig-config
include/oniggnu.h
include/onigposix.h
include/oniguruma.h
diff --git a/devel/oniguruma4/Makefile b/devel/oniguruma4/Makefile
index 5562eea4aff5..b53a733f74ec 100644
--- a/devel/oniguruma4/Makefile
+++ b/devel/oniguruma4/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= oniguruma
-PORTVERSION= 2.5.6
+PORTVERSION= 2.5.7
CATEGORIES= devel
MASTER_SITES= http://www.geocities.jp/kosako3/oniguruma/archive/
DISTNAME= onigd${PORTVERSION:S/./_/g}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= A BSDL Regular Expressions library compatible with POSIX/GNU/Perl
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -23,7 +23,12 @@ GNU_CONFIGURE= yes
DOCS= HISTORY README doc/*
+post-configure:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${FILESDIR}/onig-config > ${WRKSRC}/onig-config
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
diff --git a/devel/oniguruma4/distinfo b/devel/oniguruma4/distinfo
index b2306ebdf24f..3772e21f3365 100644
--- a/devel/oniguruma4/distinfo
+++ b/devel/oniguruma4/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/onigd2_5_6.tar.gz) = b3de8f1445ea90b220cb9c76dc709fb6
-SHA256 (ruby/onigd2_5_6.tar.gz) = e37bf3ee1a0e2e84f86f07b065513a13df2cc57e202f67845e38aa29a7bca15d
-SIZE (ruby/onigd2_5_6.tar.gz) = 212610
+MD5 (ruby/onigd2_5_7.tar.gz) = dcaa0b3608990791a5348e94b2f427d5
+SHA256 (ruby/onigd2_5_7.tar.gz) = 205b2857d77efc4caa3b98eaf91fd1cc8b8722b497df933d1fbd23f7a5186549
+SIZE (ruby/onigd2_5_7.tar.gz) = 215529
diff --git a/devel/oniguruma4/files/onig-config b/devel/oniguruma4/files/onig-config
new file mode 100644
index 000000000000..5ad4f48a0b1e
--- /dev/null
+++ b/devel/oniguruma4/files/onig-config
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+prefix=%%PREFIX%%
+exec_prefix=${prefix}
+exec_prefix_set=no
+
+usage="\
+Usage: onig-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--cflags] [--libs] [--static-libs]"
+
+if test $# -eq 0; then
+ echo "${usage}" 1>&2
+ exit 1
+fi
+
+while test $# -gt 0; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) optarg= ;;
+ esac
+
+ case $1 in
+ --prefix=*)
+ prefix=$optarg
+ if test $exec_prefix_set = no ; then
+ exec_prefix=$optarg
+ fi
+ ;;
+ --prefix)
+ echo $prefix
+ ;;
+ --exec-prefix=*)
+ exec_prefix=$optarg
+ exec_prefix_set=yes
+ ;;
+ --exec-prefix)
+ echo $exec_prefix
+ ;;
+ --version)
+ echo 1.2.9
+ ;;
+ --cflags)
+ echo -I${prefix}/include
+ ;;
+ --libs|--static-libs)
+ libdirs="-L${exec_prefix}/lib -Wl,-rpath,${exec_prefix}/lib"
+ echo $libdirs -lonig
+ ;;
+ *)
+ echo "${usage}" 1>&2
+ exit 1
+ ;;
+ esac
+ shift
+done
diff --git a/devel/oniguruma4/pkg-plist b/devel/oniguruma4/pkg-plist
index f3e13650fc2c..320c9ee5b5a8 100644
--- a/devel/oniguruma4/pkg-plist
+++ b/devel/oniguruma4/pkg-plist
@@ -1,3 +1,4 @@
+bin/onig-config
include/oniggnu.h
include/onigposix.h
include/oniguruma.h
diff --git a/devel/oniguruma5/Makefile b/devel/oniguruma5/Makefile
index 5562eea4aff5..b53a733f74ec 100644
--- a/devel/oniguruma5/Makefile
+++ b/devel/oniguruma5/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= oniguruma
-PORTVERSION= 2.5.6
+PORTVERSION= 2.5.7
CATEGORIES= devel
MASTER_SITES= http://www.geocities.jp/kosako3/oniguruma/archive/
DISTNAME= onigd${PORTVERSION:S/./_/g}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= A BSDL Regular Expressions library compatible with POSIX/GNU/Perl
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -23,7 +23,12 @@ GNU_CONFIGURE= yes
DOCS= HISTORY README doc/*
+post-configure:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${FILESDIR}/onig-config > ${WRKSRC}/onig-config
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
diff --git a/devel/oniguruma5/distinfo b/devel/oniguruma5/distinfo
index b2306ebdf24f..3772e21f3365 100644
--- a/devel/oniguruma5/distinfo
+++ b/devel/oniguruma5/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/onigd2_5_6.tar.gz) = b3de8f1445ea90b220cb9c76dc709fb6
-SHA256 (ruby/onigd2_5_6.tar.gz) = e37bf3ee1a0e2e84f86f07b065513a13df2cc57e202f67845e38aa29a7bca15d
-SIZE (ruby/onigd2_5_6.tar.gz) = 212610
+MD5 (ruby/onigd2_5_7.tar.gz) = dcaa0b3608990791a5348e94b2f427d5
+SHA256 (ruby/onigd2_5_7.tar.gz) = 205b2857d77efc4caa3b98eaf91fd1cc8b8722b497df933d1fbd23f7a5186549
+SIZE (ruby/onigd2_5_7.tar.gz) = 215529
diff --git a/devel/oniguruma5/files/onig-config b/devel/oniguruma5/files/onig-config
new file mode 100644
index 000000000000..5ad4f48a0b1e
--- /dev/null
+++ b/devel/oniguruma5/files/onig-config
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+prefix=%%PREFIX%%
+exec_prefix=${prefix}
+exec_prefix_set=no
+
+usage="\
+Usage: onig-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--cflags] [--libs] [--static-libs]"
+
+if test $# -eq 0; then
+ echo "${usage}" 1>&2
+ exit 1
+fi
+
+while test $# -gt 0; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) optarg= ;;
+ esac
+
+ case $1 in
+ --prefix=*)
+ prefix=$optarg
+ if test $exec_prefix_set = no ; then
+ exec_prefix=$optarg
+ fi
+ ;;
+ --prefix)
+ echo $prefix
+ ;;
+ --exec-prefix=*)
+ exec_prefix=$optarg
+ exec_prefix_set=yes
+ ;;
+ --exec-prefix)
+ echo $exec_prefix
+ ;;
+ --version)
+ echo 1.2.9
+ ;;
+ --cflags)
+ echo -I${prefix}/include
+ ;;
+ --libs|--static-libs)
+ libdirs="-L${exec_prefix}/lib -Wl,-rpath,${exec_prefix}/lib"
+ echo $libdirs -lonig
+ ;;
+ *)
+ echo "${usage}" 1>&2
+ exit 1
+ ;;
+ esac
+ shift
+done
diff --git a/devel/oniguruma5/pkg-plist b/devel/oniguruma5/pkg-plist
index f3e13650fc2c..320c9ee5b5a8 100644
--- a/devel/oniguruma5/pkg-plist
+++ b/devel/oniguruma5/pkg-plist
@@ -1,3 +1,4 @@
+bin/onig-config
include/oniggnu.h
include/onigposix.h
include/oniguruma.h