aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/cvsstat/Makefile2
-rw-r--r--devel/p5-App-Rad/Makefile3
-rw-r--r--devel/p5-App-Trace/Makefile9
-rw-r--r--devel/p5-AppConfig-Std/Makefile3
-rw-r--r--devel/p5-Class-Date/Makefile9
-rw-r--r--devel/p5-Data-Rmap/Makefile9
-rw-r--r--devel/p5-Data-Structure-Util/Makefile9
-rw-r--r--devel/p5-Data-Uniqid/Makefile9
-rw-r--r--devel/p5-Getopt-Attribute/Makefile9
-rw-r--r--devel/p5-IO-FDPass/Makefile3
-rw-r--r--devel/p5-IPC-MMA/Makefile9
-rw-r--r--devel/p5-MouseX-ConfigFromFile/Makefile9
-rw-r--r--devel/p5-POE-Quickie/Makefile9
-rw-r--r--devel/p5-ShipIt-Step-Manifest/Makefile9
-rw-r--r--devel/p5-Sort-Array/Makefile3
-rw-r--r--devel/p5-Tie-Hash-MultiValue/Makefile9
-rw-r--r--devel/p5-Tie-ToObject/Makefile9
-rw-r--r--devel/p5-VCP-Dest-svk/Makefile9
-rw-r--r--devel/p5-VCS-CVS/Makefile9
19 files changed, 51 insertions, 89 deletions
diff --git a/devel/cvsstat/Makefile b/devel/cvsstat/Makefile
index 657d1ba0e692..b9eda7ed908f 100644
--- a/devel/cvsstat/Makefile
+++ b/devel/cvsstat/Makefile
@@ -13,7 +13,7 @@ EXTRACT_ONLY= # empty
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Transforms the output of 'cvs status' to a sorted ASCII table
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
PLIST_FILES= bin/cvsstat
diff --git a/devel/p5-App-Rad/Makefile b/devel/p5-App-Rad/Makefile
index b9670293d28b..297f3bdd494c 100644
--- a/devel/p5-App-Rad/Makefile
+++ b/devel/p5-App-Rad/Makefile
@@ -13,7 +13,8 @@ COMMENT= Rapid (and easy!) creation of command line applications
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= App::Rad.3 \
App::Rad::Exclude.3 \
diff --git a/devel/p5-App-Trace/Makefile b/devel/p5-App-Trace/Makefile
index b15a45e8a937..99241762e6a6 100644
--- a/devel/p5-App-Trace/Makefile
+++ b/devel/p5-App-Trace/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-App-Trace
-# Date created: 2006-08-20
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= App-Trace
PORTVERSION= 0.50
@@ -16,7 +12,8 @@ COMMENT= Embedded debug statements, including call/return tracing
RUN_DEPENDS= p5-App-Options>=0:${PORTSDIR}/devel/p5-App-Options
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= App::Trace.3
diff --git a/devel/p5-AppConfig-Std/Makefile b/devel/p5-AppConfig-Std/Makefile
index 6ebfef2604f9..0985e24b1311 100644
--- a/devel/p5-AppConfig-Std/Makefile
+++ b/devel/p5-AppConfig-Std/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-AppConfig>=1.52:${PORTSDIR}/devel/p5-AppConfig
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AppConfig::Std.3
diff --git a/devel/p5-Class-Date/Makefile b/devel/p5-Class-Date/Makefile
index d55faf70e9b8..f01d226ed043 100644
--- a/devel/p5-Class-Date/Makefile
+++ b/devel/p5-Class-Date/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Class-Date
-# Date Created: 28 June 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= Class-Date
PORTVERSION= 1.1.10
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= culot@FreeBSD.org
COMMENT= A Perl class for easy date and time manipulation
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Date.3
diff --git a/devel/p5-Data-Rmap/Makefile b/devel/p5-Data-Rmap/Makefile
index 42accc94af98..b802c773a511 100644
--- a/devel/p5-Data-Rmap/Makefile
+++ b/devel/p5-Data-Rmap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Rmap
-# Date created: 2010-11-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Data-Rmap
PORTVERSION= 0.62
@@ -16,7 +12,8 @@ COMMENT= Recursive map, apply a block to a data structure
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Data::Rmap.3
diff --git a/devel/p5-Data-Structure-Util/Makefile b/devel/p5-Data-Structure-Util/Makefile
index 04464d77d487..adc3ea16c5b4 100644
--- a/devel/p5-Data-Structure-Util/Makefile
+++ b/devel/p5-Data-Structure-Util/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Structure
-# Date created: April 9 2006
-# Whom: Jon Nistor <nistor@snickers.org>
-#
+# Created by: Jon Nistor <nistor@snickers.org>
# $FreeBSD$
-#
PORTNAME= Data-Structure-Util
PORTVERSION= 0.15
@@ -18,7 +14,8 @@ COMMENT= Perl5 module to change the nature of data within a structure
BUILD_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Structure::Util.3
diff --git a/devel/p5-Data-Uniqid/Makefile b/devel/p5-Data-Uniqid/Makefile
index 3acf74ba5f15..70c79a12dbc2 100644
--- a/devel/p5-Data-Uniqid/Makefile
+++ b/devel/p5-Data-Uniqid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Uniqid
-# Date created: 2008-11-28
-# Whom: Sergey V. Dyatko <sergey.dyatko@gmail.com>
-#
+# Created by: Sergey V. Dyatko <sergey.dyatko@gmail.com>
# $FreeBSD$
-#
PORTNAME= Data-Uniqid
PORTVERSION= 0.12
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sergey.dyatko@gmail.com
COMMENT= Perl extension for simple genrating of unique id's
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Uniqid.3
diff --git a/devel/p5-Getopt-Attribute/Makefile b/devel/p5-Getopt-Attribute/Makefile
index 0303af137b6f..950d6d64fbbf 100644
--- a/devel/p5-Getopt-Attribute/Makefile
+++ b/devel/p5-Getopt-Attribute/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Getopt-Attribute
-# Date created: 2010-11-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Getopt-Attribute
PORTVERSION= 2.101700
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Attribute wrapper for Getopt::Long
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Getopt::Attribute.3
diff --git a/devel/p5-IO-FDPass/Makefile b/devel/p5-IO-FDPass/Makefile
index 9d9856f01855..54339817dce5 100644
--- a/devel/p5-IO-FDPass/Makefile
+++ b/devel/p5-IO-FDPass/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to pass a file descriptor over a socket
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::FDPass.3
diff --git a/devel/p5-IPC-MMA/Makefile b/devel/p5-IPC-MMA/Makefile
index a086901d853f..ea843690ff06 100644
--- a/devel/p5-IPC-MMA/Makefile
+++ b/devel/p5-IPC-MMA/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: IPC-MMA
-# Date created: 24 May 2011
-# Whom: Peter Vereshagin <peter@vereshagin.org>
-#
+# Created by: Peter Vereshagin <peter@vereshagin.org>
# $FreeBSD$
-#
PORTNAME= IPC-MMA
PORTVERSION= 0.81
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Devel-CheckOS>=0:${PORTSDIR}/devel/p5-Devel-CheckOS
LIB_DEPENDS= mm.14:${PORTSDIR}/devel/mm
TEST_DEPENDS= p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IPC::MMA.3
diff --git a/devel/p5-MouseX-ConfigFromFile/Makefile b/devel/p5-MouseX-ConfigFromFile/Makefile
index 5ccaae3cc4b5..b526c8569968 100644
--- a/devel/p5-MouseX-ConfigFromFile/Makefile
+++ b/devel/p5-MouseX-ConfigFromFile/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MouseX-ConfigFromFile
-# Date created: 2009-04-22
-# Whom: TERAMOTO Masahiro <markun@onohara.to>
-#
+# Created by: TERAMOTO Masahiro <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= MouseX-ConfigFromFile
PORTVERSION= 0.05
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Filter>=0:${PORTSDIR}/devel/p5-Filter \
p5-MouseX-Types-Path-Class>=0.05:${PORTSDIR}/devel/p5-MouseX-Types-Path-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MouseX::ConfigFromFile.3
diff --git a/devel/p5-POE-Quickie/Makefile b/devel/p5-POE-Quickie/Makefile
index 05602249c716..bca43f5aea94 100644
--- a/devel/p5-POE-Quickie/Makefile
+++ b/devel/p5-POE-Quickie/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-POE-Quickie
-# Date created: 2011-05-04
-# Whom: Takefu
-#
+# Created by: Takefu
# $FreeBSD$
-#
PORTNAME= POE-Quickie
PORTVERSION= 0.18
@@ -24,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Capture-Tiny>=0.07:${PORTSDIR}/devel/p5-Capture-Tiny \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Quickie.3
diff --git a/devel/p5-ShipIt-Step-Manifest/Makefile b/devel/p5-ShipIt-Step-Manifest/Makefile
index 98d139fd1815..4d5d19976d42 100644
--- a/devel/p5-ShipIt-Step-Manifest/Makefile
+++ b/devel/p5-ShipIt-Step-Manifest/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-ShipIt-Step-Manifest
-# Date created: 2010-11-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= ShipIt-Step-Manifest
PORTVERSION= 0.01
@@ -18,7 +14,8 @@ COMMENT= ShipIt step for recreating the MANIFEST
RUN_DEPENDS= p5-Dist-Joseki>=0:${PORTSDIR}/devel/p5-Dist-Joseki \
p5-ShipIt>=0:${PORTSDIR}/devel/p5-ShipIt
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ShipIt::Step::Manifest.3
diff --git a/devel/p5-Sort-Array/Makefile b/devel/p5-Sort-Array/Makefile
index 21d50c5dd373..e08cbec5965e 100644
--- a/devel/p5-Sort-Array/Makefile
+++ b/devel/p5-Sort-Array/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Powerful array sorting Perl interface
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sort::Array.3
diff --git a/devel/p5-Tie-Hash-MultiValue/Makefile b/devel/p5-Tie-Hash-MultiValue/Makefile
index f26a074b3d6c..c40b666b875c 100644
--- a/devel/p5-Tie-Hash-MultiValue/Makefile
+++ b/devel/p5-Tie-Hash-MultiValue/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-Hash-MultiValue
-# Date created: 2010-09-10
-# Whom: Frederic Culot <frederic@culot.org>
-#
+# Created by: Frederic Culot <frederic@culot.org>
# $FreeBSD$
-#
PORTNAME= Tie-Hash-MultiValue
PORTVERSION= 1.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= culot@FreeBSD.org
COMMENT= Store multiple values per key
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::Hash::MultiValue.3
diff --git a/devel/p5-Tie-ToObject/Makefile b/devel/p5-Tie-ToObject/Makefile
index 45309e256415..306add2621db 100644
--- a/devel/p5-Tie-ToObject/Makefile
+++ b/devel/p5-Tie-ToObject/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-ToObject
-# Date created: 2008-02-13
-# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
-#
+# Created by: Felippe de Meirelles Motta <lippemail@gmail.com>
# $FreeBSD$
-#
PORTNAME= Tie-ToObject
PORTVERSION= 0.03
@@ -17,7 +13,8 @@ COMMENT= Tie to an existing object
TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::ToObject.3
diff --git a/devel/p5-VCP-Dest-svk/Makefile b/devel/p5-VCP-Dest-svk/Makefile
index b76319d1de0f..6206e155d639 100644
--- a/devel/p5-VCP-Dest-svk/Makefile
+++ b/devel/p5-VCP-Dest-svk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-VCP-Dest-svk
-# Date created: Jul 19 2004
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= VCP-Dest-svk
PORTVERSION= 0.29
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-VCP-autrijus>=0:${PORTSDIR}/devel/p5-VCP-autrijus \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= VCP::Dest::svk.3
diff --git a/devel/p5-VCS-CVS/Makefile b/devel/p5-VCS-CVS/Makefile
index 8cb75dd1dca4..3f9687ea7a1c 100644
--- a/devel/p5-VCS-CVS/Makefile
+++ b/devel/p5-VCS-CVS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-VCS-CVS
-# Date created: 15 May 2001
-# Whom: Anatoliy Dmytriyev <tolid@plab.ku.dk>
-#
+# Created by: Anatoliy Dmytriyev <tolid@plab.ku.dk>
# $FreeBSD$
-#
PORTNAME= VCS-CVS
PORTVERSION= 2.06
@@ -18,7 +14,8 @@ COMMENT= Perl module that provides a simple interface to CVS
BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= VCS::CVS.3
.include <bsd.port.mk>