aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/vo-amrwbenc/Makefile37
-rw-r--r--audio/vo-amrwbenc/distinfo2
-rw-r--r--audio/vo-amrwbenc/pkg-descr8
-rw-r--r--audio/vo-amrwbenc/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 19fdf1284cee..993a0e246564 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -779,6 +779,7 @@
SUBDIR += ventrilo-server
SUBDIR += vitunes
SUBDIR += vo-aacenc
+ SUBDIR += vo-amrwbenc
SUBDIR += voipong
SUBDIR += volumecontrol.app
SUBDIR += vorbis-tools
diff --git a/audio/vo-amrwbenc/Makefile b/audio/vo-amrwbenc/Makefile
new file mode 100644
index 000000000000..7da2338ee70e
--- /dev/null
+++ b/audio/vo-amrwbenc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: vo-amrwbenc
+# Date created: 23 Jun 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vo-amrwbenc
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= https://github.com/mstorsjo/${PORTNAME}/tarball/v${PORTVERSION}/
+DISTNAME= mstorsjo-${PORTNAME}-v${PORTVERSION}-0-g${GITVERSION}
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= VisualOn AMR-WB encoder library
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GITVERSION= b20d264
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/mstorsjo-${PORTNAME}-${GITVERSION}
+
+GNU_CONFIGURE= yes
+
+USE_AUTOTOOLS= libtoolize aclocal autoheader autoconf automake
+ACLOCAL_ARGS= -I m4
+AUTOCONF_ARGS= -I m4
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E -e \
+ 's|^pkgconfigdir = .*|pkgconfigdir = $$(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.am
+
+.include <bsd.port.post.mk>
diff --git a/audio/vo-amrwbenc/distinfo b/audio/vo-amrwbenc/distinfo
new file mode 100644
index 000000000000..60d19ed92692
--- /dev/null
+++ b/audio/vo-amrwbenc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mstorsjo-vo-amrwbenc-v0.1.1-0-gb20d264.tar.gz) = 674fae9dddc52abffc4e441f15ad3a388f993331e97a70a31e01e213018b236e
+SIZE (mstorsjo-vo-amrwbenc-v0.1.1-0-gb20d264.tar.gz) = 473426
diff --git a/audio/vo-amrwbenc/pkg-descr b/audio/vo-amrwbenc/pkg-descr
new file mode 100644
index 000000000000..4b2326d6085d
--- /dev/null
+++ b/audio/vo-amrwbenc/pkg-descr
@@ -0,0 +1,8 @@
+VisualOn AMR-WB encoder library
+
+This library contains an encoder implementation of the Adaptive Multi
+Rate Wideband (AMR-WB) audio codec. The library is based on a codec
+implementation by VisualOn as part of the Stagefright framework from
+the Google Android project.
+
+WWW: https://github.com/mstorsjo/vo-amrwbenc
diff --git a/audio/vo-amrwbenc/pkg-plist b/audio/vo-amrwbenc/pkg-plist
new file mode 100644
index 000000000000..b84b49778185
--- /dev/null
+++ b/audio/vo-amrwbenc/pkg-plist
@@ -0,0 +1,7 @@
+include/vo-amrwbenc/enc_if.h
+lib/libvo-amrwbenc.a
+lib/libvo-amrwbenc.la
+lib/libvo-amrwbenc.so
+lib/libvo-amrwbenc.so.0
+libdata/pkgconfig/vo-amrwbenc.pc
+@dirrm include/vo-amrwbenc