aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-multi_json/Makefile38
-rw-r--r--devel/rubygem-multi_json/distinfo2
-rw-r--r--devel/rubygem-multi_json/pkg-descr8
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ca2ac3822216..d84ba4aea01f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3220,6 +3220,7 @@
SUBDIR += rubygem-mocha
SUBDIR += rubygem-moneta
SUBDIR += rubygem-msgpack
+ SUBDIR += rubygem-multi_json
SUBDIR += rubygem-mutter
SUBDIR += rubygem-ncurses
SUBDIR += rubygem-needle
diff --git a/devel/rubygem-multi_json/Makefile b/devel/rubygem-multi_json/Makefile
new file mode 100644
index 000000000000..2691e6537cda
--- /dev/null
+++ b/devel/rubygem-multi_json/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: multi_json
+# Date created: Mar 4, 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= multi_json
+PORTVERSION= 0.0.5
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library provide swappable JSON backends
+
+OPTIONS= JSON "JSON implementation as a Ruby extension in C" off \
+ JSON_PURE "JSON implementation in pure Ruby" on \
+ YAJL_RUBY "Yajl JSON stream-based parser library" off
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_JSON)
+RUN_DEPENDS+= rubygem-json>=0:${PORTSDIR}/devel/rubygem-json
+.endif
+
+.if defined(WITH_JSON_PURE)
+RUN_DEPENDS+= rubygem-json_pure>=0:${PORTSDIR}/devel/rubygem-json_pure
+.endif
+
+.if defined(WITH_YAJL_RUBY)
+RUN_DEPENDS+= rubygem-yajl-ruby>=0:${PORTSDIR}/devel/rubygem-yajl-ruby
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/rubygem-multi_json/distinfo b/devel/rubygem-multi_json/distinfo
new file mode 100644
index 000000000000..3ffa1b6b0c38
--- /dev/null
+++ b/devel/rubygem-multi_json/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/multi_json-0.0.5.gem) = 12831c7b53ef751995befba2ff522561bf4692cdc5c268729625243dbc2ad774
+SIZE (rubygem/multi_json-0.0.5.gem) = 8192
diff --git a/devel/rubygem-multi_json/pkg-descr b/devel/rubygem-multi_json/pkg-descr
new file mode 100644
index 000000000000..5e5d8161b804
--- /dev/null
+++ b/devel/rubygem-multi_json/pkg-descr
@@ -0,0 +1,8 @@
+This library is a generic swappable back-end for JSON handling.
+
+Lots of Ruby libraries utilize JSON parsing in some form, and
+everyone has their favorite JSON library. In order to best support
+multiple JSON parsers and libraries, multi_json is a
+general-purpose swappable JSON backend library.
+
+WWW: http://rdoc.info/projects/intridea/multi_json