aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/eggdrop/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/irc/eggdrop/Makefile b/irc/eggdrop/Makefile
index 74ef74b73a76..04034df31548 100644
--- a/irc/eggdrop/Makefile
+++ b/irc/eggdrop/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
PATCHFILES= ${PORTNAME}-${PORTVERSION}-ssl.patch.gz
PATCH_SITES= http://www.egghelp.org/files/patches/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= beech@alaskaparadise.com
COMMENT= The most popular open source Internet Relay Chat bot
LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
@@ -25,22 +25,21 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-tcllib=${LOCALBASE}/lib/libtcl84.so \
--with-tclinc=${LOCALBASE}/include/tcl8.4/tcl.h
+OPTIONS= SSL "Use SSL" off
+
MAN1= eggdrop.1
SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
+
.if defined(WITH_SSL)
-USE_OPENSSL= yes
+CFLAGS+= -DHAVE_OPENSSL
CONFIGURE_ARGS+= --with-ssl
-.else
-CONFIGURE_ARGS+= --without-ssl
.endif
-.include <bsd.port.pre.mk>
-
-pre-everything::
.if !defined(WITH_SSL)
- @${ECHO_MSG} 'Define WITH_SSL to enable SSL support'
+CONFIGURE_ARGS+= --without-ssl
.endif
post-patch: