aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/postfix/Makefile7
-rw-r--r--mail/postfix/pkg-install7
-rw-r--r--mail/postfix/pkg-plist6
-rw-r--r--mail/postfix1/Makefile7
-rw-r--r--mail/postfix1/pkg-install7
-rw-r--r--mail/postfix1/pkg-plist6
-rw-r--r--mail/postfix20/Makefile7
-rw-r--r--mail/postfix20/pkg-install7
-rw-r--r--mail/postfix20/pkg-plist6
-rw-r--r--mail/postfix21/Makefile7
-rw-r--r--mail/postfix21/pkg-install7
-rw-r--r--mail/postfix21/pkg-plist6
-rw-r--r--mail/postfix22/Makefile7
-rw-r--r--mail/postfix22/pkg-install7
-rw-r--r--mail/postfix22/pkg-plist6
-rw-r--r--mail/postfix23/Makefile7
-rw-r--r--mail/postfix23/pkg-install7
-rw-r--r--mail/postfix23/pkg-plist6
-rw-r--r--mail/postfix24/Makefile7
-rw-r--r--mail/postfix24/pkg-install7
-rw-r--r--mail/postfix24/pkg-plist6
-rw-r--r--mail/postfix25/Makefile7
-rw-r--r--mail/postfix25/pkg-install7
-rw-r--r--mail/postfix25/pkg-plist6
-rw-r--r--mail/postfix26/Makefile7
-rw-r--r--mail/postfix26/pkg-install7
-rw-r--r--mail/postfix26/pkg-plist6
-rw-r--r--mail/postfix27/Makefile7
-rw-r--r--mail/postfix27/pkg-install7
-rw-r--r--mail/postfix27/pkg-plist6
-rw-r--r--mail/postfix28/Makefile7
-rw-r--r--mail/postfix28/pkg-install7
-rw-r--r--mail/postfix28/pkg-plist6
33 files changed, 198 insertions, 22 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix/pkg-install b/mail/postfix/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix/pkg-install
+++ b/mail/postfix/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix/pkg-plist b/mail/postfix/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix/pkg-plist
+++ b/mail/postfix/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix1/Makefile b/mail/postfix1/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix1/Makefile
+++ b/mail/postfix1/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix1/pkg-install b/mail/postfix1/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix1/pkg-install
+++ b/mail/postfix1/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix1/pkg-plist b/mail/postfix1/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix1/pkg-plist
+++ b/mail/postfix1/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix20/Makefile b/mail/postfix20/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix20/Makefile
+++ b/mail/postfix20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix20/pkg-install b/mail/postfix20/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix20/pkg-install
+++ b/mail/postfix20/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix20/pkg-plist b/mail/postfix20/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix20/pkg-plist
+++ b/mail/postfix20/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix21/Makefile b/mail/postfix21/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix21/Makefile
+++ b/mail/postfix21/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix21/pkg-install b/mail/postfix21/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix21/pkg-install
+++ b/mail/postfix21/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix21/pkg-plist b/mail/postfix21/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix21/pkg-plist
+++ b/mail/postfix21/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix22/Makefile b/mail/postfix22/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix22/Makefile
+++ b/mail/postfix22/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix22/pkg-install b/mail/postfix22/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix22/pkg-install
+++ b/mail/postfix22/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix22/pkg-plist b/mail/postfix22/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix22/pkg-plist
+++ b/mail/postfix22/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix23/Makefile b/mail/postfix23/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix23/Makefile
+++ b/mail/postfix23/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix23/pkg-install b/mail/postfix23/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix23/pkg-install
+++ b/mail/postfix23/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix23/pkg-plist b/mail/postfix23/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix23/pkg-plist
+++ b/mail/postfix23/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix24/Makefile b/mail/postfix24/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix24/Makefile
+++ b/mail/postfix24/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix24/pkg-install b/mail/postfix24/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix24/pkg-install
+++ b/mail/postfix24/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix24/pkg-plist b/mail/postfix24/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix24/pkg-plist
+++ b/mail/postfix24/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix25/Makefile b/mail/postfix25/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix25/Makefile
+++ b/mail/postfix25/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix25/pkg-install b/mail/postfix25/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix25/pkg-install
+++ b/mail/postfix25/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix25/pkg-plist b/mail/postfix25/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix25/pkg-plist
+++ b/mail/postfix25/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix26/pkg-install b/mail/postfix26/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix26/pkg-install
+++ b/mail/postfix26/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix26/pkg-plist b/mail/postfix26/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix26/pkg-plist
+++ b/mail/postfix26/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix27/pkg-install b/mail/postfix27/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix27/pkg-install
+++ b/mail/postfix27/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix27/pkg-plist b/mail/postfix27/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix27/pkg-plist
+++ b/mail/postfix27/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index e9eddbfb037f..09258cd2e865 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 1.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -78,6 +79,12 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/main.cf \
+ ${PREFIX}/etc/postfix/sample-main.cf
+
+ @${INSTALL_DATA} ${WRKSRC}/conf/master.cf \
+ ${PREFIX}/etc/postfix/sample-master.cf
+
@${INSTALL_SCRIPT} \
${WRKSRC}/auxiliary/rmail/rmail \
${PREFIX}/bin/rmail
diff --git a/mail/postfix28/pkg-install b/mail/postfix28/pkg-install
index b2b0e42a0332..2e4266564c2b 100644
--- a/mail/postfix28/pkg-install
+++ b/mail/postfix28/pkg-install
@@ -83,6 +83,13 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
if [ x"$2" = xPOST-INSTALL ]; then
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/main.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-main.cf ${PKG_PREFIX}/etc/postfix/main.cf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/postfix/master.cf ]; then
+ cp ${PKG_PREFIX}/etc/postfix/sample-master.cf ${PKG_PREFIX}/etc/postfix/master.cf
+ fi
+
sh ${PKG_PREFIX}/etc/postfix/post-install tempdir=/tmp \
config_directory=${PKG_PREFIX}/etc/postfix \
daemon_directory=${PKG_PREFIX}/libexec/postfix \
diff --git a/mail/postfix28/pkg-plist b/mail/postfix28/pkg-plist
index 84154a9969fd..0bcc22b0ef74 100644
--- a/mail/postfix28/pkg-plist
+++ b/mail/postfix28/pkg-plist
@@ -5,9 +5,7 @@ etc/postfix/LICENSE
etc/postfix/access
etc/postfix/aliases
etc/postfix/canonical
-etc/postfix/main.cf
etc/postfix/main.cf.default
-etc/postfix/master.cf
etc/postfix/pcre_table
etc/postfix/post-install
etc/postfix/postfix-files
@@ -24,6 +22,8 @@ etc/postfix/sample-flush.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
+etc/postfix/sample-main.cf
+etc/postfix/sample-master.cf
etc/postfix/sample-misc.cf
etc/postfix/sample-pcre-access.cf
etc/postfix/sample-pcre-body.cf
@@ -74,6 +74,8 @@ sbin/postmap
sbin/postqueue
sbin/postsuper
sbin/sendmail
+bin/newaliases
+bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
%%PORTDOCS%%share/doc/postfix/DB_README