aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/sdl_net/Makefile6
-rw-r--r--net/sdl_net/distinfo6
-rw-r--r--net/sdl_net/files/patch-Makefile.in10
-rw-r--r--net/sdl_net/files/patch-SDLnetselect.c29
-rw-r--r--net/sdl_net/files/patch-SDLnetsys.h (renamed from net/sdl_net/files/patch-aa)0
-rw-r--r--net/sdl_net/pkg-plist3
6 files changed, 8 insertions, 46 deletions
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index ddd2b0a6bd43..4f4ee0091db3 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= sdl_net
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.2.7
CATEGORIES= net
MASTER_SITES= http://www.libsdl.org/projects/SDL_net/release/
DISTNAME= SDL_net-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mva@sysfault.org
COMMENT= A small sample cross-platform networking library
+USE_AUTOTOOLS= libtool:15
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/net/sdl_net/distinfo b/net/sdl_net/distinfo
index 2459e6a3ad5c..519c86c2d883 100644
--- a/net/sdl_net/distinfo
+++ b/net/sdl_net/distinfo
@@ -1,3 +1,3 @@
-MD5 (SDL_net-1.2.6.tar.gz) = 7be5b9ef36129ee187ace96906cd264c
-SHA256 (SDL_net-1.2.6.tar.gz) = 1a4b1a9e63e3cb6a9d482c7fecb0da0edb5b285d06e221cdabdbd421e747554b
-SIZE (SDL_net-1.2.6.tar.gz) = 372116
+MD5 (SDL_net-1.2.7.tar.gz) = 6bd4662d1423810f3140d4da21b6d912
+SHA256 (SDL_net-1.2.7.tar.gz) = 2ce7c84e62ff8117b9f205758bcce68ea603e08bc9d6936ded343735b8b77c53
+SIZE (SDL_net-1.2.7.tar.gz) = 373866
diff --git a/net/sdl_net/files/patch-Makefile.in b/net/sdl_net/files/patch-Makefile.in
deleted file mode 100644
index 93796b1512a6..000000000000
--- a/net/sdl_net/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Thu Aug 31 14:52:06 2006
-+++ Makefile.in Thu Aug 31 14:52:12 2006
-@@ -263,7 +263,6 @@
- libSDL_net_la_LIBADD = @INETLIB@
- libSDL_net_la_LDFLAGS = \
- -no-undefined \
-- -release $(LT_RELEASE) \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- @HAVE_GUI_LIB_FALSE@EXAMPLES =
diff --git a/net/sdl_net/files/patch-SDLnetselect.c b/net/sdl_net/files/patch-SDLnetselect.c
deleted file mode 100644
index b29640787a83..000000000000
--- a/net/sdl_net/files/patch-SDLnetselect.c
+++ /dev/null
@@ -1,29 +0,0 @@
-
-$FreeBSD$
-
---- SDLnetselect.c 2001/07/25 09:44:01 1.1
-+++ SDLnetselect.c 2001/07/25 09:45:57
-@@ -175,6 +175,7 @@
- SOCKET maxfd;
- int retval;
- struct timeval tv;
-+ struct timeval *tmp;
- fd_set mask;
-
- /* Find the largest file descriptor */
-@@ -199,8 +200,14 @@
- tv.tv_sec = timeout/1000;
- tv.tv_usec = (timeout%1000)*1000;
-
-+ /* XXX: Workaround for a bug in FreeBSD - w/o it in some cases select() chews 100% CPU */
-+ if (timeout == ~0)
-+ tmp = NULL;
-+ else
-+ tmp = &tv;
-+
- /* Look! */
-- retval = select(maxfd+1, &mask, NULL, NULL, &tv);
-+ retval = select(maxfd+1, &mask, NULL, NULL, tmp);
- } while ( errno == EINTR );
-
- /* Mark all file descriptors ready that have data available */
diff --git a/net/sdl_net/files/patch-aa b/net/sdl_net/files/patch-SDLnetsys.h
index db99084f9e97..db99084f9e97 100644
--- a/net/sdl_net/files/patch-aa
+++ b/net/sdl_net/files/patch-SDLnetsys.h
diff --git a/net/sdl_net/pkg-plist b/net/sdl_net/pkg-plist
index d9dd4f0fd220..e822b2535d73 100644
--- a/net/sdl_net/pkg-plist
+++ b/net/sdl_net/pkg-plist
@@ -1,6 +1,7 @@
include/SDL/SDL_net.h
+lib/libSDL_net-1.2.so
+lib/libSDL_net-1.2.so.0
lib/libSDL_net.a
lib/libSDL_net.la
lib/libSDL_net.so
-lib/libSDL_net.so.0
@dirrmtry include/SDL