aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/alure/Makefile2
-rw-r--r--audio/freealut/Makefile2
-rw-r--r--audio/openal-soft/Makefile4
-rw-r--r--devel/love07/Makefile2
-rw-r--r--devel/love08/Makefile2
-rw-r--r--emulators/fs-uae/Makefile2
-rw-r--r--emulators/pcem/Makefile6
-rw-r--r--emulators/rpcs3/Makefile5
-rw-r--r--games/OpenTomb/Makefile2
-rw-r--r--games/allacrost/Makefile2
-rw-r--r--games/apricots/Makefile2
-rw-r--r--games/aquaria/Makefile5
-rw-r--r--games/arx-libertatis/Makefile2
-rw-r--r--games/assaultcube/Makefile2
-rw-r--r--games/astromenace/Makefile2
-rw-r--r--games/atr3d/Makefile2
-rw-r--r--games/avp/Makefile3
-rw-r--r--games/barony/Makefile2
-rw-r--r--games/blackshadeselite/Makefile3
-rw-r--r--games/chromium-bsu/Makefile2
-rw-r--r--games/colobot/Makefile2
-rw-r--r--games/dhewm3/Makefile3
-rw-r--r--games/diaspora/Makefile3
-rw-r--r--games/el/Makefile2
-rw-r--r--games/endless-sky/Makefile3
-rw-r--r--games/excido/Makefile2
-rw-r--r--games/flightgear/Makefile3
-rw-r--r--games/freedoko/Makefile3
-rw-r--r--games/freeminer/Makefile2
-rw-r--r--games/freeorion/Makefile3
-rw-r--r--games/fs2open/Makefile3
-rw-r--r--games/glest/Makefile2
-rw-r--r--games/ioquake3/Makefile2
-rw-r--r--games/iortcw/Makefile3
-rw-r--r--games/irrlamb/Makefile3
-rw-r--r--games/keeperrl/Makefile3
-rw-r--r--games/linwarrior/Makefile3
-rw-r--r--games/lugaru/Makefile3
-rw-r--r--games/megaglest/Makefile2
-rw-r--r--games/minetest/Makefile3
-rw-r--r--games/naev/Makefile1
-rw-r--r--games/openclonk/Makefile2
-rw-r--r--games/openomf/Makefile3
-rw-r--r--games/opensurge/Makefile3
-rw-r--r--games/regoth/Makefile3
-rw-r--r--games/retroarch/Makefile2
-rw-r--r--games/scorched3d/Makefile2
-rw-r--r--games/spacezero/Makefile2
-rw-r--r--games/spring/Makefile1
-rw-r--r--games/springlobby/Makefile1
-rw-r--r--games/stuntrally/Makefile3
-rw-r--r--games/supertux2/Makefile2
-rw-r--r--games/supertuxkart/Makefile1
-rw-r--r--games/tome4/Makefile2
-rw-r--r--games/trigger-rally/Makefile2
-rw-r--r--games/ultimatestunts/Makefile4
-rw-r--r--games/valyriatear/Makefile2
-rw-r--r--games/vamos/Makefile2
-rw-r--r--graphics/magnum-examples/Makefile3
-rw-r--r--graphics/reallyslick/Makefile3
-rw-r--r--multimedia/mpv/Makefile3
-rw-r--r--net-im/toxic/Makefile2
62 files changed, 70 insertions, 86 deletions
diff --git a/audio/alure/Makefile b/audio/alure/Makefile
index 227e5e6ed236..154c5aff706a 100644
--- a/audio/alure/Makefile
+++ b/audio/alure/Makefile
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake compiler:c++11-lang openal:soft pkgconfig
USE_LDCONFIG= yes
-LLD_UNSAFE= yes # lld disallows preemption of protected visibility syms
CMAKE_OFF= BUILD_DOCS BUILD_STATIC
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= *
PORTEXAMPLES= *
diff --git a/audio/freealut/Makefile b/audio/freealut/Makefile
index 5ffc52874160..2225504640f3 100644
--- a/audio/freealut/Makefile
+++ b/audio/freealut/Makefile
@@ -16,7 +16,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USES= gmake libtool openal:al pathfix pkgconfig
USE_LDCONFIG= yes
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
INSTALL_TARGET= install-strip
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 6447b7c225ad..98446f59f7a4 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -24,10 +24,6 @@ CMAKE_ON= ALSOFT_BACKEND_WAVE ALSOFT_UTILS
# do not link with librt and libdl.
LDFLAGS+= -Wl,--as-needed
LDFLAGS_i386= -Wl,-z,notext
-# XXX Drop after FreeBSD 12.0 EOL
-.if exists(/usr/lib/clang/6.0.1)
-LLD_UNSAFE= yes
-.endif
PLIST_SUB= SOVERSION=${PORTVERSION}
diff --git a/devel/love07/Makefile b/devel/love07/Makefile
index f7d18173235f..5bdf2f04296a 100644
--- a/devel/love07/Makefile
+++ b/devel/love07/Makefile
@@ -32,7 +32,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
-I${LUA_INCDIR} `${SDL_CONFIG} --cflags`
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=07
WRKSRC= ${WRKDIR}/love-HEAD
diff --git a/devel/love08/Makefile b/devel/love08/Makefile
index 2e3935c566fb..668f436939b4 100644
--- a/devel/love08/Makefile
+++ b/devel/love08/Makefile
@@ -30,7 +30,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
-I${LUA_INCDIR} `${SDL_CONFIG} --cflags`
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=08
WRKSRC= ${WRKDIR}/love-${PORTVERSION}
diff --git a/emulators/fs-uae/Makefile b/emulators/fs-uae/Makefile
index e642d46c8313..3a17aea78a45 100644
--- a/emulators/fs-uae/Makefile
+++ b/emulators/fs-uae/Makefile
@@ -25,11 +25,11 @@ USE_GL= gl
USE_GNOME= glib20
USE_XORG= x11
-LLD_UNSAFE= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CFLAGS+= -Wno-c++11-narrowing
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= DOCS DEBUG
OPTIONS_DEFINE_i386= JIT
diff --git a/emulators/pcem/Makefile b/emulators/pcem/Makefile
index 1334c4ff1b9a..9d25822bb0c2 100644
--- a/emulators/pcem/Makefile
+++ b/emulators/pcem/Makefile
@@ -23,10 +23,4 @@ CONFIGURE_ARGS= --enable-release-build --with-wx-config=wxgtk3u-3.0-config
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= amd64
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
-LDFLAGS+= -fuse-ld=bfd
-.endif
-
.include <bsd.port.mk>
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 274b147d7011..839d9a4451ff 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -44,11 +44,6 @@ CMAKE_ON= CMAKE_SKIP_RPATH USE_SYSTEM_FFMPEG USE_SYSTEM_LIBPNG
CMAKE_OFF= USE_NATIVE_INSTRUCTIONS
LDFLAGS+= -Wl,--as-needed # GLU
-# XXX Drop after FreeBSD 12.0 EOL
-.if exists(/usr/lib/clang/6.0.1)
-LLD_UNSAFE= yes # XXX ports/219089
-.endif
-
# XXX Remove after FreeBSD 11.2/12.0 reach EOL i.e., around 2020-02-01
.if make(makesum) || (!exists(/usr/include/c++/v1/charconv) && exists(/usr/lib/libc++.so))
MASTER_SITES+= https://releases.llvm.org/${LLVM_VER}/:libcxx
diff --git a/games/OpenTomb/Makefile b/games/OpenTomb/Makefile
index a0b97b5fbae0..f82e5397695a 100644
--- a/games/OpenTomb/Makefile
+++ b/games/OpenTomb/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libpng.so:graphics/png
USES= cmake:insource compiler:c++11-lang lua openal sdl
USE_GITHUB= yes
USE_SDL= sdl2
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
SUB_FILES= OpenTomb
post-patch:
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 1bdf13d862c0..5978ff259b3e 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -29,7 +29,7 @@ USE_CXXSTD= c++98
CONFIGURE_ARGS= --datadir=${DATADIR} --enable-editor=no
CPPFLAGS+= -isystem${LUA_INCDIR}
LDFLAGS+= -L${LUA_LIBDIR}
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/apricots/Makefile b/games/apricots/Makefile
index d5ba793c6582..b3fe18134a1d 100644
--- a/games/apricots/Makefile
+++ b/games/apricots/Makefile
@@ -21,7 +21,7 @@ PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME}
PORTDATA= *
PORTDOCS= *
CPPFLAGS+= -DAP_PATH="\"${DATADIR}/\""
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
DESKTOP_ENTRIES="Apricots" \
"${COMMENT}" \
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index 875dfe2ae60b..6bac6d7cd73a 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -42,11 +42,6 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/aquaria
PORTDATA= *
-# XXX Drop after FreeBSD 12.0 EOL
-.if exists(/usr/lib/clang/6.0.1)
-LLD_UNSAFE= yes # XXX ports/219089
-.endif
-
DESKTOP_ENTRIES="${GH_PROJECT}" \
"" \
"${DATADIR}/${PORTNAME}.png" \
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index fedcd7f137f4..ce5b47e9d6bc 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -20,10 +20,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/foreach.hpp:devel/boost-libs
USES= cmake compiler:c++11-lang gl openal sdl tar:xz
USE_SDL= sdl
USE_GL= gl glew
-LLD_UNSAFE= yes
CMAKE_ARGS= -DDATA_DIR=arx \
-DSTRICT_USE=ON \
-DBUILD_CRASHREPORTER=OFF
+LDFLAGS_i386= -Wl,-znotext
SUB_FILES= pkg-message
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 8b1febcdbb4b..fcf093a330a6 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -24,7 +24,7 @@ LICENSE_PERMS_CUBE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_OTHER= dist-mirror pkg-mirror auto-accept
USES= gmake tar:bzip2
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
WRKSRC= ${WRKDIR}/AssaultCube_v${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/source/src
SUB_FILES= ${PLIST_FILES:Mbin/*:T}
diff --git a/games/astromenace/Makefile b/games/astromenace/Makefile
index 8f0f420646cb..89a920115018 100644
--- a/games/astromenace/Makefile
+++ b/games/astromenace/Makefile
@@ -29,7 +29,7 @@ DOS2UNIX_FILES= CMakeLists.txt src/config/config.cpp
USE_GL= gl glu
USE_SDL= sdl2
CMAKE_ARGS= -DDATADIR="${DATADIR}"
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
PORTDATA= *
PORTDOCS= *
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index fa6f8482d2f2..32687c7a1313 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= OPENAL
OPTIONS_DEFAULT=OPENAL
diff --git a/games/avp/Makefile b/games/avp/Makefile
index 3af3425e14d4..53da2654027a 100644
--- a/games/avp/Makefile
+++ b/games/avp/Makefile
@@ -17,7 +17,8 @@ USES= cmake compiler:c++11-lang gl openal sdl
USE_GL= gl
USE_SDL= sdl
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
+
PLIST_FILES= bin/${PORTNAME}
do-install:
diff --git a/games/barony/Makefile b/games/barony/Makefile
index aef3ccfc5487..f82f3be7b034 100644
--- a/games/barony/Makefile
+++ b/games/barony/Makefile
@@ -28,7 +28,7 @@ CMAKE_ON= OPENAL_ENABLED DATA_DIR
CMAKE_ARGS= -DEDITOR_EXE_NAME:STRING="barony-editor"
DOS2UNIX_FILES= src/menu.cpp
LDFLAGS+= -Wl,--as-needed
-LLD_UNSAFE= yes # cf. PR 226980
+LDFLAGS_i386= -Wl,-znotext
SUB_FILES= pkg-message
diff --git a/games/blackshadeselite/Makefile b/games/blackshadeselite/Makefile
index ee441289d5e1..6e674c143e53 100644
--- a/games/blackshadeselite/Makefile
+++ b/games/blackshadeselite/Makefile
@@ -21,9 +21,8 @@ USE_CXXSTD= c++98
USE_SDL= sdl
USE_GL= gl glu
-LLD_UNSAFE= yes
-
MAKE_ARGS= CC="${CC}" CXX="${CXX}"
+LDFLAGS_i386= -Wl,-znotext
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index d67dcecb68ff..173da8a5f40d 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -26,8 +26,8 @@ CONFIGURE_ARGS= --disable-sdl \
--disable-ftgl \
--disable-glut \
--disable-glpng
-LLD_UNSAFE= yes
MAKE_ARGS= LDFLAGS="${LDFLAGS}"
+LDFLAGS_i386= -Wl,-znotext
INSTALLS_ICONS= yes
diff --git a/games/colobot/Makefile b/games/colobot/Makefile
index 1e6217c77d44..6bfadb6957b4 100644
--- a/games/colobot/Makefile
+++ b/games/colobot/Makefile
@@ -35,7 +35,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_TUPLE= colobot:colobot-data:c467bd9:data
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
post-extract:
@${MV} ${WRKDIR}/colobot-data-c467bd9/* ${WRKSRC}/data
diff --git a/games/dhewm3/Makefile b/games/dhewm3/Makefile
index 57948d17a17e..608a5a21b0bf 100644
--- a/games/dhewm3/Makefile
+++ b/games/dhewm3/Makefile
@@ -21,7 +21,8 @@ GH_ACCOUNT= dhewm
USES= cmake compiler:c++11-lang jpeg openal:al sdl
USE_SDL= sdl2
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
WRKSRC_SUBDIR= neo
diff --git a/games/diaspora/Makefile b/games/diaspora/Makefile
index 7b24b2a9dc8e..49295d499f29 100644
--- a/games/diaspora/Makefile
+++ b/games/diaspora/Makefile
@@ -39,7 +39,8 @@ USE_CXXSTD= gnu++98
USE_GL= gl glu
USE_SDL= sdl
GNU_CONFIGURE= yes
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
WRKDIR_DIASPORA=${WRKDIR}/Diaspora_R1_Linux/Diaspora
WRKSRC= ${WRKDIR_DIASPORA}/fs2_open
diff --git a/games/el/Makefile b/games/el/Makefile
index 11ab6f407528..cb68f505a1b3 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -25,7 +25,7 @@ USE_GITHUB= yes
GH_ACCOUNT= raduprv
GH_PROJECT= Eternal-Lands
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lX11
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
ALL_TARGET= el.bin
MAKEFILE= Makefile.bsd
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
index b10b8e29da7a..ea3b988c7127 100644
--- a/games/endless-sky/Makefile
+++ b/games/endless-sky/Makefile
@@ -22,7 +22,8 @@ USES= compiler:c++11-lang gl gnome jpeg localbase:ldflags openal scons sdl xorg
USE_SDL= sdl2
USE_GL= gl glew
INSTALLS_ICONS= yes
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
PORTDATA= *
diff --git a/games/excido/Makefile b/games/excido/Makefile
index 225f9db1ee74..fe140edc3487 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -22,7 +22,7 @@ USES= compiler:c++11-lang gl gmake openal:al,alut sdl tar:bzip2
USE_GL= gl glu
USE_SDL= image sdl ttf
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= DOCS
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index d37e6ba6cff8..102dcd1a95c9 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -34,14 +34,13 @@ USES= alias cmake:noninja compiler:c++11-lang cpe dos2unix gl jpeg \
USE_XORG= ice sm x11 xext xft xi xinerama xmu xt
USE_GL= gl glew glu glut
-LLD_UNSAFE= yes
-
DOS2UNIX_REGEX= .*\.(c|h|cxx|cpp|hxx|hpp)
CMAKE_ARGS+= -DSYSTEM_SQLITE:BOOL=ON \
-DFG_DATA_DIR:PATH=${LOCALBASE}/share/${PORTNAME} \
-DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man \
-DFGCOM_DATA_PATH:PATH=${DATADIR}
LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= DBUS QT5
OPTIONS_DEFAULT= DBUS QT5
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index 17d0a4b5ce73..f874dc327ccf 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -21,7 +21,6 @@ USES= compiler:c++14-lang gettext-runtime gettext-tools gmake gnome \
USE_CXXSTD= c++14
USE_GNOME= gdkpixbuf2 gtkmm30
-LLD_UNSAFE= yes
MAKE_ENV= OS="${OPSYS}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
OPTIONS_DEFINE= DOCS NETWORK OPENAL
@@ -35,6 +34,8 @@ OPENAL_USES= openal:al,alut
OPENAL_MAKE_ENV= INCLUDE_SOUND_ALUT="$$(pkg-config --cflags freealut)" \
LIBS_SOUND_ALUT="$$(pkg-config --libs freealut)" \
USE_SOUND=true USE_SOUND_ALUT=true
+OPENAL_LDFLAGS= ${_OPENAL_LDFLAGS_${ARCH}}
+_OPENAL_LDFLAGS_i386= -Wl,-znotext
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/games/freeminer/Makefile b/games/freeminer/Makefile
index c59c7d5b5b18..6917ae142762 100644
--- a/games/freeminer/Makefile
+++ b/games/freeminer/Makefile
@@ -18,10 +18,10 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3
USE_GITHUB= yes
USES= compiler:c++11-lib cmake
-LLD_UNSAFE= yes
CMAKE_ARGS= -DCUSTOM_MANDIR="${PREFIX}/man" \
-DCUSTOM_EXAMPLE_CONF_DIR="${PREFIX}/etc" \
-DRUN_IN_PLACE=0
+LDFLAGS_i386= -Wl,-znotext
PORTDATA= *
PORTDOCS= *
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
index b852ca214f48..33e599f6fb0e 100644
--- a/games/freeorion/Makefile
+++ b/games/freeorion/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
USE_GITHUB= yes
USES= cmake compiler:c++14-lang python:2.7
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= ChangeLog.md README.md
PORTDATA= *
diff --git a/games/fs2open/Makefile b/games/fs2open/Makefile
index baab1fae5e52..85b40287eb8d 100644
--- a/games/fs2open/Makefile
+++ b/games/fs2open/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libpng.so:graphics/png
USES= cmake compiler:c++11-lang lua:51 jpeg openal pkgconfig sdl
-LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= scp-fs2open
GH_PROJECT= fs2open.github.com
@@ -28,6 +27,8 @@ USE_SDL= sdl2
CMAKE_OFF= ENABLE_COTIRE
CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_Doxygen
+LDFLAGS_i386= -Wl,-znotext
+
PLIST_FILES= bin/fs2_open
do-install:
diff --git a/games/glest/Makefile b/games/glest/Makefile
index dc594022dbe8..4e5711e42be2 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -23,9 +23,9 @@ USES= autoreconf:build compiler:c++11-lang dos2unix gl localbase \
USE_SDL= sdl
USE_GL= gl glu
USE_XORG= x11
-LLD_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= mk/linux/configure
+LDFLAGS_i386= -Wl,-znotext
SUB_FILES= glest-wrapper pkg-message
JAM_CMD= ${LOCALBASE}/bin/jam -q -a -dx
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 31bec865021e..f57c25abe015 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -53,7 +53,7 @@ MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
TOOLS_CC="${CC}" \
USE_LOCAL_HEADERS=0
ALL_TARGET= release
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
LIBDIR= lib/${PORTNAME}${PKGNAMESUFFIX}
DOCSDIR= share/doc/${PORTNAME}${PKGNAMESUFFIX}
diff --git a/games/iortcw/Makefile b/games/iortcw/Makefile
index 9bd537a67a69..a479ba27160c 100644
--- a/games/iortcw/Makefile
+++ b/games/iortcw/Makefile
@@ -29,8 +29,7 @@ WOLFDIR= "libexec/${PORTNAME}"
MAKE_ARGS= BINDIR="${STAGEDIR}${PREFIX}/bin" \
COPYDIR="${STAGEDIR}${PREFIX}/${WOLFDIR}"
-# cf. PR 226980
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
PLIST_SUB= ARCH="${ARCH}" \
WOLFDIR="${WOLFDIR}"
diff --git a/games/irrlamb/Makefile b/games/irrlamb/Makefile
index 5a3990412177..32fcbc7604ea 100644
--- a/games/irrlamb/Makefile
+++ b/games/irrlamb/Makefile
@@ -24,7 +24,8 @@ USE_GITHUB= yes
GH_ACCOUNT= jazztickets
USES= cmake compiler:c++11-lib lua:53 openal
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= *
PORTDATA= *
diff --git a/games/keeperrl/Makefile b/games/keeperrl/Makefile
index 468b64768d36..a2dee6b06a59 100644
--- a/games/keeperrl/Makefile
+++ b/games/keeperrl/Makefile
@@ -29,12 +29,13 @@ USE_SDL= sdl2 image2
ALPHA_VERSION= 23
LIBS+= -lexecinfo
-LLD_UNSAFE= yes
MAKE_ARGS= DATA_DIR="${DATADIR}" GCC="${CXX}" \
LDFLAGS="${LDFLAGS}" RELEASE=true
# USE_GCC adds -Wl,-rpath=${_GCC_RUNTIME} which breaks -x c++-header
MAKE_ARGS+= PCH= PCHINC=
+LDFLAGS_i386= -Wl,-znotext
+
DESKTOP_ENTRIES="KeeperRL" "" "" "keeper" \
"Game;Simulation;" false
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index e8c2ebf08093..a476ba93e089 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -15,9 +15,10 @@ COMMENT= Navigate a mech through a 3D world and fire at enemies
USES= compiler:c++11-lang gl gmake openal:al,alut sdl
USE_GL= gl glu
USE_SDL= sdl
-LLD_UNSAFE= yes
USE_CXXSTD= gnu++98
+LDFLAGS_i386= -Wl,-znotext
+
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
diff --git a/games/lugaru/Makefile b/games/lugaru/Makefile
index efe02c9e3c2e..1971c205ce33 100644
--- a/games/lugaru/Makefile
+++ b/games/lugaru/Makefile
@@ -22,7 +22,8 @@ USES= cmake compiler:c++11-lang gl jpeg openal:soft pkgconfig sdl tar:bzip2 xor
USE_GL= gl glu
USE_SDL= sdl
USE_XORG= sm
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= README
OPTIONS_DEFINE= DOCS
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index b3a095244d63..0b24cac6b9df 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -35,9 +35,9 @@ USE_GL= glew gl glu
USE_SDL= sdl2
USE_XORG= sm ice x11 xext
USE_CXXSTD= c++11
-LLD_UNSAFE= yes
LDFLAGS+= -lssl -lcrypto
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= EDITOR DOCS VIEWER
OPTIONS_SUB= yes
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index b7020cfb67ad..530bab429f18 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -18,10 +18,11 @@ USE_GITHUB= yes
GH_ACCOUNT= minetest
USES= cmake compiler:c11 iconv:wchar_t
-LLD_UNSAFE= yes
CMAKE_ARGS= -DCUSTOM_MANDIR="${PREFIX}/man" \
-DCUSTOM_EXAMPLE_CONF_DIR="${PREFIX}/etc"
+LDFLAGS_i386= -Wl,-znotext
+
PORTDATA= *
PORTDOCS= *
diff --git a/games/naev/Makefile b/games/naev/Makefile
index c09aeec6a6f8..1876356c9933 100644
--- a/games/naev/Makefile
+++ b/games/naev/Makefile
@@ -54,7 +54,6 @@ LUA_JIT_DESC= Use LuaJIT from lang/luajit
LUA_JIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
OPENAL_USES= openal
OPENAL_CONFIGURE_WITH= openal
-OPENAL_VARS= LLD_UNSAFE=yes # cf. PR 226980
SDL_MIXER_DESC= SDL_mixer sound backend
SDL_MIXER_CONFIGURE_WITH= sdlmixer
SDL2_DESC= Use SDL2 instead of SDL
diff --git a/games/openclonk/Makefile b/games/openclonk/Makefile
index 293836b23e00..d0c0577edb9b 100644
--- a/games/openclonk/Makefile
+++ b/games/openclonk/Makefile
@@ -35,7 +35,7 @@ USE_SDL= sdl2
USE_XORG= x11 xpm
INSTALLS_ICONS= yes
CMAKE_ARGS= -DAudio_TK:STRING="OpenAL"
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
post-patch:
@${REINPLACE_CMD} -e 's|DESTINATION games|DESTINATION bin|' \
diff --git a/games/openomf/Makefile b/games/openomf/Makefile
index e834c3fe978a..c7a51d1608f4 100644
--- a/games/openomf/Makefile
+++ b/games/openomf/Makefile
@@ -27,7 +27,8 @@ GH_TUPLE= omf2097:libShadowDive:b2c34a6:shadow \
USES= cmake:insource compiler:c++11-lang gettext openal sdl
USE_SDL= sdl2
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
DESKTOP_ENTRIES="OpenOMF" "" \
"${PREFIX}/share/openomf/openomf_icon.png " \
diff --git a/games/opensurge/Makefile b/games/opensurge/Makefile
index ea24e5923bd0..e680d5fee7c9 100644
--- a/games/opensurge/Makefile
+++ b/games/opensurge/Makefile
@@ -40,7 +40,8 @@ SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Open Surge" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
INSTALLS_ICONS= yes
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
SVN_REV= 765
MODS_VER= 20140321
diff --git a/games/regoth/Makefile b/games/regoth/Makefile
index 4e6d1ca21c93..99a59843bfcc 100644
--- a/games/regoth/Makefile
+++ b/games/regoth/Makefile
@@ -35,9 +35,8 @@ GH_TUPLE= ataulien:bgfx-cmake:9a9b596:bgfxcmake/lib/bgfx-cmake \
USE_XORG= ice sm x11 xcursor xext xinerama xrandr
USE_GL= gl glu
-# OpenAL https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219089
-LLD_UNSAFE= yes
CMAKE_ARGS+= -DREGOTH_BUILD_WITH_SYSTEM_OPENAL:BOOL=YES
+LDFLAGS_i386= -Wl,-znotext
post-extract:
${MV} ${WRKSRC_bgfx}/* ${WRKSRC}/lib/bgfx-cmake/bgfx
diff --git a/games/retroarch/Makefile b/games/retroarch/Makefile
index 4caee97460d7..c73264e852e5 100644
--- a/games/retroarch/Makefile
+++ b/games/retroarch/Makefile
@@ -57,6 +57,7 @@ FBO_CONFIGURE_ENABLE= fbo
CFLAGS+= -pthread
LDFLAGS+= -pthread
+LDFLAGS_i386= -Wl,-znotext
CONFIGURE_ARGS+=--enable-threads
CONFIGURE_ENV+= MAN_DIR=${MANPREFIX}/man
@@ -67,7 +68,6 @@ SUB_FILES= pkg-message
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--global-config-dir=${LOCALBASE}/etc
USE_XORG= x11 xcb xext xinerama xv xxf86vm
-LLD_UNSAFE= yes
SHEBANG_FILES= libretro-common/glsym/glgen.py libretro-common/glsym/rglgen.py tools/cg2glsl.py tools/vulkan_loader_generator.py
post-patch:
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 21e53098fc1e..292a65afd967 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -31,12 +31,12 @@ USE_WX= 2.8
WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR}
-LLD_UNSAFE= yes
DOS2UNIX_GLOB= *.h *.cpp
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS_i386= -Wl,-znotext
SCORCH_VERSION= 43.3d
SCORCH_REVISION= # none
diff --git a/games/spacezero/Makefile b/games/spacezero/Makefile
index 6a42f83821d5..cd644912b93f 100644
--- a/games/spacezero/Makefile
+++ b/games/spacezero/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
USES= openal:al,alut gnome pkgconfig xorg
USE_GNOME= gtk20
USE_XORG= x11
-LLD_UNSAFE= yes
MAKE_ARGS= DATADIR="${DATADIR}" \
INSTALL_DATA_DIR="${DATADIR}"
ALL_TARGET= ${PORTNAME}
@@ -25,6 +24,7 @@ ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}
LDFLAGS+= -lX11
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= *
PORTDATA= *
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 3009d5046da5..561bf8b46748 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -30,7 +30,6 @@ USE_SDL= sdl2
USE_GL= gl glu glew
USE_XORG= x11 xcursor
USE_LDCONFIG= yes
-LLD_UNSAFE= yes
DOS2UNIX_GLOB= *.h *.hpp *.cpp
USES= cmake:insource compiler:c++11-lib dos2unix gl openal:al sdl \
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index 8a2dd49db62d..55e74229bec1 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -22,7 +22,6 @@ USES= cmake compiler:c++11-lib pkgconfig tar:bzip2
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}" \
-DENABLE_DEBUG_REPORT=FALSE
USE_WX= 2.8+
-LLD_UNSAFE= yes
PORTDOCS= *
diff --git a/games/stuntrally/Makefile b/games/stuntrally/Makefile
index 6c98dcabc485..e5e2eba3c7be 100644
--- a/games/stuntrally/Makefile
+++ b/games/stuntrally/Makefile
@@ -22,7 +22,8 @@ USE_CXXSTD= gnu++11
DOS2UNIX_FILES= source/ogre/BaseApp_Create.cpp
CMAKE_ARGS= -DSHARE_INSTALL="${DATADIR_REL}" \
-DBULLET_ROOT="${LOCALBASE}"
-LLD_UNSAFE= yes
+
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= Readme.txt
PORTDATA= *
diff --git a/games/supertux2/Makefile b/games/supertux2/Makefile
index 33315a4dbe29..3fed24ee73f6 100644
--- a/games/supertux2/Makefile
+++ b/games/supertux2/Makefile
@@ -28,7 +28,7 @@ USE_SDL= sdl2 image2 ttf2
CMAKE_ARGS= -DINSTALL_SUBDIR_BIN=bin \
-DBUILD_SHARED_LIBS=off
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
DOS2UNIX_FILES= external/squirrel/CMakeLists.txt \
external/squirrel/squirrel/sqvm.cpp
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index a52cf4c194f1..cdc3625ba6ac 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -30,7 +30,6 @@ USES= alias cmake compiler:c++11-lib gettext gl \
USE_GL= gl glu glew
USE_SDL= sdl
USE_XORG= x11 xrandr
-LLD_UNSAFE= yes
CMAKE_OFF= USE_WIIUSE BUILD_RECORDER \
USE_SYSTEM_ENET USE_SYSTEM_SQUISH
CMAKE_ON= USE_SYSTEM_GLEW
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index 9785c16b4014..8afcb70ac835 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -26,7 +26,6 @@ USE_GL= gl glu
USE_CSTD= gnu89
SUB_FILES= tome4
-LLD_UNSAFE= yes
MAKE_JOBS_UNSAFE= yes
DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
@@ -35,6 +34,7 @@ DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
PLIST_SUB= PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/t-engine4-src-${DISTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH="" CC=${CC} CXX=${CXX}
+LDFLAGS_i386= -Wl,-znotext
.include <bsd.port.pre.mk>
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
index 384ff378257f..9e90a807a0d8 100644
--- a/games/trigger-rally/Makefile
+++ b/games/trigger-rally/Makefile
@@ -23,7 +23,7 @@ USE_SDL= image2
USE_GL= glu glew
MAKEFILE= GNUmakefile
ALL_TARGET= build
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
INSTALLS_ICONS= yes
WRKSRC_SUBDIR= src
diff --git a/games/ultimatestunts/Makefile b/games/ultimatestunts/Makefile
index 545b65cea342..b654a5df1bdd 100644
--- a/games/ultimatestunts/Makefile
+++ b/games/ultimatestunts/Makefile
@@ -25,10 +25,6 @@ USE_SDL= sdl image
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openal
MAKE_JOBS_UNSAFE= yes
-# XXX Drop after FreeBSD 12.0 EOL
-.if exists(/usr/lib/clang/6.0.1)
-LLD_UNSAFE= yes
-.endif
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index 8199a599b376..5495062b5925 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -31,7 +31,7 @@ USE_SDL= sdl2 image2 ttf2
USE_GL= gl glu glew
USE_XORG= x11 xext sm ice
INSTALLS_ICONS= yes
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
PORTDOCS= *
PORTDATA= *
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index fccb1b7a0e9f..eb19ce8512a3 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -29,10 +29,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_lib_freeglut_glutGetModifiers=no \
--disable-unit-tests
USE_LDCONFIG= yes
-LLD_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LDFLAGS_i386= -Wl,-znotext
INFO= vamos
PORTDOCS= *
diff --git a/graphics/magnum-examples/Makefile b/graphics/magnum-examples/Makefile
index 245e2d0ba3d8..962a549c3ac5 100644
--- a/graphics/magnum-examples/Makefile
+++ b/graphics/magnum-examples/Makefile
@@ -26,8 +26,7 @@ USE_SDL= sdl2
USE_XORG= ice sm x11 xext
LDFLAGS+= -lGL # only missing for one example
-# for openal cf. PR 226980
-LLD_UNSAFE= yes
+LDFLAGS_i386= -Wl,-znotext
CMAKE_ARGS= -DLIB_SUFFIX:STRING=""
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 50528500b6a9..d53b653c718a 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -28,7 +28,8 @@ OPTIONS_DEFINE= FREEALUT GLEW
FREEALUT_DESC= Enable freealut support
FREEALUT_CONFIGURE_ENABLE= sound
FREEALUT_USES= openal:alut
-FREEALUT_VARS= LLD_UNSAFE=yes # cf. PR 226980
+FREEALUT_LDFLAGS= ${_FREEALUT_LDFLAGS_${ARCH}}
+_FREEALUT_LDFLAGS_i386= -Wl,-znotext
GLEW_DESC= Enable GLEW support
GLEW_USE= GL=glew
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index 2058f4934e80..aa26f0fd1c7e 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -104,7 +104,8 @@ MANPAGES_CONFIGURE_OFF= --disable-manpage
OPENAL_CONFIGURE_ENABLE= openal
OPENAL_USES= openal
-OPENAL_VARS= LLD_UNSAFE=yes # cf. PR 226980
+OPENAL_LDFLAGS= ${_OPENAL_LDFLAGS_${ARCH}}
+_OPENAL_LDFLAGS_i386= -Wl,-znotext
OPENGL_USES= gl
OPENGL_USE= GL=egl,gbm,gl
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index 7e816751f1ea..5e465b44b9aa 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -41,9 +41,9 @@ PYTHON_MAKE_ARGS= ENABLE_PYTHON=1
CFLAGS+= -I${NCURSESINC}
LDFLAGS+= -L${NCURSESLIB}
+LDFLAGS_i386= -Wl,-znotext
MAKE_ENV= USER_CFLAGS="${CFLAGS}" USER_LDFLAGS="${LDFLAGS}" \
MANDIR="${MANPREFIX}/man"
-LLD_UNSAFE= yes
SUB_FILES= pkg-message
post-patch-PYTHON-on: