aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/octave-forge-ltfat/Makefile3
-rw-r--r--math/octave-forge-ltfat/files/patch-inst_nonstatgab_nsdgt.m13
2 files changed, 14 insertions, 2 deletions
diff --git a/math/octave-forge-ltfat/Makefile b/math/octave-forge-ltfat/Makefile
index 0d12f09075a0..a96eed29dd05 100644
--- a/math/octave-forge-ltfat/Makefile
+++ b/math/octave-forge-ltfat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge-ltfat
PORTVERSION= 2.3.1
-PORTREVISION= 9
+PORTREVISION= 10
PORTEPOCH= 1
CATEGORIES= math
@@ -13,7 +13,6 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
-BROKEN= does not install properly with octave-6.2.0
BROKEN_FreeBSD_12_powerpc64= fails to compile: modules/libltfat/src/dgt_multi.c:47:31: 'cexpl' undeclared (first use in this function); did you mean 'cexpf'?
LIB_DEPENDS= libfftw3.so:math/fftw3 \
diff --git a/math/octave-forge-ltfat/files/patch-inst_nonstatgab_nsdgt.m b/math/octave-forge-ltfat/files/patch-inst_nonstatgab_nsdgt.m
new file mode 100644
index 000000000000..95f07f6698f0
--- /dev/null
+++ b/math/octave-forge-ltfat/files/patch-inst_nonstatgab_nsdgt.m
@@ -0,0 +1,13 @@
+--- ../inst/nonstatgab/nsdgt.m.orig 2021-02-21 22:07:54.880669000 -0600
++++ ../inst/nonstatgab/nsdgt.m 2021-02-21 22:08:12.573573000 -0600
+@@ -149,8 +149,8 @@
+ col = ceil(Lg/M(ii));
+
+ temp = zeros(col*M(ii),W,assert_classname(f,g{1}));
+- temp([end-floor(Lg/2)+1:end,1:ceil(Lg/2)],:) = bsxfun(@ ...
+- times,f(win_range,:),g{ii}(idx));
++ temp([end-floor(Lg/2)+1:end,1:ceil(Lg/2)],:) = bsxfun(@times, ...
++ f(win_range,:),g{ii}(idx));
+
+ temp = reshape(temp,M(ii),col,W);
+ X = squeeze(fft(sum(temp,2)));