aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--shells/bash-devel/Makefile6
-rw-r--r--shells/bash/Makefile5
2 files changed, 7 insertions, 4 deletions
diff --git a/shells/bash-devel/Makefile b/shells/bash-devel/Makefile
index 79bfe1053a2d..037e95050791 100644
--- a/shells/bash-devel/Makefile
+++ b/shells/bash-devel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 45
PORTVERSION= 4.2.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= shells
MASTER_SITES= GNU
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -82,7 +82,9 @@ CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= YACC="bison -y"
+CONFIGURE_ENV= YACC="bison -y" \
+ bash_cv_dev_fd=absent
+
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index bb5d1910efbf..1139334bd2e2 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 45
PORTVERSION= 4.2.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/:faq
@@ -91,7 +91,8 @@ CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= YACC="bison -y"
+CONFIGURE_ENV= YACC="bison -y" \
+ bash_cv_dev_fd=absent
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1