aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/otrs/Makefile8
-rw-r--r--devel/p5-Log-Dispatch/Makefile1
-rw-r--r--devel/pushmi/Makefile4
-rw-r--r--mail/p5-qpsmtpd/Makefile2
-rw-r--r--net-mgmt/netdisco/Makefile3
-rw-r--r--net/p5-Apache2-SOAP/Makefile1
-rw-r--r--www/libapreq2/Makefile1
-rw-r--r--www/p5-Apache-AuthCookie/Makefile1
-rw-r--r--www/p5-Apache-AuthTicket/Makefile14
-rw-r--r--www/p5-Apache-Clean2/Makefile2
-rw-r--r--www/p5-Apache-DB/Makefile4
-rw-r--r--www/p5-Apache-GopherHandler/Makefile1
-rw-r--r--www/p5-Apache-MP3/Makefile1
-rw-r--r--www/p5-Apache-ParseFormData/Makefile1
-rw-r--r--www/p5-Apache-Test/Makefile12
-rw-r--r--www/p5-Apache2-Scoreboard/Makefile4
-rw-r--r--www/p5-Bundle-Sledge/Makefile4
-rw-r--r--www/p5-MasonX-WebApp/Makefile12
-rw-r--r--www/p5-Maypole/Makefile25
-rw-r--r--www/p5-libapreq/Makefile2
-rw-r--r--www/rt36/Makefile2
21 files changed, 68 insertions, 37 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index d9892413d094..58ce71f656f4 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= otrs
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
@@ -34,7 +35,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Pcalc.pm:${PORTSDIR}/devel/p5-Date
p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
p5-CSS-Minifier-XS>=0:${PORTSDIR}/textproc/p5-CSS-Minifier-XS \
p5-JavaScript-Minifier-XS>=0:${PORTSDIR}/textproc/p5-JavaScript-Minifier-XS \
- p5-Apache-Reload>=0:${PORTSDIR}/www/p5-Apache-Reload \
${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
${SITE_PERL}/XML/FeedPP.pm:${PORTSDIR}/textproc/p5-XML-FeedPP
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -88,8 +88,10 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
USE_PGSQL= yes
.endif
-.if ${APACHE_VERSION} > 13
-RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=2.0.0:${PORTSDIR}/www/mod_perl2
+.if ${APACHE_VERSION} == 13
+BUILD_DEPENDS+= p5-Apache-Reload>=0:${PORTSDIR}/www/p5-Apache-Reload
+.else
+RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=2.0.5:${PORTSDIR}/www/mod_perl2
.endif
.ifdef WITH_REPORTS_MODULES
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index 5b94b930d44f..4d6e68c4deb6 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Log-Dispatch
PORTVERSION= 2.29
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/devel/pushmi/Makefile b/devel/pushmi/Makefile
index 7715058404b1..ff11277ed365 100644
--- a/devel/pushmi/Makefile
+++ b/devel/pushmi/Makefile
@@ -7,10 +7,10 @@
PORTNAME= pushmi
PORTVERSION= 1.0.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
+MASTER_SITE_SUBDIR= CPAN:CLKAO
DISTNAME= Pushmi-v${PORTVERSION}
MAINTAINER= rafan@FreeBSD.org
diff --git a/mail/p5-qpsmtpd/Makefile b/mail/p5-qpsmtpd/Makefile
index 1480d69546f6..676187dbc20c 100644
--- a/mail/p5-qpsmtpd/Makefile
+++ b/mail/p5-qpsmtpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qpsmtpd
PORTVERSION= 0.84
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail perl5
MASTER_SITES= http://smtpd.develooper.com/files/
PKGNAMEPREFIX= p5-
diff --git a/net-mgmt/netdisco/Makefile b/net-mgmt/netdisco/Makefile
index 3e2fd03f5229..00661aada1e9 100644
--- a/net-mgmt/netdisco/Makefile
+++ b/net-mgmt/netdisco/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netdisco
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net-mgmt www
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}_with_mibs
@@ -21,7 +22,6 @@ RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
${SITE_PERL}/Net/NBName.pm:${PORTSDIR}/net/p5-Net-NBName \
${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
- ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test \
${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MasonX/Request/WithApacheSession.pm:${PORTSDIR}/www/p5-MasonX-Request-WithApacheSession
@@ -70,6 +70,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
.else
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test \
${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI-mp1
.endif
diff --git a/net/p5-Apache2-SOAP/Makefile b/net/p5-Apache2-SOAP/Makefile
index c38f888d3568..8ba81ee62096 100644
--- a/net/p5-Apache2-SOAP/Makefile
+++ b/net/p5-Apache2-SOAP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache2-SOAP
PORTVERSION= 0.73
+PORTREVISION= 1
CATEGORIES= net www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index 3321e7f6084c..7c6e84c646f4 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libapreq2
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
diff --git a/www/p5-Apache-AuthCookie/Makefile b/www/p5-Apache-AuthCookie/Makefile
index 705dff734a98..422d832b47b7 100644
--- a/www/p5-Apache-AuthCookie/Makefile
+++ b/www/p5-Apache-AuthCookie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-AuthCookie
PORTVERSION= 3.15
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/p5-Apache-AuthTicket/Makefile b/www/p5-Apache-AuthTicket/Makefile
index 52b6fec319a2..27ef5551f16e 100644
--- a/www/p5-Apache-AuthTicket/Makefile
+++ b/www/p5-Apache-AuthTicket/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-AuthTicket
PORTVERSION= 0.90
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,9 +17,8 @@ COMMENT= Perl modules that implement a cookie-based authentication system
RUN_DEPENDS= ${SITE_PERL}/Apache/AuthCookie.pm:${PORTSDIR}/www/p5-Apache-AuthCookie \
${SITE_PERL}/SQL/Abstract.pm:${PORTSDIR}/databases/p5-SQL-Abstract \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
-BUILD_DEPENDS= ${RUN_DEPENDS}
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -27,12 +27,14 @@ MAN3= Apache::AuthTicket.3 Apache2::AuthTicket.3
USE_APACHE= 1.3+
.include <bsd.port.pre.mk>
-.if ${APACHE_VERSION} > 20
+.if ${APACHE_VERSION} > 13
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Clean2/Makefile b/www/p5-Apache-Clean2/Makefile
index 33a7c8da4111..d637053a7bea 100644
--- a/www/p5-Apache-Clean2/Makefile
+++ b/www/p5-Apache-Clean2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Apache-Clean
PORTVERSION= 2.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Apache/GEOFF
diff --git a/www/p5-Apache-DB/Makefile b/www/p5-Apache-DB/Makefile
index 3d8d84f94ec3..21d1da1acda2 100644
--- a/www/p5-Apache-DB/Makefile
+++ b/www/p5-Apache-DB/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-DB
PORTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,13 +18,14 @@ COMMENT= Debugging and profiling tools for mod_perl
MAKE_JOBS_SAFE= yes
PERL_CONFIGURE= yes
+USE_APACHE_RUN= 13+
MAN3= Apache::DB.3 Apache::DProf.3 Apache::perl5db.3 \
Apache::SmallProf.3
.include <bsd.port.pre.mk>
-.if defined(WITH_MODPERL2)
+.if defined(WITH_MODPERL2) || ${APACHE_VERSION} > 13
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
diff --git a/www/p5-Apache-GopherHandler/Makefile b/www/p5-Apache-GopherHandler/Makefile
index 64dde078b5ec..e686214626ea 100644
--- a/www/p5-Apache-GopherHandler/Makefile
+++ b/www/p5-Apache-GopherHandler/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-GopherHandler
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= www net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
index ee14c5ca8a66..f726a864aa15 100644
--- a/www/p5-Apache-MP3/Makefile
+++ b/www/p5-Apache-MP3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-MP3
PORTVERSION= 4.00
+PORTREVISION= 1
CATEGORIES= www audio perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/p5-Apache-ParseFormData/Makefile b/www/p5-Apache-ParseFormData/Makefile
index 29ac93092d12..5367c35cb0e7 100644
--- a/www/p5-Apache-ParseFormData/Makefile
+++ b/www/p5-Apache-ParseFormData/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-ParseFormData
PORTVERSION= 0.09
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/p5-Apache-Test/Makefile b/www/p5-Apache-Test/Makefile
index 0a6f9d8dbc1e..701fd637ab31 100644
--- a/www/p5-Apache-Test/Makefile
+++ b/www/p5-Apache-Test/Makefile
@@ -8,7 +8,8 @@
PORTNAME= Apache-Test
PORTVERSION= 1.36
CATEGORIES= www perl5
-MASTER_SITES= CPAN/../../authors/id/P/PH/PHRED
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PHRED
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
@@ -17,11 +18,10 @@ COMMENT= Test.pm wrapper with helpers for testing Apache
MAKE_JOBS_SAFE= yes
PERL_CONFIGURE= yes
USE_APACHE= 1.3+
+.include <bsd.port.pre.mk>
-## XXX: Need to fix this, www/mod_perl2 currently @2.0.4 contains A-T 1.29,
-## XXX: but
-## XXX: A-T has released 1.32
-.if defined(WITH_MODPERL2)
+## XXX: www/mod_perl2 currently @2.0.5 contains A-T 1.36,
+.if defined(WITH_MODPERL2) || ${APACHE_VERSION} > 13
IGNORE= is already included in mod_perl2
.endif
@@ -40,4 +40,4 @@ MAN3= Apache::Test.3 \
Apache::TestUtil.3 \
Bundle::ApacheTest.3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache2-Scoreboard/Makefile b/www/p5-Apache2-Scoreboard/Makefile
index 64f437e2e35d..b1d7a98940b1 100644
--- a/www/p5-Apache2-Scoreboard/Makefile
+++ b/www/p5-Apache2-Scoreboard/Makefile
@@ -7,8 +7,10 @@
PORTNAME= Apache2-Scoreboard
PORTVERSION= 2.09.2
+PORTREVISION= 1
CATEGORIES= www perl5
-MASTER_SITES= CPAN/../../authors/id/M/MJ/MJH
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MJH
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME:C/2//}-${PORTVERSION}
diff --git a/www/p5-Bundle-Sledge/Makefile b/www/p5-Bundle-Sledge/Makefile
index 3294df49a354..0f4ec264e64c 100644
--- a/www/p5-Bundle-Sledge/Makefile
+++ b/www/p5-Bundle-Sledge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Bundle-Sledge
PORTVERSION= 0.04
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -23,10 +23,10 @@ USE_APACHE= 13+
.if ${APACHE_VERSION} == 13
PM_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+PM_DEPENDS+= ${SITE_PERL}/Apache/Reload.pm:${PORTSDIR}/www/p5-Apache-Reload
.else
PM_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
.endif
-PM_DEPENDS+= ${SITE_PERL}/Apache/Reload.pm:${PORTSDIR}/www/p5-Apache-Reload
PM_DEPENDS+= ${SITE_PERL}/Test/Inline.pm:${PORTSDIR}/devel/p5-Test-Inline
PM_DEPENDS+= ${SITE_PERL}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert
PM_DEPENDS+= ${SITE_PERL}/Class/Fields.pm:${PORTSDIR}/devel/p5-Class-Fields
diff --git a/www/p5-MasonX-WebApp/Makefile b/www/p5-MasonX-WebApp/Makefile
index cd4ee620af9c..86c77526c9d8 100644
--- a/www/p5-MasonX-WebApp/Makefile
+++ b/www/p5-MasonX-WebApp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= MasonX-WebApp
PORTVERSION= 0.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,9 +20,13 @@ RUN_DEPENDS= ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util
-BUILD_DEPENDS= ${RUN_DEPENDS}
-.if defined(WITH_MODPERL2)
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USE_APACHE_RUN= 13+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MODPERL2) || ${APACHE_VERSION} > 13
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
@@ -34,4 +38,4 @@ PERL_MODBUILD= yes
MAN3= MasonX::WebApp.3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index cd8022fd7743..fce5a63deb6c 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -6,7 +6,7 @@
PORTNAME= Maypole
PORTVERSION= 2.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/T/TE/TEEJAY
@@ -36,19 +36,34 @@ BUILD_DEPENDS= p5-CGI-Simple>0:${PORTSDIR}/www/p5-CGI-Simple \
p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
p5-URI>0:${PORTSDIR}/net/p5-URI \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:2.121
MAKE_JOBS_SAFE= yes
OPTIONS= MODPERL "mod_perl support" on \
- MODPERL2 "mod_perl2 support" off
+ MODPERL2 "mod_perl2 support" off
PERL_CONFIGURE= yes
+.include <bsd.port.options.mk>
+
+.if defined(WITH_MODPERL) || defined(WITH_MODPERL2)
+USE_APACHE_RUN= 13+
+.endif
.include <bsd.port.pre.mk>
+.if defined(WITH_MODPERL) && ${APACHE_VERSION} > 13
+IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
+.elif defined(WITH_MODPERL2) && ${APACHE_VERSION} < 20
+IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
+.endif
+
+.if defined(WITH_MODPERL) && defined(WITH_MODPERL2)
+IGNORE= only 1 mod_perl at a time
+.endif
+
.if defined(WITH_MODPERL2)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
.endif
@@ -56,10 +71,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
.endif
-.if defined(WITH_MODPERL) && defined(WITH_MODPERL2)
-IGNORE= only 1 mod_perl at a time
-.endif
-
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES+= pkg-message
diff --git a/www/p5-libapreq/Makefile b/www/p5-libapreq/Makefile
index c4994b6a3664..185096d05512 100644
--- a/www/p5-libapreq/Makefile
+++ b/www/p5-libapreq/Makefile
@@ -28,7 +28,7 @@ USE_APACHE= 13
.include <bsd.port.pre.mk>
-.if ${APACHE_VERSION} > 13 || ${APACHE_PORT} != "www/apache13"
+.if ${APACHE_VERSION} > 13
IGNORE= build only with apache13
.endif
diff --git a/www/rt36/Makefile b/www/rt36/Makefile
index 6c1c587c72a7..fd4775944723 100644
--- a/www/rt36/Makefile
+++ b/www/rt36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rt
PORTVERSION?= 3.6.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
http://download.bestpractical.com/pub/rt/devel/ \